Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1

    HiFiBerry Dac Pro Pi 4B 2GB PiCorePlayer 6.1.0 not playing 24/192 files

    I have searched the forum and found various reports of HiFiBerry Dacs not playing 24/192 files with a pi 4B but I haven't managed to find any post where this problem has been solved. I have seen a post that says 24/192 does work with a Pi 3B and a HiFiBerry Dac.

    I have the same problem of 24/192 files not playing. I have another Pi4B 4GB with an external USB Dac and the 24/192 files that won't play through the HiFiBerry Dac Pro on my pi4B 2GB do play via the external DAC on my other system.

    Is there a solution to this problem?

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,498
    Quote Originally Posted by coyrls View Post
    I have searched the forum and found various reports of HiFiBerry Dacs not playing 24/192 files with a pi 4B but I haven't managed to find any post where this problem has been solved. I have seen a post that says 24/192 does work with a Pi 3B and a HiFiBerry Dac.

    I have the same problem of 24/192 files not playing. I have another Pi4B 4GB with an external USB Dac and the 24/192 files that won't play through the HiFiBerry Dac Pro on my pi4B 2GB do play via the external DAC on my other system.

    Is there a solution to this problem?
    By "not play" - do you mean play but downsampled or when trying to play - no audio starts ?

  3. #3
    Quote Originally Posted by bpa View Post
    By "not play" - do you mean play but downsampled or when trying to play - no audio starts ?
    I mean no audio (silence) but the "Playing" screen (Material View) looks as if the track is playing, i.e. time counter running and the progress line moving.

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,498
    Quote Originally Posted by coyrls View Post
    I mean no audio (silence) but the "Playing" screen (Material View) looks as if the track is playing, i.e. time counter running and the progress line moving.
    Recently there was a problem with similar symptoms playing DXD (325.8KHz) files - the problem turned out to be ALSA paramters - buffers were not big enough ( https://forums.slimdevices.com/showt...es-(DXD)/page2 ) . It has been noticed that this issues happens with other devices/frequencies using ALSA

    It can do no harm trying out enlarged buffer size to see if it helps as in this post
    https://forums.slimdevices.com/showt...l=1#post995100

  5. #5
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,765
    Quote Originally Posted by coyrls View Post
    I mean no audio (silence) but the "Playing" screen (Material View) looks as if the track is playing, i.e. time counter running and the progress line moving.
    What audio output have you selected in Squeezelite ?

    Can you ssh into the pi and run

    Code:
    alsamixer
    then select the dac and check the volume level ?

    ronnie

    and any message in the LMS server log ?

  6. #6
    Quote Originally Posted by Man in a van View Post
    What audio output have you selected in Squeezelite ?
    hw:CARD=sndrpihifiberry

    Quote Originally Posted by Man in a van View Post
    Can you ssh into the pi and run

    Code:
    alsamixer
    then select the dac and check the volume level
    I have set the volume to 86 and alsamixer confirms that setting. Note, the DAC works for all resolutions below 24/192 that I have tested.

    Quote Originally Posted by Man in a van View Post
    ronnie

    and any message in the LMS server log ?
    No, no messages in the LMS server log.

    I will try experimenting with buffer sizes tomorrow.

  7. #7
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,765
    Quote Originally Posted by coyrls View Post
    hw:CARD=sndrpihifiberry


    I have set the volume to 86 and alsamixer confirms that setting. Note, the DAC works for all resolutions below 24/192 that I have tested.



    No, no messages in the LMS server log.

    I will try experimenting with buffer sizes tomorrow.
    Are you on the beta tab (bottom of the pCP web gui)

    try

    Code:
    plughw:CARD=sndrpihifiberry
    In the audio output list, do you have a setting ending in DEV=0 (I'm going from memory here, and a different hifiberry card, but with the same overlay). Expand the red word more to see options

    does 86 in the alsamixer represent 0.0 db?

    I think the preferred way is to set the volume level in alsamixer and then use the web gui to save it (Squeezelite tab, Card Control box, at the top of the page,

    Reboot the pi.

    ronnie

    Edit: I forgot this; Also on LMS web gui Home page, go to Settings > Player > Audio > Volume Control > Output level is fixed at 100%
    Last edited by Man in a van; 2020-11-21 at 14:47.

  8. #8
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,517
    The original Dac Pro should set just fine through the web interface. 100% is 0db. That is where you should start.

    Turn on logging for squeezelite on the squeezelite page. then try to play the file. Then go to Diagnostics|Logs and check out the log. pcp_squeezelite.log.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  9. #9
    Quote Originally Posted by paul- View Post
    The original Dac Pro should set just fine through the web interface. 100% is 0db. That is where you should start.

    Turn on logging for squeezelite on the squeezelite page. then try to play the file. Then go to Diagnostics|Logs and check out the log. pcp_squeezelite.log.
    I started at 100% but reduced to 86% through the web interface, as 100% was too high for my amplifier.

    I will turn logging on and report back.

    Oh, and I already have the output level fixed at 100% for the player.
    Last edited by coyrls; 2020-11-21 at 16:49.

  10. #10
    I have set logging at info level, is that OK?

    Here is the ouptut from playing the first 30 seconds or so:

    Code:
    [00:04:11.654185] stream_thread:247 headers: len: 541
    HTTP/1.1 200 OK
    Content-Type: audio/flac
    Content-Length: 322760001
    Connection: close
    Accept-Ranges: bytes
    Access-Control-Allow-Origin: *
    Access-Control-Expose-Headers: Content-Length, Accept-Ranges, Content-Range
    Cache-Control: public, max-age=86400
    Date: Sun, 22 Nov 2020 00:04:11 GMT
    ETag: dMjPsV5n7eb/Mp7rF6dzVQ==
    Server: nginx
    X-Cache: Miss from cloudfront
    Via: 1.1 f9dabb7450b8978c710eac50c8933749.cloudfront.net (CloudFront)
    X-Amz-Cf-Pop: LHR62-C2
    X-Amz-Cf-Id: zpDRCoWWhlf42JMK0Z9CuXP7hSp89C9OXkImhhw8sF8UNPBjH0QNmg==
    
    
    [00:04:11.766905] write_cb:128 setting track_start
    [00:04:11.773255] _output_frames:64 start buffer frames: 27648
    [00:04:11.773330] _output_frames:149 track start sample rate: 192000 replay_gain: 0
    [00:04:11.783379] output_thread:687 open output device: hw:CARD=sndrpihifiberry
    [00:04:11.787374] alsa_open:351 opening device at: 192000
    [00:04:11.789589] alsa_open:422 opened device hw:CARD=sndrpihifiberry using format: S32_LE sample rate: 192000 mmap: 1
    [00:04:11.789668] alsa_open:513 buffer: 80 period: 4 -> buffer size: 15360 period size: 3840
    [00:04:33.502192] decode_flush:237 decode flush
    [00:04:33.502278] output_flush:435 flush output buffer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •