Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Senior Member jth's Avatar
    Join Date
    Apr 2005
    Location
    Phoenix, AZ, USA
    Posts
    380
    Unfortunately I have only been able to reproduce it the one time having tried multiple scenarios, and I did not have plugin debugging turned on. chaug - did you notice this happening during specific occasions - like first time after restarting the radio or the server. I see you are using local media and not Internet radio. Was the stop occurring on every new play of a playlist?

  2. #12
    Senior Member chaug's Avatar
    Join Date
    Jun 2011
    Posts
    103
    I am not 100% sure whether the problem occurred every single day. But if there were times when it didn't occur, those where rare.

    Our usage pattern for the Radio is very simple: it is almost exclusively used to play music to help my daughter fall asleep. For a long time, this meant playing one specific track over and over again. And nothing else. This usage pattern made it difficult to track down the problem because there was no playlist to provide orientation regarding, for example, whether the problem occurs with a specific song or after a specific time.

    Fortunately, a few weeks ago, my daughter finally got tired of that one song and we are now playing a variety of songs. The playlist is usually created by selecting the first song manually and then letting Spicefly SugarCube select the subsequent ones automatically (all stored locally on our server, no streaming from the internet whatsoever).

    The whole point of using the Power Save feature is to turn the music off after a certain amount of time. Basically a sleep timer. We can do that because the Radio is not used for anything else, so its fine that it always turns off after x minutes.

    Not sure if this helps...
    Server: LMS 8.1.1 on an Ubuntu 18.04 virtual machine
    Players: Radio, Touch, Duet (Receiver & Controller), 2 Booms
    Remote control apps: Material Skin (Web UI), but also SqueezePad (iOS), Squeezecontroller (Android)
    Important plugins: Trackstat, Spicefly Sugarcube, Lazy Search Music, Custom Browse, Multi Library

  3. #13
    Senior Member jth's Avatar
    Join Date
    Apr 2005
    Location
    Phoenix, AZ, USA
    Posts
    380
    I believe I've found and corrected the cause of the problem. Over the next week I'm going to be testing some various scenarios to make sure nothing else has broken.

    chaug - would you be comfortable testing this when I am done? It would involve making a backup copy of a Plugin file on your server, copying a new file in its place, restarting the server, and testing your scenario.

    All things considered, I'm a little reluctant to release this publicly into the server plugin auto-update mechanism after 10 years of no changes. My squeezebox usage has dwindled to one Radio and I no longer have the wide assortment of hardware to test changes on like I used to.

  4. #14
    Senior Member chaug's Avatar
    Join Date
    Jun 2011
    Posts
    103
    Sure, if the update can be reversed in case it breaks something, I'd be happy to try it. Apart from the Radio we regularly use a Boom and a Touch, so if it works well for me, chances are that it will worm more broadly. (We also have a Receiver, but that is rarely used.)
    Server: LMS 8.1.1 on an Ubuntu 18.04 virtual machine
    Players: Radio, Touch, Duet (Receiver & Controller), 2 Booms
    Remote control apps: Material Skin (Web UI), but also SqueezePad (iOS), Squeezecontroller (Android)
    Important plugins: Trackstat, Spicefly Sugarcube, Lazy Search Music, Custom Browse, Multi Library

  5. #15
    Senior Member jth's Avatar
    Join Date
    Apr 2005
    Location
    Phoenix, AZ, USA
    Posts
    380
    If you want to try the fix:

    First, make a backup copy of your PowerSave/Plugin.pm file. You can find the plugin path in your server settings -> Information -> Plugin Path. It's usually the first entry.

    Download a copy of the new plugin - https://bitflip.net/slim/plugins/pow...Save-7.4.1.zip

    Unzip the file to a staging area. Copy the Plugin.pm file in the unzipped folder so that it overwrites your original PowerSave/Plugin.pm file. Then restart your slimserver.

    Verify your PowerSave settings and test the Plugin. If you have any problems, restore the original Plugin.pm and restart your slimserver.

  6. #16
    Senior Member jth's Avatar
    Join Date
    Apr 2005
    Location
    Phoenix, AZ, USA
    Posts
    380
    Just to follow up - I did end up pushing version 7.4.1 with the "PowerSave Always" fix out to my repository so you will be able to update via the normal method as well.

  7. #17
    Junior Member
    Join Date
    Mar 2009
    Posts
    18
    Quote Originally Posted by chaug View Post
    Wow, that is fantastic! I wasn't even aware that Power Save is a plugin. Probably because I installed it about 10 years ago and took it for granted after that. I guess that's a good thing. Excellent work! And over all those years, you probably helped save tons of CO2 emissions.
    I have the same problem, sound stops after 15 min. Just a touch of the volume sets it working again. I looked in the settings and somehow the sleep timer was set for 15 min. Took that off will see how it goes. Might be worth a check.

  8. #18
    Junior Member
    Join Date
    Mar 2009
    Posts
    18
    Quote Originally Posted by ians View Post
    I have the same problem, sound stops after 15 min. Just a touch of the volume sets it working again. I looked in the settings and somehow the sleep timer was set for 15 min. Took that off will see how it goes. Might be worth a check.
    My Radio has now been working over 30 mins since I altered the sleep timer. I changed it to 90 minutes as the cancel option appeared to set it back to 15 minutes. Not tried on that but going for 90 minutes option to see if this does clear the issue and it would appear it does. If it stops on 90 minutes as I expect it will, will then try the Cancel option.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •