Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Jul 2020
    Posts
    14

    piCore Player / SAMBA & Windows 10 - Password permission denied

    I have an Rpi3+ all successfully set up with a Allo Boss Dac and a USB HDD with all the music files. ( Sounds great ).
    Even have it also "playing" to two Airport Express, when I want to.

    Trying to get the Windows 10 PC to "see" the files on the USB HDD via SAMBA.
    I have all that set up as per the piCore Player Documentation.
    I can see the drive on my MacBook and successfully enter the user "tc" and the password that I set.

    BUT same does not work on the Windows PC.
    I have SMB check boxes ticked etc etc
    I assume I have the correct path address as I get the the Enter Network Credentials for user and password.
    No matter I enter the saved password - no access " The user name or password is incorrect".
    Yet the same work on the MacBook ?

    Any ideas for the next thing to try ?
    Much appreciated,
    Julian

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,554
    Make sure you set the workgroup to match your windows machine. Windows is very very picky.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Senior Member
    Join Date
    Jan 2010
    Posts
    717
    Quote Originally Posted by paul- View Post
    Make sure you set the workgroup to match your windows machine. Windows is very very picky.
    I do have different workgroup names for pCP's SAMBA and Windows and I'm able to access the files from Windows.
    I vaguely remember I had the same error initially and I think I had to configure something in addition in pCP. Unfortunately I don't remember what this was (and currently I don't have access to the system).

  4. #4
    Junior Member
    Join Date
    Jul 2020
    Posts
    14
    Quote Originally Posted by paul- View Post
    Make sure you set the workgroup to match your windows machine. Windows is very very picky.
    Thanks Paul for the suggestion. I double checked - it's the same workgroup name on both the Picore Samba settings and the Windows PC.
    Still no success.

    At someone else's suggestion I did download WinSCP and that can at least transfer music files from the PC to the Raspberry Pi HDD.

    Take care - for the most part I hugely amazed at how this all works - I am from an era where vinyl records were placed on a gramophone turntable in the pride of place Living Room.

    Julian

  5. #5
    Junior Member
    Join Date
    Jul 2020
    Posts
    14

    Solved for me at least :-)

    Aha

    I solved the problem by changing a registry key. According to another web search dealing with Raspian,
    there is a registry key that controls what mode of authentication and session security to be used for network logons.
    Loaded registry Editor:-

    When down the entries and in -

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa

    Set

    LmCompatibilityLevel

    at least to three (3)

    Rebooted the Windows PC and when I clicked on the network folder it finally accepted my Picore/Samba/"tc" password !

    Hurrah - thanks everyone.
    Julian

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •