Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 46
  1. #21
    Just finished upgrading my squeezelite installation to the 1.9.7-1278 version, and looking at the logs now I can that it's no longer transcoding the opus stream to Flac. So it all seems to be resolved now, thanks everybody for the help & I've learned a few things along the way about LMS as well!

  2. #22
    Rats, so the opus streams are now working, but on a flac stream it's trying to convert to mp3 using lame, but the log is indicating the binary lame couldn't be found. Perhaps anybody knows how I can install this? I can't find a good answer online after searching for a while :S

  3. #23
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,546
    Quote Originally Posted by Hawkeyenl View Post
    Rats, so the opus streams are now working, but on a flac stream it's trying to convert to mp3 using lame, but the log is indicating the binary lame couldn't be found. Perhaps anybody knows how I can install this? I can't find a good answer online after searching for a while :S
    Why is it converting to MP3 ?
    What is the player ?
    Have you got bit rate limiting set ?

  4. #24
    Quote Originally Posted by bpa View Post
    Why is it converting to MP3 ?
    What is the player ?
    Have you got bit rate limiting set ?
    I don't know why it's trying to convert to mp3. I got the same logging when trying to play it on ipeng on my iPhone as when trying to stream it to the squeezelite player I have upgraded. I set the bit rate to 128k, but then I got the following result in the log:

    Code:
    0
    [20-10-27 06:45:44.5300] Slim::Player::StreamingController::playerActive (2013) 01:c6:83:66:f3:f2 player already active: 01:c6:83:66:f3:f2
    [20-10-27 06:45:44.5321] Slim::Player::Squeezebox::reconnect (80) 01:c6:83:66:f3:f2 restaring play on pseudo-reconnect at 0
    [20-10-27 06:45:44.5338] Slim::Player::StreamingController::playerReconnect (2092) 01:c6:83:66:f3:f2
    [20-10-27 06:45:44.5363] Slim::Player::StreamingController::_Stop (610) Song queue is now 0
    [20-10-27 06:45:44.5380] Slim::Player::StreamingController::_setPlayingState (2377) new playing state STOPPED
    [20-10-27 06:45:44.5397] Slim::Player::StreamingController::_setStreamingState (2386) new streaming state IDLE
    [20-10-27 06:45:44.5426] Slim::Player::Squeezebox::reconnect (88) 01:c6:83:66:f3:f2 forcing stop on pseudo-reconnect
    [20-10-27 06:45:47.4102] Slim::Player::StreamingController::play (2120) 01:c6:83:66:f3:f2
    [20-10-27 06:45:47.4129] Slim::Player::StreamingController::_Stop (610) Song queue is now 0
    [20-10-27 06:45:47.4145] Slim::Player::StreamingController::_setPlayingState (2377) new playing state STOPPED
    [20-10-27 06:45:47.4161] Slim::Player::StreamingController::_setStreamingState (2386) new streaming state IDLE
    [20-10-27 06:45:47.4183] Slim::Player::StreamingController::nextsong (889) The next song is number 0, was 0
    [20-10-27 06:45:47.4206] Slim::Player::Song::new (108) index 0 -> youtube://www.youtube.com/v/QK-Z1K67uaA
    [20-10-27 06:45:47.4242] Slim::Player::StreamingController::_setStreamingState (2386) new streaming state TRACKWAIT
    [20-10-27 06:45:47.4279] Slim::Player::StreamingController::_playersMessage (796) Stroominfo wordt opgehaald...: youtube://www.youtube.com/v/QK-Z1K67uaA
    [20-10-27 06:45:47.4390] Slim::Player::Song::getNextSong (230) youtube://www.youtube.com/v/QK-Z1K67uaA
    [20-10-27 06:45:47.4507] Slim::Player::Source::playmode (95) 01:c6:83:66:f3:f2: Current playmode: play
    [20-10-27 06:45:48.6071] Plugins::YouTube::ProtocolHandler::getSignature (731) no player url to unobfuscate signature
    [20-10-27 06:45:48.6090] Slim::Player::StreamingController::_playersMessage (796) Problem: Can't open file for:: youtube://www.youtube.com/v/QK-Z1K67uaA
    [20-10-27 06:45:48.6176] Slim::Player::StreamingController::_setStreamingState (2386) new streaming state IDLE
    [20-10-27 06:45:48.6198] Slim::Player::StreamingController::nextsong (889) The next song is number 0, was 0
    Last edited by Hawkeyenl; 2020-10-26 at 22:47.

  5. #25
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,109
    From LMS web UI - Settings/Player/playername/audio
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  6. #26
    Quote Originally Posted by Hawkeyenl View Post
    I don't know why it's trying to convert to mp3. I got the same logging when trying to play it on ipeng on my iPhone as when trying to stream it to the squeezelite player I have upgraded. I set the bit rate to 128k, but then I got the following result in the log:

    Code:
    0
    [20-10-27 06:45:44.5300] Slim::Player::StreamingController::playerActive (2013) 01:c6:83:66:f3:f2 player already active: 01:c6:83:66:f3:f2
    [20-10-27 06:45:44.5321] Slim::Player::Squeezebox::reconnect (80) 01:c6:83:66:f3:f2 restaring play on pseudo-reconnect at 0
    [20-10-27 06:45:44.5338] Slim::Player::StreamingController::playerReconnect (2092) 01:c6:83:66:f3:f2
    [20-10-27 06:45:44.5363] Slim::Player::StreamingController::_Stop (610) Song queue is now 0
    [20-10-27 06:45:44.5380] Slim::Player::StreamingController::_setPlayingState (2377) new playing state STOPPED
    [20-10-27 06:45:44.5397] Slim::Player::StreamingController::_setStreamingState (2386) new streaming state IDLE
    [20-10-27 06:45:44.5426] Slim::Player::Squeezebox::reconnect (88) 01:c6:83:66:f3:f2 forcing stop on pseudo-reconnect
    [20-10-27 06:45:47.4102] Slim::Player::StreamingController::play (2120) 01:c6:83:66:f3:f2
    [20-10-27 06:45:47.4129] Slim::Player::StreamingController::_Stop (610) Song queue is now 0
    [20-10-27 06:45:47.4145] Slim::Player::StreamingController::_setPlayingState (2377) new playing state STOPPED
    [20-10-27 06:45:47.4161] Slim::Player::StreamingController::_setStreamingState (2386) new streaming state IDLE
    [20-10-27 06:45:47.4183] Slim::Player::StreamingController::nextsong (889) The next song is number 0, was 0
    [20-10-27 06:45:47.4206] Slim::Player::Song::new (108) index 0 -> youtube://www.youtube.com/v/QK-Z1K67uaA
    [20-10-27 06:45:47.4242] Slim::Player::StreamingController::_setStreamingState (2386) new streaming state TRACKWAIT
    [20-10-27 06:45:47.4279] Slim::Player::StreamingController::_playersMessage (796) Stroominfo wordt opgehaald...: youtube://www.youtube.com/v/QK-Z1K67uaA
    [20-10-27 06:45:47.4390] Slim::Player::Song::getNextSong (230) youtube://www.youtube.com/v/QK-Z1K67uaA
    [20-10-27 06:45:47.4507] Slim::Player::Source::playmode (95) 01:c6:83:66:f3:f2: Current playmode: play
    [20-10-27 06:45:48.6071] Plugins::YouTube::ProtocolHandler::getSignature (731) no player url to unobfuscate signature
    [20-10-27 06:45:48.6090] Slim::Player::StreamingController::_playersMessage (796) Problem: Can't open file for:: youtube://www.youtube.com/v/QK-Z1K67uaA
    [20-10-27 06:45:48.6176] Slim::Player::StreamingController::_setStreamingState (2386) new streaming state IDLE
    [20-10-27 06:45:48.6198] Slim::Player::StreamingController::nextsong (889) The next song is number 0, was 0
    I seem to be getting this message for every track I try to play from YouTube now, both on my iPhone (ipeng playback) and my squeezelite installation:
    Plugins::YouTube::ProtocolHandler::getSignature (731) no player url to unobfuscate signature

    I can play music files from my NAS just fine, as well as a radio stream. Youtube was working yesterday evening when I went to bed :/

  7. #27
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,546
    Quote Originally Posted by Hawkeyenl View Post
    I seem to be getting this message for every track I try to play from YouTube now, both on my iPhone (ipeng playback) and my squeezelite installation:
    Plugins::YouTube::ProtocolHandler::getSignature (731) no player url to unobfuscate signature

    I can play music files from my NAS just fine, as well as a radio stream. Youtube was working yesterday evening when I went to bed :/
    IIRC there are some issues about specific Youtube URL with the unobfuscate signature - post Youtube problems on the Youtube thread - you will not get users who know about Youtube problems on this thread with your thread title.

    Don't post about Yotube problem until you have sorted the lame issues. If a player is bitrate limited - then it will be transcoded into MP3. If it cannot be transcoded then you'll get the "Can't open file for " message which in turn may trigger the Youtube error (due to the use of callbacks & event handling etc. the order of messages in log do not always reflect the order of "cause-effect").

    Get bit rate working for the player (e.g test a simple http AAC stream of 128kbps with a bitrate of 32kbs) before attempting to play Youtube or other streams which are complicated to process.

    If you want to do bitrate limiting you need "lame" or an alternative. It may result in a significant/overwhelming load on the NAS in conjunction with streams that need additional processing such as Youtube. (e.g. opus -> flac->mp3)

  8. #28
    Quote Originally Posted by bpa View Post
    IIRC there are some issues about specific Youtube URL with the unobfuscate signature - post Youtube problems on the Youtube thread - you will not get users who know about Youtube problems on this thread with your thread title.

    Don't post about Yotube problem until you have sorted the lame issues. If a player is bitrate limited - then it will be transcoded into MP3. If it cannot be transcoded then you'll get the "Can't open file for " message which in turn may trigger the Youtube error (due to the use of callbacks & event handling etc. the order of messages in log do not always reflect the order of "cause-effect").

    Get bit rate working for the player (e.g test a simple http AAC stream of 128kbps with a bitrate of 32kbs) before attempting to play Youtube or other streams which are complicated to process.

    If you want to do bitrate limiting you need "lame" or an alternative. It may result in a significant/overwhelming load on the NAS in conjunction with streams that need additional processing such as Youtube. (e.g. opus -> flac->mp3)
    Thanks for the reply, I'll see to getting the LAME installation working and try to downgrade the bitrate!

  9. #29
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,546
    Quote Originally Posted by Hawkeyenl View Post
    I don't know why it's trying to convert to mp3. I got the same logging when trying to play it on ipeng on my iPhone as when trying to stream it to the squeezelite player I have upgraded. I set the bit rate to 128k, but then I got the following result in the log:
    Before you go too far with lame (probably post on pinkdot's thread to get an good answer as there are alternatives for low power CPUs/NAS)

    You seem to not to know about MP3 is used for bit rate limited yet knowing how to bit rate limit to 128k

    Can you confirm that the 128k setting is via the menu Paul suggested Settings/Player/Audio and not some other setting in iPeng

    edit:

    After lame is working. It may be better to revisit the use of bitrate limiting and whether it is the best solution. It is a old feature and is a sledgehammer as it will affects all formats to the player. For example, a "better" solution may be to disable ops->flac & ops->wav to the specific player. Lame will still be used but only with opus.
    Last edited by bpa; 2020-10-27 at 02:41.

  10. #30
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,638
    Quote Originally Posted by Hawkeyenl View Post
    Thanks for the reply, I'll see to getting the LAME installation working and try to downgrade the bitrate!
    lame on an arm cpu usually pegs the cpu at 100% usage, if you find the same, then as an alternative you could try shineenc.

    You should be able to extract the tar file into the same folder as your sox binary and lms should find it, you might need to restart lms. The tarball includes the shineenc program and a lame script which just converts the command line options from lms from lame format to shineenc.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •