Home of the Squeezebox™ & Transporter® network music players.
Page 7 of 21 FirstFirst ... 5678917 ... LastLast
Results 61 to 70 of 205
  1. #61
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,546
    Quote Originally Posted by slartibartfast View Post
    I am surprised the Triode version still works for anyone
    I think just the HLS & MP3 live streams still work. IIRC There are still LMS Windows XP users !

  2. #62
    Senior Member
    Join Date
    Aug 2014
    Location
    UK
    Posts
    139

    Version 1.0.0 Released

    I have now "open sourced" this plugin and the project is hosted on a github repository here : https://github.com/expectingtofly/LMS_BBC_Sounds_Plugin
    It is therefore now open to anyone who wants to contribute to improving or adding features to the plugin .

    I have created version 1.0.0 from the latest merge which includes a number of bug fixes since the last beta release. These closed issues are viewable on github here

    Version 1.0.0 is available from the existing beta repository here : http://plugins.expectingtofly.co.uk/betarepo.xml
    Additionally, I have created another repository where version 1.0.0 is also available here : http://plugins.expectingtofly.co.uk/stablerepo.xml

    Going forward, if there are any experimental/less stable features in the future they will go to the beta repository first. So please switch to the stable repository if you prefer a calmer existence.

  3. #63
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,109
    Are you OK with the stable repo going into the list of 3rd-party repos so that all LMS users who have 3rd-party enabled see it listed - i.e. no need for them to add your repo to their list?
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  4. #64
    Senior Member
    Join Date
    Aug 2014
    Location
    UK
    Posts
    139
    Quote Originally Posted by Paul Webster View Post
    Are you OK with the stable repo going into the list of 3rd-party repos so that all LMS users who have 3rd-party enabled see it listed - i.e. no need for them to add your repo to their list?
    Yes, sure. Is there a submission process I need to follow to do that?

    (Also, I guess there is a dependency on the bpa's version of the BBC Iplayer plugin also being in the 3rd party repos )
    Last edited by expectingtofly; 2020-10-26 at 15:01.

  5. #65
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,546
    Quote Originally Posted by expectingtofly View Post
    Yes, sure. Is there a submission process I need to follow to do that?

    (Also, I guess there is a dependency on the bpa's version of the BBC Iplayer plugin also being in the 3rd party repos )
    The community repository doesn't validate anything or check xml - it just means users do not have to add the personal repo url to LMS plugins tab.

    1. To add - all you need to is ask. ( new github https://github.com/LMS-Community/lms-plugin-repository )
    2. The location of the BBCiPlayer repo should be irrelevant to your repo. Users just needs to know that BBCiPlayer plugin myustr be installed. If you want to be helpful to end users, you could include a check in BBC Sounds plugin to see if BBCiPlayer plugin is installed (e.g. check if iplayer is amongst registered handlers) and if not make a log entry saying "cant find BBCiPlayer plugin".
    Last edited by bpa; 2020-10-26 at 15:30.

  6. #66
    Senior Member
    Join Date
    Aug 2014
    Location
    UK
    Posts
    139
    Quote Originally Posted by bpa View Post
    The community repository doesn't validate anything or check xml - it just means users do not have to add the personal repo url to LMS plugins tab.

    1. To add - all you need to is ask.
    Ok, thanks, I'll try and find out where I need to ask. [Edit], ah, I see you have pointed me in the right direction in your edit. thanks.

    Quote Originally Posted by bpa View Post
    2. The location of the BBCiPlayer repo should be irrelevant to your repo. Users just needs to know that BBCiPlayer plugin myustr be installed.
    Yes, I realise that, but I thought I read earlier in this thread that there is an older version of the Iplayer plugin in the official repos and that your version isn't in the community repo's, thus creating confusion?
    Last edited by expectingtofly; 2020-10-26 at 15:35.

  7. #67
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,546
    Quote Originally Posted by expectingtofly View Post
    Yes, I realise that, but I thought I read earlier in this thread that there is an older version of the Iplayer plugin in the official repos and that your version isn't in the community repo's, thus creating confusion?
    Possibly but we can deal with it and hopefully soon Triode plugin will be a non-issue.
    The log entry would at least point user in the right direction - you can add BBCiPlayer required min version in log entry.
    You could even add a note to your Sounds plugin requirement that "BBCiPlayer plugin must be installed and able to play 'Listen Again' " . but there is a limit to hand holding.

  8. #68
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,109
    I think the idea is that only LMS8 sees the new github repo list - and this one would not have Triode's BBC iPlayer plugin listed.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  9. #69
    Senior Member
    Join Date
    Aug 2014
    Location
    UK
    Posts
    139
    Quote Originally Posted by Paul Webster View Post
    I think the idea is that only LMS8 sees the new github repo list - and this one would not have Triode's BBC iPlayer plugin listed.
    Ok, thanks, that's clear now.

  10. #70
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,476

    Announce : BBC Sounds Plugin

    > I think the idea is that only LMS8 sees the new github repo list - and
    > this one would not have Triode's BBC iPlayer plugin listed.


    LMS 7.9 should be using the new repository, too. I've created re-directs
    to point them to the new version.

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •