Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1

    LMS now seems to see some folders as playlists

    Hi, I hope this is the right area for posting this.

    I have my music stored on a NAS and use piCorePlayer with Squeezelite and LMS for playback and use the Squeezer app on my android phone as a remote.

    While I was using the Squeezer app to go back and forth through the folders on my NAS to try out different albums to test out my new DAC, I was suddenly unable to open a folder that I was perfectly able to open just moments before. It is a folder containing several other folders, each folder containing a separate album with individual tracks. Instead of just opening the (artist) folder to reveal the separate (album) folders inside (so I can select the one I want), LMS now creates a playlist containing all the tracks in all the album folders that are inside the main artist folder and starts playing it. Thus, I can't go into the artist folder anymore and select an album folder, as I was able to do just moments before. I now have several folders that exhibit this behavior. All of them are folders I had browsed through just moments before. When I went and looked in the LMS web gui browser, I saw that exactly the folders that exhibit this behavior have had their folder icon replaced with the icon of a music note. (I suppose LMS now sees these folders as playlists?)

    Name:  LMS error.jpg
Views: 132
Size:  86.7 KB

    These folders themselves are perfectly accessible from outside LMS btw, like through windows explorer.

    I remember, while playing an album, in Squeezer, tapping the playlist icon bottom right and then tapping the "delete playlist" icon left of the search icon (I was exploring the app's functionality) and that after that, LMS now seems to see that folder as a playlist instead of a folder.

    Sorry for the somewhat confusing story and maybe this is something incredibly benign, but I really hope someone can help me in having LMS see these folders as folders again instead of playlists.

    Thanks in advance!

    Cheers.

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,925
    Quote Originally Posted by LaszloFolgerts View Post
    Hi, I hope this is the right area for posting this.

    I have my music stored on a NAS and use piCorePlayer with Squeezelite and LMS for playback and use the Squeezer app on my android phone as a remote.

    While I was using the Squeezer app to go back and forth through the folders on my NAS to try out different albums to test out my new DAC, I was suddenly unable to open a folder that I was perfectly able to open just moments before. It is a folder containing several other folders, each folder containing a separate album with individual tracks. Instead of just opening the (artist) folder to reveal the separate (album) folders inside (so I can select the one I want), LMS now creates a playlist containing all the tracks in all the album folders that are inside the main artist folder and starts playing it. Thus, I can't go into the artist folder anymore and select an album folder, as I was able to do just moments before. I now have several folders that exhibit this behavior. All of them are folders I had browsed through just moments before. When I went and looked in the LMS web gui browser, I saw that exactly the folders that exhibit this behavior have had their folder icon replaced with the icon of a music note. (I suppose LMS now sees these folders as playlists?)

    Name:  LMS error.jpg
Views: 132
Size:  86.7 KB

    These folders themselves are perfectly accessible from outside LMS btw, like through windows explorer.

    I remember, while playing an album, in Squeezer, tapping the playlist icon bottom right and then tapping the "delete playlist" icon left of the search icon (I was exploring the app's functionality) and that after that, LMS now seems to see that folder as a playlist instead of a folder.

    Sorry for the somewhat confusing story and maybe this is something incredibly benign, but I really hope someone can help me in having LMS see these folders as folders again instead of playlists.

    Thanks in advance!

    Cheers.
    But that picture doesn't look like the Squeezer app, it looks more like Material.

    EDIT: Sorry, I now see that your picture is from the LMS web gui.
    Last edited by kidstypike; 2020-09-29 at 14:15. Reason: confusion
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.1.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 6.1.0/pi screen/Allo Boss DAC Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Squeezebox Radio

    Spares - 2xTouch, 1xSB3, 7xRPi

  3. #3
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,925
    You may get more and better response if you post this in the Material thread, it has little to do with LINUX/Unix.

    https://forums.slimdevices.com/showt...l=1#post990107
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.1.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 6.1.0/pi screen/Allo Boss DAC Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Squeezebox Radio

    Spares - 2xTouch, 1xSB3, 7xRPi

  4. #4
    I don't think it's got anything to do with Material Skin; when I revert back to the default LMS skin, this is what it shows me when I click on a folder:

    Instead of showing the two folders inside I get this:

    Name:  LMS error standard skin.jpg
Views: 85
Size:  118.0 KB

  5. #5
    Ok I created a new post in the 3rd party section, mods can close or remove this one if necessary.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    LMS now seems to see some folders asplaylists

    Would a scan succeed scanning those folders? Could there be a
    permissions problem?

    And as always: anything in server.log or scanner.log?

    --

    Michael

  7. #7
    I'm too new to piCorePlayer to be able to answer those questions.

    In the end I removed LMS from picoreplayer, deleted its cache and then re-installed it. The folders that weren't, seem to be accessible again, so all seems to be normal again.

  8. #8
    How do you navigate your music collection? Are you selecting folders then tracks through the Music Folder view, or browsing via the music files' tags as presented after a scan (e.g. the Albums view)?

    Robert
    Home: Raspberry Pi 3/pCP6.1.0/LMS8.0.0/Material with files on QNAP TS-251A
    Touch > DacMagic 100 > Naim Audio Nait 3 > Mission 752 (plus Rega Planar 3 > Rega Fono Mini; Naim CD3)
    2 x Squeezebox Radios, 1 X Squeezebox 3 (retired), spare Pi2/piCorePlayer
    Office: LMS8.0.0 running on Raspberry Pi3; Raspberry Pi 3 player with touchscreen/piCorePlayer/IQaudIO DAC and Amp
    Portable: Raspberry Pi Zero/pCP6.1.0/LMS8.0.0/Material, files on Seagate portable drive, powered via power brick

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •