Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Aug 2020
    Posts
    1

    LMS 8 in Docker + Tidal

    Hi all,

    I have been strugling a lot with getting LMS 8 to work with Tidal.
    My LMS was running as a Docker container using the image from apnar
    (apnar/logitech-media-server)

    I kept getting the following error
    Slim::Player::Song:pen (409) Error: Couldn't create command line for mp4 playback for


    It turned out, that the latest published docker image (digest version: 21b8a388cb02ee4b50096cfc13249becd1f7a4afb85b075458 4df331725ae6ac) contained LMS 8.0.0 version 1594451286.

    I found a comment on the forum, stating that I would need a more recent version (15987...something) for AAC playback to work.
    After rebuilding the Docker image with the latest nightly LMS8.0, I could again get Tidal to start playing. Hooray!

    This was the version I rebuild the Docker image with: 1600604030

    I had to modify the docker image a little bit to be able to rebuild
    Pull Request created on github.com / apnar / docker-image-logitech-media-server

  2. #2
    Senior Member
    Join Date
    Oct 2013
    Posts
    122
    Good to read that the problem is solved.
    I was wondering how this image differs from the Doliana images from this thread:
    https://forums.slimdevices.com/showt...for-LMS/page17

    Big differences? Is it worth combining our scarce resources in developing and optimizing a docker LMS image?

    Also this thread better belongs in the Linux/Unix section of this forum I think.
    Living Room: HifiBerry DAC+ Pro & piCorePlayer
    Attic: HifiBerry DAC+ RCA & piCorePlayer
    Kitchen: SB Radio
    Other rooms: 4x SB Radio

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •