Home of the Squeezebox™ & Transporter® network music players.
Page 10 of 10 FirstFirst ... 8910
Results 91 to 98 of 98
  1. #91
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    536
    Quote Originally Posted by mherger View Post
    > (I just posted this in the other Spotty thread and now I wonder if that
    > may have been the wrong placeÔÇöso I'm posting here, too.) ... I'm using
    > Spotty on my two Classics. I have several playlists in Spotify, and I
    > want to play them in shuffle mode. I can't see a way to do that, either
    > with my remote and a Classic, or with iPeng and a Classic. I suspect I'm
    > missing something obvious, but I'd be grateful if someone can point me
    > in the right direction. I really don't want to hear my playlists in the
    > order I saved them originally!


    Once you started playing them, just turn on Shuffle mode in LMS. That
    should work with any list of tracks, no matter where they come from. But
    you cannot "Play Shuffled", like Spotify has a button to do.

    --

    Michael
    Michael, thanks. So I was indeed missing something obvious! I'd been hunting every which where in Spotty with the suspicion that there must be something as useful as a shuffle setting somewhere. It didn't occur to look "outside", as it were, in LMS. Now I know. I still yearn for a place where all these things could be looked up. You know, like an old fashioned (and much missed) manual. But at least we have this forum, which is a goldmine, and helpful guides like yourself. Thank you, once again.

  2. #92
    Junior Member
    Join Date
    Jun 2020
    Posts
    12
    Quote Originally Posted by mherger View Post
    > I run a pc anyway to host a plex server which also hosts my LMS media.

    That might actually be the reason why Spotty can't use local
    announcements: they conflict with Plex.

    > Regarding the local announcements failing and only the last used devices
    > being visible. At least in my situation, I dont think that is the issue.


    It is.

    --

    Michael
    Dear Michael,

    I took the plunge and moved LMS to one of my Raspberry Pi zero devices.
    Since i wanted my audio tracks to continue to be hosted on my PC i added a Network mount to my pi zero and configured LMS to access the shared music folder on my windows PC. It is slow in scanning the remotely hosted files over wifi/LAN but it works!

    My family account spotify issue also is resolved with this setup!!

    I was skeptical that the pi zero would be usable as a LMS server but it is working fine.

    Thank you!

    Regards
    Sanjay

  3. #93
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    [Announce] Spotty 4.4 - morepersonalised content

    > Since i wanted my audio tracks to continue to be hosted on my PC i added
    > a Network mount to my pi zero and configured LMS to access the shared
    > music folder on my windows PC. It is slow in scanning the remotely
    > hosted files over wifi/LAN but it works!


    Great! (except for the speed)

    > I was skeptical that the pi zero would be usable as a LMS server but it
    > is working fine.


    The Zero certainly isn't the best model to use in this case :-). Running
    LMS on a Pi3B+ connecting over ethernet is much faster than running on
    the NAS itself (ReadyNAS Duo v2).

    --

    Michael

  4. #94
    doesn't work(

    every song skips after a few seconds, not usable

  5. #95
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,133
    Quote Originally Posted by fominator View Post
    doesn't work(

    every song skips after a few seconds, not usable
    Something has definitely happened. My Spotty menu is empty.

    Sent from my Pixel 3a using Tapatalk

  6. #96
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,133
    Quote Originally Posted by slartibartfast View Post
    Something has definitely happened. My Spotty menu is empty.

    Sent from my Pixel 3a using Tapatalk
    I am getting lots of these errors in the server log
    Code:
    [20-10-22 19:51:30.6468] Plugins::Spotty::AccountHelper::getCredentials (299) Failed to read credentials file, or credentials file was empty
    [20-10-22 19:51:30.6488] Plugins::Spotty::AccountHelper::getCredentials (299) Failed to read credentials file, or credentials file was empty
    [20-10-22 19:51:30.6503] Slim::Networking::IO::Select::__ANON__ (130) Error: Select task failed calling Slim::Web::HTTP::processHTTP: Can't use string ("2") as a HASH ref while "strict refs" in use at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/API.pm line 156.

  7. #97
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,133
    Quote Originally Posted by fominator View Post
    doesn't work(

    every song skips after a few seconds, not usable
    Have you tried deleting your account and reauthorising? That seems to have fixed my issues.

    Sent from my Pixel 3a using Tapatalk

  8. #98
    Quote Originally Posted by slartibartfast View Post
    Have you tried deleting your account and reauthorising? That seems to have fixed my issues.

    Sent from my Pixel 3a using Tapatalk
    You mean on settings page? Yes, didn't fix the issue!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •