Home of the Squeezebox™ & Transporter® network music players.
Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 79
  1. #31
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,504

    Scan taking hours instead ofminutes on recent nightlies

    Who's willing to share his library.db with me?

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    --

    Michael

  2. #32
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,186
    Quote Originally Posted by mherger View Post
    Who's willing to share his library.db with me?

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6al
    Done.

    Please note, I've not had this issue up to the last week or so.
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.0/pi screen/Hifiberry DAC HAT Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Pi3B/Bluetooth/Echo Show 8

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  3. #33
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,504

    Scan taking hours instead ofminutes on recent nightlies

    > Please note, I've not had this issue up to the last week or so.

    That's because the playlist indexing was broken before that. Broken as
    in not working at all. Now it's broken as in "too slow under certain
    circumstances"...

    Thanks for the file. I'll look into it.

    --

    Michael

  4. #34
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,504

    Scan taking hours instead ofminutes on recent nightlies

    > Please note, I've not had this issue up to the last week or so.

    Would there be anything in server.log? Could you please run a FTS
    enabled scan with logging for scan enabled?

    And please share a library.db with the FTS enabled with me.

    From what I can see your playlists don't look crazy large. LMS should
    be able to handle these with FTS. When it crashed, was the scanner still
    busy (taking a very long time to finish) using the CPU? Or did it exit
    prematurely?

    --

    Michael

  5. #35
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,186
    Quote Originally Posted by mherger View Post
    > Please note, I've not had this issue up to the last week or so.

    Would there be anything in server.log? Could you please run a FTS
    enabled scan with logging for scan enabled?

    And please share a library.db with the FTS enabled with me.

    From what I can see your playlists don't look crazy large. LMS should
    be able to handle these with FTS. When it crashed, was the scanner still
    busy (taking a very long time to finish) using the CPU? Or did it exit
    prematurely?l
    Scanner was busy, or at least the time was still incrementing as in the pic below (taken from a previous non-terminating scan).

    Which of these scan items should I enable?

    Name:  scanner.jpg
Views: 64
Size:  15.5 KB

    Name:  scan01.jpg
Views: 63
Size:  113.5 KB
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.0/pi screen/Hifiberry DAC HAT Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Pi3B/Bluetooth/Echo Show 8

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  6. #36
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,186
    Quote Originally Posted by mherger View Post
    > Please note, I've not had this issue up to the last week or so.

    Would there be anything in server.log? Could you please run a FTS
    enabled scan with logging for scan enabled?

    And please share a library.db with the FTS enabled with me.

    From what I can see your playlists don't look crazy large. LMS should
    be able to handle these with FTS. When it crashed, was the scanner still
    busy (taking a very long time to finish) using the CPU? Or did it exit
    prematurely?

    I enabled logging for (scan) - All scan logging, was prompted to restart LMS.

    Enabled FST (which I'd disabled last night), prompted to restart LMS, I now can't get into LMS settings to start a scan, or to view progress if already started.

    According to pCP webgui LMS is running but I just get "This site can't be reached" for LMS or it's settings.

    Restarted LMS a couple of times from the pCP ui, rebooted the Pi, still can't get into LMS or it's settings.

    I've pulled the plug on the Pi.
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.0/pi screen/Hifiberry DAC HAT Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Pi3B/Bluetooth/Echo Show 8

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  7. #37
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,504

    Scan taking hours instead ofminutes on recent nightlies

    > Restarted LMS a couple of times from the pCP ui, rebooted the Pi, still
    > can't get into LMS or it's settings.


    As always: check the server.log. It might give you a hint. Eg. LMS might
    be trying to re-build the FTS as it didn't get created in the previous scan.

    --

    Michael

  8. #38
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,186
    Quote Originally Posted by mherger View Post
    > Restarted LMS a couple of times from the pCP ui, rebooted the Pi, still
    > can't get into LMS or it's settings.


    As always: check the server.log. It might give you a hint. Eg. LMS might
    be trying to re-build the FTS as it didn't get created in the previous scan.

    --

    Michael
    How do I get to the server log?
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.0/pi screen/Hifiberry DAC HAT Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Pi3B/Bluetooth/Echo Show 8

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  9. #39
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,186
    OK, found it I think using SCP. This is all I see.

    [CODE[20-09-23 12:37:54.1236] main::init (388) Starting Logitech Media Server (v8.0.0, 1600604030, Sun Sep 20 14:55:17 CEST 2020) perl 5.028000 - arm-linux-gnueabihf-thread-multi-64int[20-09-23 12:37:56.7072] Plugins::LazySearch2::Plugin::initPlugin (852) Initialising v3.6.6 (trunk-7.x)
    [20-09-23 12:37:57.0181] Slim::Plugin::FullTextSearch::Plugin::_initPopular Terms (560) Fulltext index missing or outdated - re-building
    [20-09-23 12:37:57.0185] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (442) Starting fulltext index build
    [20-09-23 12:37:57.0187] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (446) Initialize fulltext table
    [20-09-23 12:37:59.7831] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (459) Create fulltext index for tracks
    [20-09-23 12:38:30.5912] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (469) Create fulltext index for albums
    [20-09-23 12:38:40.0181] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (478) Create fulltext index for contributors
    [20-09-23 12:38:40.4496] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (488) Create fulltext index for playlists][/CODE]
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.0/pi screen/Hifiberry DAC HAT Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Pi3B/Bluetooth/Echo Show 8

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  10. #40
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,186
    Try again

    Code:
    [20-09-23 12:37:54.1236] main::init (388) Starting Logitech Media Server (v8.0.0, 1600604030, Sun Sep 20 14:55:17 CEST 2020) perl 5.028000 - arm-linux-gnueabihf-thread-multi-64int[20-09-23 12:37:56.7072] Plugins::LazySearch2::Plugin::initPlugin (852) Initialising v3.6.6 (trunk-7.x)
    [20-09-23 12:37:57.0181] Slim::Plugin::FullTextSearch::Plugin::_initPopularTerms (560) Fulltext index missing or outdated - re-building
    [20-09-23 12:37:57.0185] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (442) Starting fulltext index build
    [20-09-23 12:37:57.0187] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (446) Initialize fulltext table
    [20-09-23 12:37:59.7831] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (459) Create fulltext index for tracks
    [20-09-23 12:38:30.5912] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (469) Create fulltext index for albums
    [20-09-23 12:38:40.0181] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (478) Create fulltext index for contributors
    [20-09-23 12:38:40.4496] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (488) Create fulltext index for playlists
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.0/pi screen/Hifiberry DAC HAT Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Pi3B/Bluetooth/Echo Show 8

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •