Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Senior Member Browny's Avatar
    Join Date
    Nov 2005
    Location
    Suffolk, UK
    Posts
    187

    Latest Nightly RPM refusing to start

    Afternoon all,

    I've switched over to running LMS8 and it's been running well for me.

    As it was prompting for an update I downloaded the latest rpm (logitechmediaserver-8.0.0-0.1.1599249040.noarch.rpm) and installed as usual using rpm, but service fails to start once installed with the following:

    Code:
    Ô squeezeboxserver.service - LSB: Startup script for the Logitech Media Server
       Loaded: loaded (/etc/rc.d/init.d/squeezeboxserver; bad; vendor preset: disabled)
       Active: failed (Result: exit-code) since Sat 2020-09-05 16:59:44 BST; 23s ago
         Docs: man:systemd-sysv-generator(8)
      Process: 17883 ExecStop=/etc/rc.d/init.d/squeezeboxserver stop (code=exited, status=0/SUCCESS)
      Process: 18036 ExecStart=/etc/rc.d/init.d/squeezeboxserver start (code=exited, status=1/FAILURE)
    
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: BEGIN failed--compilation aborted at /usr/lib64/perl5/Slim/Buttons/XMLBrowser.pm line 27.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: Compilation failed in require at /usr/lib64/perl5/Slim/Buttons/Common.pm line 43.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: BEGIN failed--compilation aborted at /usr/lib64/perl5/Slim/Buttons/Common.pm line 43.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: Compilation failed in require at /usr/libexec/squeezeboxserver line 235.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: BEGIN failed--compilation aborted at /usr/libexec/squeezeboxserver line 235.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: [FAILED]
    Sep 05 16:59:44 xxx systemd[1]: squeezeboxserver.service: control process exited, code=exited status=1
    Sep 05 16:59:44 xxx systemd[1]: Failed to start LSB: Startup script for the Logitech Media Server.
    Sep 05 16:59:44 xxx systemd[1]: Unit squeezeboxserver.service entered failed state.
    Sep 05 16:59:44 xxx systemd[1]: squeezeboxserver.service failed.
    Reverting back to a previous version (logitechmediaserver-8.0.0-0.1.1598791476.noarch.rpm) is working fine so something new is breaking on my system.

    Details of my system as follows:

    perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux-thread-multi
    OS - ClearOS (Centos based) 7.7.2 (Final)

    Happy to test if needed or will stay on the older version for while!

    Thanks
    Browny

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,125
    Quote Originally Posted by Browny View Post
    Afternoon all,

    I've switched over to running LMS8 and it's been running well for me.

    As it was prompting for an update I downloaded the latest rpm (logitechmediaserver-8.0.0-0.1.1599249040.noarch.rpm) and installed as usual using rpm, but service fails to start once installed with the following:

    Code:
    Ô squeezeboxserver.service - LSB: Startup script for the Logitech Media Server
       Loaded: loaded (/etc/rc.d/init.d/squeezeboxserver; bad; vendor preset: disabled)
       Active: failed (Result: exit-code) since Sat 2020-09-05 16:59:44 BST; 23s ago
         Docs: man:systemd-sysv-generator(8)
      Process: 17883 ExecStop=/etc/rc.d/init.d/squeezeboxserver stop (code=exited, status=0/SUCCESS)
      Process: 18036 ExecStart=/etc/rc.d/init.d/squeezeboxserver start (code=exited, status=1/FAILURE)
    
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: BEGIN failed--compilation aborted at /usr/lib64/perl5/Slim/Buttons/XMLBrowser.pm line 27.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: Compilation failed in require at /usr/lib64/perl5/Slim/Buttons/Common.pm line 43.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: BEGIN failed--compilation aborted at /usr/lib64/perl5/Slim/Buttons/Common.pm line 43.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: Compilation failed in require at /usr/libexec/squeezeboxserver line 235.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: BEGIN failed--compilation aborted at /usr/libexec/squeezeboxserver line 235.
    Sep 05 16:59:44 xxx squeezeboxserver[18036]: [FAILED]
    Sep 05 16:59:44 xxx systemd[1]: squeezeboxserver.service: control process exited, code=exited status=1
    Sep 05 16:59:44 xxx systemd[1]: Failed to start LSB: Startup script for the Logitech Media Server.
    Sep 05 16:59:44 xxx systemd[1]: Unit squeezeboxserver.service entered failed state.
    Sep 05 16:59:44 xxx systemd[1]: squeezeboxserver.service failed.
    Reverting back to a previous version (logitechmediaserver-8.0.0-0.1.1598791476.noarch.rpm) is working fine so something new is breaking on my system.

    Details of my system as follows:

    perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux-thread-multi
    OS - ClearOS (Centos based) 7.7.2 (Final)

    Happy to test if needed or will stay on the older version for while!

    Thanks
    Browny
    Already discussed in this thread
    https://r.tapatalk.com/shareLink/top...ink_source=app
    Try updating again, the change has been reverted.

    Sent from my Pixel 3a using Tapatalk

  3. #3
    Senior Member Browny's Avatar
    Join Date
    Nov 2005
    Location
    Suffolk, UK
    Posts
    187
    Suspected I wouldn't be alone, but clearly searched in the wrong place....thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •