Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Senior Member
    Join Date
    Jun 2010
    Location
    California, USA
    Posts
    213

    piCore Unable to Install LMS Nightly Versions

    I think there is some changes in the lms-update.sh script. It is now not able install LMS 7.9.4 or 8.0.0 since they are nightly versions only.

    Checking version for release status...Not a release version

    Downloading update from http://downloads.slimdevices.com/Log...9.4-noCPAN.tgz
    Connecting to downloads.slimdevices.com (13.227.77.120:80)
    wget: server returned error: HTTP/1.1 404 Not Found
    Download FAILED...... exiting!

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,353
    Hmm, let me check. To be clear. Can you get me the info from the LMS settings/information page.

    And are you using the web interface to select Nightly Update, or doing something manually
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Senior Member
    Join Date
    Jun 2010
    Location
    California, USA
    Posts
    213
    Quote Originally Posted by paul- View Post
    Hmm, let me check. To be clear. Can you get me the info from the LMS settings/information page.

    And are you using the web interface to select Nightly Update, or doing something manually
    Manually. I ran the lms-upgrade.sh script.

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,353
    I think I found the problem, give it a shot now.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Senior Member
    Join Date
    Jun 2010
    Location
    California, USA
    Posts
    213
    Quote Originally Posted by paul- View Post
    I think I found the problem, give it a shot now.
    Works now. Thanks for the quick support.

  6. #6
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    1,076
    On a 2nd pi I attempted a downgrade to 7.9.3 with the lms-update.sh script and it fails.
    7.9.3 is downloaded and then lms-update.sh successfully unpacks it, but the installation fails (always with a “broken pipe”)
    I just removed LMS and reinstalled within pCP, but I thought I’d just let you know.
    Tony
     SBTouch ♪ SBRadio ♬

  7. #7
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,353
    I need to know how you tried to run it. As I specifically tested that, I also need to see the error message. Broken pipe sounds like a download issue.


    On a side note.... Michael, if your listening here, is there a reason that.
    Code:
    http://www.mysqueezebox.com/update/?version=${VERSION}&revision=${REVISION}&geturl=1&os=nocpan
    Cannot return the link to a release version.....i.e. 7.9.3?
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #8
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    1,076
    I followed the instructions on: https://www.picoreplayer.org/how_to_upgrade_lms.shtml
    Here's what happens:

    Code:
    tc@piCorePlayerPB:~$ cd /tmp
    tc@piCorePlayerPB:/tmp$ wget https://raw.githubusercontent.com/piCorePlayer/lms-
    update-script/Master/lms-update.sh
    Connecting to raw.githubusercontent.com (151.101.0.133:443)
    lms-update.sh        100% |********************************| 14059  0:00:00 ETA
    tc@piCorePlayerPB:/tmp$ chmod 755 lms-update.sh
    tc@piCorePlayerPB:/tmp$ sudo ./lms-update.sh --mm 7.9.3 -s -r -u
    
    ###############################################################
    
      This script will update the Logitech Media Server extension  
    
      usage: ./lms-update.sh [-u] [-d] [-m] [-r] [-s] [-t]
                -u Unattended Execution
                -d Debug, Temp files not erased
                -m Manual download Link Check for LMS update
                -r Reload LMS after Update
                -s Skip Update from GitHub
                -t Test building, but do not move extension to tce directory
                --mm <version> Force the version you want to update. (eg 7.9.1)
    
           Unattended Operation Enabled
           Manual Download Link Check Enabled Version:7.9.3
           Automatic Reload Enabled
           Skipping Update
    ###############################################################
    
    Press Enter to continue, or Ctrl-c to exit and change options
    Copying and Running script to tmp so we can automatically reload LMS later
    Checking version for release status...Found Logitech Media Server Release 7.9.3
    
    Downloading update from http://downloads.slimdevices.com/LogitechMediaServer_v7.9.3/logitechmediaserver-7.9.3-noCPAN.tgz
    Connecting to downloads.slimdevices.com (13.225.62.42:80)
    logitechmediaserver- 100% |********************************| 20.3M  0:00:00 ETA
    Loading Local Extension squashfs-tools.tcz
    
    All files tested good.
    Checking Dependancies for squashfs-tools.tcz...
       squashfs-tools.tcz already on system....OK
    Dependancy check complete for squashfs-tools.tcz.
    squashfs-tools.tcz: OK
    
    Updating from /tmp/slimupdate/logitechmediaserver-7.9.3-noCPAN.tgz
    
    Extracting Update...|
    Tar Extraction Complete, Building Updated Extension Filesystem
    
    Press Enter to continue, or Ctrl-c to exit
    
    Update in progress .../tmp/slimupdate/lms-update.sh
    
    
    Done Updating Files.  The files are ready to be packed into the new extension
    
    Press Enter to continue, or Ctrl-c to exit
    Creating extension, it may take a while ... especially on rpi 0/A/B/A+/B+
    Parallel mksquashfs: Using 4 processors
    Creating 4.0 filesystem on /tmp/slimserver.tcz, block size 131072.
    [====================/                                         ]  804/2398  33%
    Gets stuck on 33%, and then:
    packet_write_wait: Connection to xxx.xxx.xx.xx port 22: Broken pipe
    Tony
     SBTouch ♪ SBRadio ♬

  9. #9
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,353
    I've never seen that before, even on a pi0. But you are likely running out of RAM. Are you doing other things that might be saving lots to the /tmp drive?

    Reboot your system, type "free" before running the update script.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  10. #10
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    1,076
    Just running pCp (also tried with LMS shut down). On a Pi 3B.

    Code:
    tc@piCorePlayerPB:~$ free              
    
                  total        used        free      shared  buff/cache   available
    Mem:         999040      177920      631452       11428      189668      809460
    Swap:        240048           0      240048
    Last edited by Tony T; 2020-09-01 at 14:50.
    Tony
     SBTouch ♪ SBRadio ♬

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •