Home of the Squeezebox™ & Transporter® network music players.
Page 7 of 7 FirstFirst ... 567
Results 61 to 66 of 66
  1. #61
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,763
    Quote Originally Posted by d6jg View Post
    The server developer has responded with an update that should have fixed the reported bitrate. He says the apparently excessive icy-metaint is to support 24bit and 96kHz streams.

    Attachment 31462
    The large metaint is not an issue (well I hope for most players) and makes perfect sense. Now, I see you servers are back on their feet but I think there is a bug to be corrected in LMS. The bitrate should be updated, even f the first value is incorrect, the parsing of the ogg header should have overwritten it. Let me check
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  2. #62
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,763
    I've submitted a patch here https://github.com/Logitech/slimserver/pull/413 which solves the issue, not in a fully satisfactory way b/c the bitrate in header is wrong, but at least 1500 is used a 1000's not, as 1's. I still think we'd rather trust the bitrate from the track if we were able to acquire it rather than the one from the HTTP header...

    I've added a step 2 in the patch that let user see the proper bitrate...

    The fact that full metadata is there at every icy-metaint creates way to much noise IMHO, but that's another discussion
    Last edited by philippe_44; 2020-09-04 at 23:39.
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  3. #63
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    8,217
    Quote Originally Posted by d6jg View Post
    I'm back from my few days away now.
    Confirmed that disabling OGG-FLAC on a pCP Player/Server allows metadata updates to work correctly.
    This change is NOT necessary where the pCP is a Player only !!!
    Yet to try the change on a server where I have an SB Touch available.
    I have OGG FLAC set to native on my Raspian server and metadata seems to update correctly on my Radio and Material skin. I have noticed some pops and disturbances in the sound.

    Sent from my Pixel 3a using Tapatalk

  4. #64
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,327
    Quote Originally Posted by slartibartfast View Post
    I have OGG FLAC set to native on my Raspian server and metadata seems to update correctly on my Radio and Material skin. I have noticed some pops and disturbances in the sound.

    Sent from my Pixel 3a using Tapatalk
    Yes. There is interference coming from somewhere which we are investigating. I suspect the encoder stage of the audio chain.
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

  5. #65
    Senior Member
    Join Date
    Dec 2005
    Location
    Sutton Coldfield, UK
    Posts
    810
    Quote Originally Posted by d6jg View Post
    If anyone wants to test they are streaming from
    https://jukeradio.double6.net/mp3 and /flc
    We are currently in test mode so the content is ..... well there is usually something streaming that’s all I am guaranteeing
    I’m uploading files at present - upto E has taken 2 days.
    We are still working on the website but it is functional
    Please do not publicise at this stage
    Any update? Sometimes you played tracks that interested me. Always on the look out for good quality radio streams
    Study Server/Player: LMS 8.2.0 on Pi 4B pCp 8.1.0/IQ Audio DAC+
    Refurbished 1962 RCA Stereo Console Player pCp 8.1.0 on Pi4b/IQ Audio DAC+
    LAN Player pCp 8.1.0 on Pi 3B / IQ Audio DAC+
    LAN Player/ADC pCp 8.1.0 on Pi 3B / IQ audio Codec +
    PC Players: x2: Squeezelite on Windows 10 PC.

  6. #66
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,327
    I have resurrected this project after solving (I think) the interference issue. There is W10 VM in the chain that is running the encoder. It had what we thought was a decent spec of 4 processors & 4GB RAM but was hitting memory issues and although Windows reporterd itself as running well within CPU capability the VM Manager indicated it was operating way over 100%. The CPU spiking was on crossfade and metadata update but also hitting memory issues. Long story short have doubled to 8 processors and 8GB RAM and we seem to be Ok.

    We have a couple of remaining issues to be resolved but these aren't technical. https://jukeradio.double6.net - currently limited to a max of 100 listeners.
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •