Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Jan 2010
    Posts
    711

    piCorePlayer analog out not working

    Finally I bought my first rpi and installed pCP. I need some help with the simple task to get analog audio working via the 3.5mm jack.

    I connected pCP to my existing LMS using the default squeezelite settings (/usr/local/bin/squeezelite -n piCorePlayer -o hw:CARD=ALSA -a 80 1). It worked once after a few reboots, but after some more reboots (I installed LMS on pCP in the meantime) it doesn't work anymore.
    On Diagnostics->Sound I can hear the left&right channels, but otherwise there's no sound. I tried with squeezelite loglevel output=debug and there are lots of errors "output_thread:764 start error: File descriptor in bad state". I tried some other output settings like default or sysdefault:CARD=ALSA and updated squeezelite from 1.9.6 to 1.9.7-1270-pCP without any change.

    Any ideas what I probably missed to configure?

  2. #2
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,915
    hi reinholdk,

    If you have a RPi4B then it may be the mmap setting.

    [Squeezebox settings] > "Change Squeezelite settings" > "ALSA setting" > 4th field, change 1 to 0, then click [Save].

    Short story, after many years mmap became the default, then the RPi4B came along.

    regards
    Greg

  3. #3
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,353
    It’s the 64bit kernel that doesn’t like mmap with the built in audio. I made an obviously failed attempt to override the mmap setting on a pi in 64 bit mode.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Posts
    711
    Quote Originally Posted by Greg Erskine View Post
    hi reinholdk,

    If you have a RPi4B then it may be the mmap setting.

    [Squeezebox settings] > "Change Squeezelite settings" > "ALSA setting" > 4th field, change 1 to 0, then click [Save].

    Short story, after many years mmap became the default, then the RPi4B came along.

    regards
    Greg
    Hi Greg,

    yes, it's the RPi4B and yes, disabling mmap did the trick!
    Although I'm planning to use the rpi as my new LMS server (it's the 4GB model) and therefore don't really need the audio on it, it's reassuring to know everything is working.

    Thanks for your support and the work you and Paul and others are doing for pCP!

    Reinhold

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •