Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 25
  1. #1
    Senior Member
    Join Date
    Oct 2010
    Posts
    166

    LMS running but can't be contacted on Port 9000

    That's the message I got today after using LMS for many years. I have not made any intentional changes to my computer, and it worked last night. I have rebooted, turned LMS off and on several times, but no luck. Any suggestions?

  2. #2
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,613
    It's possible some automatic update changed your port rules. What operating system is LMS running on?

    You might also try rebooting your router and server PC.

  3. #3
    Senior Member
    Join Date
    Oct 2010
    Posts
    166
    Windows 10. The computer is connected to the internet. I have McAfee Firewall. I did notice during troubleshooting that port 9000 was not open, and I opened it, but only for my home network. I should open it up fully I guess.

    Edit - tried turning my Firewall off. It made no difference. Also tried a different browser.

    Should I reinstall LMS?
    Last edited by john greenwood; 2020-08-15 at 08:31.

  4. #4
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,613
    Port opening on "Home Network" is what you want; you don't want LMS accessible from the internet or you'll get hacked.

    Easiest way to rewrite all LMS port rules is to just reinstall LMS. Install it into same location on PC and all settings will be maintained.

    Latest stable version is here: http://downloads.slimdevices.com/nig...ex.php?ver=7.9

    EDIT: If after doing this and rebooting server you still need to punch a hole through McAfee, the instructions are here:
    https://www.technipages.com/allow-pr...sonal-firewall

    I would not set access to "Open to all devices".
    Last edited by Apesbrain; 2020-08-15 at 08:31.

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,923
    If another media server has been started and is using port 9000 then LMS will revert to 9001 or 9002 or 9003 etc. Try other port nos.

  6. #6
    Senior Member
    Join Date
    Oct 2010
    Posts
    166
    Problem resolved when I installed 7.9.3. I see there's another thread where other people had the same problem today.

  7. #7
    Senior Member agbagb's Avatar
    Join Date
    Aug 2006
    Posts
    471
    Quote Originally Posted by john greenwood View Post
    Problem resolved when I installed 7.9.3. I see there's another thread where other people had the same problem today.
    And there's yet another thread about clicking on Settings>PlugIns crashing pre-7.9.3 LMS ........ I had that oddity, as well as several others, all solved by shifting to 7.9.3.
    Last edited by agbagb; 2020-08-16 at 03:54. Reason: Clarity!
    LMS 8.0.1 (1606118512)
    Win10
    Control: Web GUI; sometimes OrangeSqueeze on Android phones / pads

    Machines / devices are in France, in two locations.
    a) Sagem Livebox
    Internal HDD (FLAC music; mp3 voice), Desktop
    3 x Touch - 2 wireless, 1 LAN. (7.8.0-r16754)
    3 x SB Radios [2 wireless, 1 LAN] (7.7.3-r16676)
    1 x Riva Arena (via Airplay LMS PlugIn)

    b) Freebox
    External SSD (all mp3), WiFi Laptop
    1 x Touch LAN (Firmware:7.8.0-r16754)
    2 x SB Radios, Wireless (7.7.3-r16676)

  8. #8
    Senior Member
    Join Date
    Sep 2008
    Location
    West Sussex, UK
    Posts
    326
    Hi there, I am struggling with this too - I have just re-installed 7.9.4 on my WHS 2011 server, and still am getting the message. ANy thoguths?

    J
    Attached Images Attached Images  
    Last edited by JonWill; 2020-09-08 at 06:17.
    Main system: SB Touch, Arcam A85, Tannoy V4i speakers
    SB Classic into JVC R-1XL Stereo Receiver and JPW bookshelf speakers (an Ebay/ Freecycle set up!)
    SB Boom, Logitech Z4 subwoofer
    SB Radio
    LMS 7.8.0 running on WHS 2011 on a HP Prolaint Microserver
    Orange Squeeze/ Squeeze Commander on Google Nexus 7 and HTC One

  9. #9
    Junior Member
    Join Date
    Dec 2020
    Posts
    7
    Hi, hoping someone may be able to assist me as I have the same symptoms. I've been running LMS V8.0.0 - 1605892076 on Windows 10 PC (Ver 20H2 OS build 19042.630) and previous versions successfully until this weekend when I switched ISP from Plusnet to Virgin. Since then below is what I see in teh LMS Control Panel -> Diagnostics (as this is my first post I can't attached images):
    LMS
    Port 3483 (slimproto): Failed
    Port 9000 (HTTP):
    Port 9091 (CLI): Failed

    mysqueezebox.com
    Ping: OK
    Port 3483 (slimproto): OK
    Port 9000 (HTTP): OK

    Alerts
    Logitech Media Server is running but can't be contacted on port 9000.

    In the LMS Control Panel -> Information it says "Total Players Recognised: 0"

    netstat -ab has TIME_WAIT for port 9000

    I have AVG running on the PC but this was also in place prior to my ISP migration. There is a firewall running on the Virgin Media Hub 3.0 .=

    Do I need to update some settings on the Hub and if so, would you know where and what values are required?

    Thank you

  10. #10
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,923
    In Ireland, I have VM Hub 3.0 and nothing needed to be set up with a test LMS 8.0.0 30 Nov Win10 20H2 system

    Possible cause is IP addresses, DHCP & ARP caches - check IP address of player, IP address of Win10 LMS host and IP address of Hub 3.0. Check what IP devices does Hub 3.0 "see"

    Turn everything off, Hub, player and Win 10 system. If you have extenders etc. turn them off as well - anything that can hold & maybe cache network info.

    Power on Hub 3.0 and wait till it is up and running.
    Then power on Win10 system and LMS.
    When LMS is up and running - only then power up player.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •