Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Aug 2020
    Posts
    4

    piCorePlayer 6.0.1 Raspberry Pi 3B WiFi Issue with Static IP

    Hi,

    Running piCorePlayer 6.0.1 on a Raspberry Pi 3B - no problems when using DHCP.
    I have a 256GB flash drive connected to the Pi and I can use the WiFi interface to control the LMS server running on the Pi and stream to stereo BT speakers.

    BUT when using static IPs, I cannot connect to the static WiFi IP address via the web interface or via SSH although I can see the WiFi IP address in my router.

    I have no issues with the static Ethernet IP address.
    Connecting on Ethernet via the static Ethernet IP, when I run the WiFi diagnostic everything seems fine, except the Ping LMS test fails.

    Have I missed any additional settings in the interface that need to be done?
    Last edited by Gussie; 2020-08-14 at 05:51. Reason: corrected info

  2. #2
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,379
    What method did you use to set static IP?

    The recommended way is to do it on your dhcp server (router).

  3. #3
    Junior Member
    Join Date
    Aug 2020
    Posts
    4
    piCorePlayer settings ...

    Name:  eth.jpg
Views: 173
Size:  96.2 KB

    Name:  wlan.jpg
Views: 173
Size:  96.0 KB

    Router settings ...

    Name:  Router DHCP.jpg
Views: 178
Size:  109.2 KB

    To define a new static IP address I have always used an unused address outside my allowed DHCP pool (100 to 140).
    I have several devices with static IPs that are outside the DHCP pool, and have no issues with them.
    Are you suggesting I should use the "Enable Manual Assignment" setting on my router - which I have never had to use before?
    Also note that both 190 and 191 do appear on my routers client list.
    I can access the 190 web/SSH interfaces but not 191 which is the wlan.
    Change the PiCorePlayer IPs back to DHCP and everything works fine.
    Last edited by Gussie; 2020-08-14 at 14:29. Reason: extra info

  4. #4
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,234
    On most routers itís called DHCP reservation and yes when using WiFi that is definitely the method to use.
    If your router doesnít have the facility (some donít) get a new router.
    Static IP over WiFi is pretty much a no no.
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

  5. #5
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,379
    Why are you setting up wired ethernet and wifi? Squeezelite will default to your wired ethernet. I don't know what LMS does?

    For LMS I would recommend wired ethernet only.

    "Enable Manual Assignment" sounds about right. It should map a MAC address to IP address.

    As your DHCP usually does your IP allocation, it makes sense to do your static IPs there also, so you do all your IP assignments in one place. You should also do a backup of your router configuration once done. Using one tool means you don't accidently assign the same IP address more than once. Also, even after a complete rebuild of pCP your static IP will still be there, nothing to do. The map to the MAC address of your ethernet interface means it will follow the RPi forever no matter what software you load on it. Remember, if you map to a USB Wifi adapter the IP address will also follow that device no matter what you plug it into.

  6. #6
    Junior Member
    Join Date
    Aug 2020
    Posts
    4
    Quote Originally Posted by Greg Erskine View Post
    Why are you setting up wired ethernet and wifi? Squeezelite will default to your wired ethernet.
    I am not.

    I just wanted to show you all my settings.

    When I want to use WiFi, I disconnect the lan cable so that piCorePlayer only uses the Wlan interface.

  7. #7
    Junior Member
    Join Date
    Aug 2020
    Posts
    4
    Quote Originally Posted by d6jg View Post
    On most routers itís called DHCP reservation and yes when using WiFi that is definitely the method to use.
    If your router doesnít have the facility (some donít) get a new router.
    Static IP over WiFi is pretty much a no no.
    Hmm, I have several IP cameras using WiFi that work just fine without explicit DHCP reservation - I just chose their IP addresses to be outside the DHCP pool - never needed to use explicit DHCP reservations.

    Also note that my router does list the piCorePlayer Wlan IP address in it's client list - but I cannot connect to it.

    Anyway, I specified an explicit DHCP reservation for my piCorePlayer Wlan IP address on my router...

    Name:  explicit static ip setting.jpg
Views: 150
Size:  208.8 KB

    I then disconnected the lan cable and rebooted, this is my full router client list - ypu will see my piCorePlayer list at the bottom.

    Name:  client list.jpg
Views: 149
Size:  97.9 KB

    It still does not work, I still cannot access 192.168.1.191 by web interface or SSH.

    The strange thing is - if connect a lan cable to the inaccessible piCorePlayer as is, then I can suddenly access both 192.168.1.190 and 192.168.1.191 ip addresses.

    Here's the router client list with both ips present ..

    Name:  both.jpg
Views: 142
Size:  129.1 KB

    The WiFi on its own will not work with a static ip setting.
    Last edited by Gussie; 2020-08-15 at 07:38. Reason: extra info

  8. #8
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,379
    Are you intending to use LMS over Wifi ? That is not recommended, just be careful if you end up streaming music over multiple Wifi hops.

    Have you got rid of all the Static IP settings on piCorePlayer?

    To swap between wired and Wifi you need to shutdown piCorePlayer, remove cable then power up piCorePlayer.

    EDIT: Thinking out loud, there may be a condition, if you setup static IP on wired ethernet the try and boot without the cable. It might just fail and not try wifi.
    Last edited by Greg Erskine; 2020-08-15 at 13:50.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •