Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Ubuntu 20.4

  1. #1
    Junior Member
    Join Date
    Aug 2020
    Posts
    15

    Ubuntu 20.4

    I am trying to install LMS on ubuntu 20.4, on my raspberry pi4.
    Installation is ok with this "tuto" from askubuntu

    I can't open the webbrowser

    i haven't modify yet the init.d script...
    do you have some experience with this?

    thanks

  2. #2

  3. #3
    Member
    Join Date
    May 2017
    Location
    Saint-Siméon, France
    Posts
    59
    That tutorial is a bit misleading, as it is based on upgrading form a previous version to Ubuntu 20.04.

    On a fresh install you do not have to edit any init'd scripts, you just need to 'sudo systemctl enable logitechmediaserver'

    You can install any version after downloading the appropriate .deb file, then using 'sudo dpkg -i'

    You will, however, have some problems with perl versions, which can be overcome.

  4. #4
    Junior Member
    Join Date
    Aug 2020
    Posts
    15
    ok thanks,
    which version is for pi4,
    all.deb or arm.deb
    [ ] logitechmediaserver_7.9.2_all.deb 14-Jan-2020 11:21 140M Debian Package
    [ ] logitechmediaserver_7.9.2_arm.deb 14-Jan-2020 11:21 47M Debian Package
    Quote Originally Posted by Yatsushiro View Post
    That tutorial is a bit misleading, as it is based on upgrading form a previous version to Ubuntu 20.04.

    On a fresh install you do not have to edit any init'd scripts, you just need to 'sudo systemctl enable logitechmediaserver'

    You can install any version after downloading the appropriate .deb file, then using 'sudo dpkg -i'

    You will, however, have some problems with perl versions, which can be overcome.

  5. #5
    Member
    Join Date
    May 2017
    Location
    Saint-Siméon, France
    Posts
    59
    Either can be used, but the arm specific is a much smaller download.

  6. #6
    Junior Member
    Join Date
    Aug 2020
    Posts
    15
    I have perl 5 v30.
    Ubuntu 20.4 on the pi4.
    Logitechmediaserver 7.9.3
    Install with dpkg-i file arm.deb, and access refused on webbrowser...
    Any ideas?

  7. #7
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    1,064
    Quote Originally Posted by davidscrat View Post
    I have perl 5 v30.
    Ubuntu 20.4 on the pi4.
    Logitechmediaserver 7.9.3
    Install with dpkg-i file arm.deb, and access refused on webbrowser...
    Any ideas?
    perl >= 5.30 on the Arm architecture (which all RPIs are based on) is not supported by the official binary packages.
    Various SW: Web Interface | Playlist Editor / Generator | Music Classification | Similar Music | Announce | EventTrigger | LMSlib2go | ...
    Various HowTos: build a self-contained LMS | Bluetooth/ALSA | Control LMS with any device | ...

  8. #8
    Junior Member
    Join Date
    Aug 2020
    Posts
    15
    Wow...
    So nobody installed Logitechmediaserver with perl 5.30?
    Is it possible to install an older version of perl or another solution to open the webbrowser (port 9000 doesnt appear with netstat - tlpn)

  9. #9
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    1,064
    Quote Originally Posted by davidscrat View Post
    So nobody installed Logitechmediaserver with perl 5.30?
    It runs on x86_64 (i.e. AMD / Intel)

    Quote Originally Posted by davidscrat View Post
    Is it possible to install an older version of perl or another solution to open the webbrowser (port 9000 doesnt appear with netstat - tlpn)
    The port issue is a red herring - LMS simply cannot start (as there are no binary modules for perl 5.30)
    Downgrading the system perl isn't realistic.
    Options:
    - use a OS distribution providing perl <= 5.28
    - install a custom perl <= 5.28 (separate from the main OS) and use this to run LMS
    - compile the binary modules for perl 5.30 yourself
    Various SW: Web Interface | Playlist Editor / Generator | Music Classification | Similar Music | Announce | EventTrigger | LMSlib2go | ...
    Various HowTos: build a self-contained LMS | Bluetooth/ALSA | Control LMS with any device | ...

  10. #10
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    4,964
    Quote Originally Posted by davidscrat View Post
    Wow...
    So nobody installed Logitechmediaserver with perl 5.30?
    Is it possible to install an older version of perl or another solution to open the webbrowser (port 9000 doesnt appear with netstat - tlpn)
    This was a similar issue.
    https://github.com/Logitech/slimserver/issues/154
    The solution seems to be build your own.

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •