Home of the Squeezebox™ & Transporter® network music players.
Page 78 of 89 FirstFirst ... 2868767778798088 ... LastLast
Results 771 to 780 of 887
  1. #771
    I logged #74 about these messages and I don't think Bluetooth was on as I don't use it. Also with the ESP32 Audo Kit V2.2.

  2. #772
    I have made some tests today.

    1) Android BT stream have no sound.
    2) IOS BT stream work well.
    3) Android BT stream after IOS stream have sound.
    4) After reboot Android BT stream have no sound anymore.

    I hope this can help you.


    Quote Originally Posted by philippe_44 View Post
    If you could please - I don't see a problem with my iOS device but just want to verify

  3. #773
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,109

    ANNOUNCE: Squeezelite-ESP32 (dedicated thread)

    Quote Originally Posted by bgiraut View Post
    I have made some tests today.

    1) Android BT stream have no sound.
    2) IOS BT stream work well.
    3) Android BT stream after IOS stream have sound.
    4) After reboot Android BT stream have no sound anymore.

    I hope this can help you.
    Thanks - itís probably linked to that issue of absolute volume. Iíll investigate
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  4. #774
    Senior Member sle118's Avatar
    Join Date
    Dec 2009
    Location
    Quebec City, Canada
    Posts
    438
    Quote Originally Posted by philippe_44 View Post
    Thanks - itís probably linked to that issue of absolute volume. Iíll investigate
    Is it related to this?
    https://github.com/espressif/esp-idf/issues/4646
    LMS 7.9 - 1xRadio, 1xBoom, 5xDuet,3xTouch, 1 SB2. Sony PlayStation, Emby, Chromecast v1 and v2 and...
    6xSqueezeAmp!
    Contributing to Folding@Home : https://stats.foldingathome.org/donor/squeezelite-esp32

  5. #775
    Junior Member
    Join Date
    Dec 2020
    Posts
    8
    I think that android handles Bluetooth-Volume in an other way than iPhone...
    Some month before I changed from android to iPhone an found out:

    Android (Version 10): volume changes the volume from the stream and not the volume of the destination-device.
    iPhone (Version 14.x): volume changes NOT the volume from the stream, but changes the volume from the destination-device.

    My destination-device is a Sennheiser Bluetooth In-Ear-Headset.

  6. #776
    Quote Originally Posted by philippe_44 View Post
    Thanks - itís probably linked to that issue of absolute volume. Iíll investigate
    I found that if you change the volume of the player that has be set as BT sink in LMS ,then audio comes through and plays

  7. #777
    Confirmed ! Bluethoot stream has sound if you change the volume once throught the software player. You can then change volume throught device button.

    Quote Originally Posted by justjason View Post
    I found that if you change the volume of the player that has be set as BT sink in LMS ,then audio comes through and plays

  8. #778
    Junior Member
    Join Date
    Mar 2021
    Posts
    16

    A2DP BT Sink

    Quote Originally Posted by bgiraut View Post
    I have made some tests today.

    1) Android BT stream have no sound.
    2) IOS BT stream work well.
    3) Android BT stream after IOS stream have sound.
    4) After reboot Android BT stream have no sound anymore.

    I hope this can help you.
    Like I stated before: I have the same behaviour.
    In my case however: although I get audio streaming from an Android device after connecting an IOS device, the max volume I can set is the level that was set when I disconnected the IOS device. So setting the ios device to 30% volume, and then connecting the Android device I can set the volume between 0 and 30% absolute volume.

  9. #779
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,109
    Quote Originally Posted by MisterA View Post
    Like I stated before: I have the same behaviour.
    In my case however: although I get audio streaming from an Android device after connecting an IOS device, the max volume I can set is the level that was set when I disconnected the IOS device. So setting the ios device to 30% volume, and then connecting the Android device I can set the volume between 0 and 30% absolute volume.
    It should be fixed in the latest release and hopefully you can alternate between iOS and Android devices, each will have their own volume. You now have a "bt_sink_volume" NVS parameter that is 127 (max) by default. This is the *hardware* volume of the device.

    For controller like Android, they apply a *soft* gain on samples and do not try to set/change the hardware volume, so it makes sense to set it to max by default. The *only* option to change this hardware value is through the webUI or by using rotary/buttons.

    Controllers like iOS use a BT function that sends an absolute volume request to the player which is used, regardless of the hardware volume (it takes precedence, it is *not* a multiplier). Note that this does *not* change/set the hardware volume so that when you go back to an Android device, you're back to where you were.

    BE CAREFUL AS THIS MIGHT NOT BE FOOLPROOF AND DUE TO PREVIOUS VERSION, YOU MIGHT HAVE SET THE BT VOLUME ON YOUR ANDROID DEVICE PRETTY HIGH AND WITH A HARDWARE VOLUME AT 100%, IT WILL BE *VERY* LOUD.
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  10. #780
    Senior Member sle118's Avatar
    Join Date
    Dec 2009
    Location
    Quebec City, Canada
    Posts
    438

    UI Improvements for testing!

    I am looking for brave testers that are willing to flash an off-release build on their devices to help with testing before we create an official release.

    The main improvements are found in the firmware update page:
    - Alignment of the style with the rest of the UI
    - Consistent end-to-end feedback during the flashing process which covers rebooting to recovery all the way to completion of the OTA
    - Added ability to upload a firmware without having to first restart to recovery
    - Improved compatibility with devices running older recovery versions. The new UI will drive the old recovery and understand ota progress, etc. Note that due to the lack of support for firmware upload on the much older recovery versions, attempts made to upload will fail with a recommendation to use the web url method.

    oh, and the annoying overlap of the UI content pages by the footer is also fixed once and for all (hopefully)

    You can find the firmware binaries in the artifacts section of the build here:
    https://github.com/sle118/squeezelit...runs/750310406

    Note that these files are in ZIP format and need to be flashed either with a USB connection or using a local http server. This thread has numerous examples on how to achieve this.

    thank you!
    LMS 7.9 - 1xRadio, 1xBoom, 5xDuet,3xTouch, 1 SB2. Sony PlayStation, Emby, Chromecast v1 and v2 and...
    6xSqueezeAmp!
    Contributing to Folding@Home : https://stats.foldingathome.org/donor/squeezelite-esp32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •