Home of the Squeezebox™ & Transporter® network music players.
Page 122 of 141 FirstFirst ... 2272112120121122123124132 ... LastLast
Results 1,211 to 1,220 of 1407
  1. #1211
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,764
    Quote Originally Posted by ElFishi View Post
    I still struggle with my S/PDIF system.
    I finally found the time to hook it up with a serial interface so I could log what is going on when the music stops playing.
    Attached you find my NVS-config and the section of the log when the system lost connection.
    During the time the ESP was "unable to connect to server" I checked and found that the LMS server was actually available.
    What firmware do you have?
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  2. #1212
    Senior Member
    Join Date
    Feb 2008
    Posts
    435
    Quote Originally Posted by philippe_44 View Post
    What firmware do you have?
    fw: I2S-4MFlash.16.764.master-cmake

  3. #1213

    issue with LMS plugin

    I just finished another ESP32 based player and it was running fine fora while. Then while I was messing around with the spectrum analyser settings for the player in LMS, suddenly the Player/ESP32 settings page in LMS didn't want to load anymore.
    I then uninstalled and re-installed the plugin. Now the page still isn't loading most of the time, and when it does it only shows the first line with the link to the webpage of the ESP32. There are no display settings or equaliser.

    In the log I get this error:
    [21-11-27 21:56:52.2034] Slim::Networking::IO::Select::__ANON__ (130) Error: Select task failed calling Slim::Web::HTTP:rocessHTTP: Undefined subroutine &Plugins::SqueezeESP32::FirmwareHelper::initFirmwa reDownload called at /srv/squeezebox/cache/InstalledPlugins/Plugins/SqueezeESP32/PlayerSettings.pm line 134.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0x5589ce9008)

    Any idea what is causing this and how to solve it?



    ---- Nevermind, I fixed it by removing the players' entry from server.prefs
    Last edited by nenu; 2021-11-27 at 15:36.

  4. #1214
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,764
    Quote Originally Posted by ElFishi View Post
    fw: I2S-4MFlash.16.764.master-cmake
    Does the issue happen very often and more with SPDIF?
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  5. #1215
    Senior Member
    Join Date
    Feb 2008
    Posts
    435
    Quote Originally Posted by philippe_44 View Post
    Does the issue happen very often and more with SPDIF?
    I keep loging the system and it hasn't re-occurred since ca 6h playing time. Before I updated to the latest version I couldn't log via serial, but I lost connection every 1-2h or so.
    It seems only my S/PDIF system is affected, but it is also the system I work the most. I have two more, both I2S. One of them is frequently synced to the S/PDIF system, but I left it off for the current extended test with serial logging.
    So maybe also syncing increases the risk of loss of connection?

  6. #1216
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,764

    GPIO expander

    I'm finishing the addition of I2C GPIO expander for devices that don't have many available GPIOs or when people want a full set of buttons. The drivers will be fully built-in, not like DAC where I've left extensions to the user. Can you tell me which expander you typically use so that I can include them directly?
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  7. #1217
    Senior Member
    Join Date
    Feb 2008
    Posts
    435
    Quote Originally Posted by philippe_44 View Post
    can you tell me which expander you typically use so that i can include them directly?
    mcp23017, pcf8574

  8. #1218
    Member
    Join Date
    Jan 2020
    Location
    Germany
    Posts
    69
    Quote Originally Posted by philippe_44 View Post
    I'm finishing the addition of I2C GPIO expander for devices that don't have many available GPIOs or when people want a full set of buttons. The drivers will be fully built-in, not like DAC where I've left extensions to the user. Can you tell me which expander you typically use so that I can include them directly?
    Sounds great; I am using MCP 23017-E/SP

  9. #1219
    Senior Member
    Join Date
    Feb 2008
    Posts
    435

    one more loss of connection

    Quote Originally Posted by ElFishi View Post
    I still struggle with my S/PDIF system.
    caught another one while streaming from spotify (took some 10hrs, this time)
    Code:
    [00:20:23.695868] slimproto_run:606 error reading from socket: closed
    [00:20:28.796636] slimproto:964 unable to connect to server 0
    ...
    full log attached
    Attached Files Attached Files

  10. #1220
    Senior Member sle118's Avatar
    Join Date
    Dec 2009
    Location
    Quebec City, Canada
    Posts
    469

    Ethernet support

    Quote Originally Posted by piPlayer View Post
    This is very interesting for me. I look forward to learning more about it.

    Regards
    PiPlayer
    I quickly came to the conclusion that the existing code base would become unmanageable with Ethernet coexistence, so I opted for a complete re-write of the network manager using a better state machine framework. I'm not sure yet when I'll have the first version available, but good progress has been made. And by that, I mean I am almost ready to try compiling the code

    Jokes aside, Ethernet definitely works, at least with the RMII modules that provide their own clocks. I just received some SPI modules and they are next in my list; they are a bit slower than RMII, but require less gpio's.

    Here is a link to the modules I ordered (W5500)
    https://a.aliexpress.com/_mrr85ZY
    LMS 7.9 - 1xRadio, 1xBoom, 5xDuet,3xTouch, 1 SB2. Sony PlayStation, Emby, Chromecast v1 and v2 and...
    6xSqueezeAmp, several other ESP32-Wrover boards with jumper wires flying around, some with ethernet!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •