Home of the Squeezebox™ & Transporter® network music players.
Page 125 of 141 FirstFirst ... 2575115123124125126127135 ... LastLast
Results 1,241 to 1,250 of 1407
  1. #1241
    Quote Originally Posted by philippe_44 View Post
    I know that there are dangers here and there in parsing of nvs parameters and thatís really bad to fall into a boot because of a syntax error. But checking everything also requires more code and time and thatís also why there is the web guided interface. But Iíll look at what happened and see if it can do something
    I made plenty of errors before, especially in set_GPIO and the worst that would happen is that things defined there wouldn't work.
    But honestly, I wouldn't worry about it too much. If it fails, people will find their way here most likely.

    Maybe just add a little note just below 'Configuration': Interpretation of the configuration strings is very sensitive to syntax errors, e.g. requiring ',' or ':' or '=' in different places. There is no syntax validation before saving. In most cases, that particular part of the configuration will not work and you can simply modify, save and reboot again. However in some instances an error may cause booting to halt and loop. The device will appear unresponsive in LMS and in the configuration page. Fix this by erasing all of the flash memory to remove the faulty configuration. You can do this through the esp flash download tool.

    Nobody reads this beforehand, but some may once they are stuck

  2. #1242
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,763
    Quote Originally Posted by nenu View Post
    I made plenty of errors before, especially in set_GPIO and the worst that would happen is that things defined there wouldn't work.
    But honestly, I wouldn't worry about it too much. If it fails, people will find their way here most likely.

    Maybe just add a little note just below 'Configuration': Interpretation of the configuration strings is very sensitive to syntax errors, e.g. requiring ',' or ':' or '=' in different places. There is no syntax validation before saving. In most cases, that particular part of the configuration will not work and you can simply modify, save and reboot again. However in some instances an error may cause booting to halt and loop. The device will appear unresponsive in LMS and in the configuration page. Fix this by erasing all of the flash memory to remove the faulty configuration. You can do this through the esp flash download tool.

    Nobody reads this beforehand, but some may once they are stuck
    Finally I took the bull by the horns and decided to make a safe parsing of these parameters. The risk is really too big for users that have no serial cable.
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  3. #1243
    Senior Member
    Join Date
    Jan 2016
    Location
    Germany
    Posts
    218
    @phillipe
    Will you include the offset feature in future versions?

  4. #1244
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,763
    Quote Originally Posted by piPlayer View Post
    @phillipe
    Will you include the offset feature in future versions?
    Yes, itís in there already
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  5. #1245
    Junior Member
    Join Date
    Nov 2018
    Posts
    10
    Is there a possiblity to add a "mono" mode? I'm using one of those "horrible" AI-thinker boards (it's kinda fine, althought still haven't figured the buttons out and documentation is "sparse") and the amps seem to get a bit hot if you wire a single speaker up to both channels. For the device I'm upgrading though, it only has the one speaker and I don't want to pick left or right. Not sure if that's easy or high-cpu to do before the DAC (something makes me think about "joint stereo" files from the ancient parts of my memory).

  6. #1246
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    5,106
    LMS/Settings/Player/PlayerName/Audio/Output channel mode


    Sent from my iPhone using Tapatalk
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  7. #1247
    Quote Originally Posted by Paul Webster View Post
    LMS/Settings/Player/PlayerName/Audio/Output channel mode
    Is that going to work though? The A1S will still separate its L and R output to each of its connectors, no? So if you select 'Left Channel' in LMS, both connectors will give you L, and similar for R. But if you use 'Both Channels', the L connector will be L and the right connector will be R only.
    There is no option to mix both channels to the outputs.
    Last edited by nenu; 2021-12-08 at 11:12.

  8. #1248
    Quote Originally Posted by philippe_44 View Post
    Finally I took the bull by the horns and decided to make a safe parsing of these parameters. The risk is really too big for users that have no serial cable.
    Thanks once more for picking up another valiant quest!
    But also: challenge accepted. Never underestimate a resourceful idiot

    (Just kidding, not about the thank you part though.)

  9. #1249
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,763
    Quote Originally Posted by iMartyn View Post
    Is there a possiblity to add a "mono" mode? I'm using one of those "horrible" AI-thinker boards (it's kinda fine, althought still haven't figured the buttons out and documentation is "sparse") and the amps seem to get a bit hot if you wire a single speaker up to both channels. For the device I'm upgrading though, it only has the one speaker and I don't want to pick left or right. Not sure if that's easy or high-cpu to do before the DAC (something makes me think about "joint stereo" files from the ancient parts of my memory).
    This is what the "Both Channels (mono)" I've added sometimes ago does: combine in the player L and R and output the result to both
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  10. #1250
    Quote Originally Posted by philippe_44 View Post
    It is included. The only reason (bug aside ) why you might not see anything on LMS GUI is that the plugin is not installed
    Are the sliders for the equalizer only available in the classic UI? When running the Material skin UI I do see the equalizer function, but only showing numeric values, no sliders.
    Attached Images Attached Images   

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •