Home of the Squeezebox™ & Transporter® network music players.
Page 43 of 62 FirstFirst ... 33414243444553 ... LastLast
Results 421 to 430 of 615
  1. #421
    I updated my firmware to 546, and had trouble with the NVS screen, as the bottom Reboot and fw: I2S-4MFlash.546.master-cmake, mode: squeezelite, SSID: xxxxxxxxxxxxxx, IP: xxxxxxxxxxxxxx "banner" covers the buttons at the bottom of the screen. Just tried 552 and have the same problem. Should I be using different firmware? Tried searching NVS but had no luck.

    Thanks, Mike

  2. #422
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,689
    Quote Originally Posted by mboxler View Post
    I updated my firmware to 546, and had trouble with the NVS screen, as the bottom Reboot and fw: I2S-4MFlash.546.master-cmake, mode: squeezelite, SSID: xxxxxxxxxxxxxx, IP: xxxxxxxxxxxxxx "banner" covers the buttons at the bottom of the screen. Just tried 552 and have the same problem. Should I be using different firmware? Tried searching NVS but had no luck.

    Thanks, Mike
    It's a small bug that I think @sle118 has already fixes locally. You should be able to click just on the visible part of the button, though
    LMS 8.1.x on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  3. #423
    Quote Originally Posted by philippe_44 View Post
    It's a small bug that I think @sle118 has already fixes locally. You should be able to click just on the visible part of the button, though
    I figured as such. I should have also asked how the four buttons are labeled. There are three light blue on the left side of the screen and a dark blue
    on the right. I can click on them but have no idea which is which.

  4. #424
    Senior Member sle118's Avatar
    Join Date
    Dec 2009
    Location
    Quebec City, Canada
    Posts
    399
    Quote Originally Posted by mboxler View Post
    I figured as such. I should have also asked how the four buttons are labeled. There are three light blue on the left side of the screen and a dark blue
    on the right. I can click on them but have no idea which is which.
    The upcoming changes should come soon enough. Thank you for your patience!
    LMS 7.9 - 1xRadio, 1xBoom, 5xDuet,3xTouch, 1 SB2. Sony PlayStation, Emby, Chromecast v1 and v2 and...
    6xSqueezeAmp!
    Contributing to Folding@Home : https://stats.foldingathome.org/donor/squeezelite-esp32

  5. #425
    Quote Originally Posted by mboxler View Post
    Thanks! This is all I get with a connected and working SSD1306 display

    Executing

    0 1 2 3 4 5 6 7 8 9 a b c d e f
    00: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    70: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    I established a Putty session. When I execute the Scan I2C bus for devices command I get dozens of this message...

    E (145503) i2c: /opt/esp/idf/components/driver/i2c.c:1273 (i2c_master_cmd_begin):i2c driver not installed

    Is this a clue to my issue?

    I2S-4MFlash.546.master-cmake

    Thanks, Mike

  6. #426
    Senior Member sle118's Avatar
    Join Date
    Dec 2009
    Location
    Quebec City, Canada
    Posts
    399
    Quote Originally Posted by mboxler View Post
    I established a Putty session. When I execute the Scan I2C bus for devices command I get dozens of this message...

    E (145503) i2c: /opt/esp/idf/components/driver/i2c.c:1273 (i2c_master_cmd_begin):i2c driver not installed

    Is this a clue to my issue?

    I2S-4MFlash.546.master-cmake

    Thanks, Mike
    Please share your configuration so I can have a look. Driver not installed seems to indicate that i2c is misconfigured. My main dev desktop's power supply died yesterday so I will need to go from memory for a couple of days
    LMS 7.9 - 1xRadio, 1xBoom, 5xDuet,3xTouch, 1 SB2. Sony PlayStation, Emby, Chromecast v1 and v2 and...
    6xSqueezeAmp!
    Contributing to Folding@Home : https://stats.foldingathome.org/donor/squeezelite-esp32

  7. #427
    Quote Originally Posted by sle118 View Post
    Please share your configuration so I can have a look. Driver not installed seems to indicate that i2c is misconfigured. My main dev desktop's power supply died yesterday so I will need to go from memory for a couple of days
    Thank you for the help (and everything else you do for that matter). I assumed that since the display was working that I had I2c
    configured properly.

    NVS Editor

    display_config I2C:width=128,height=32,address=60,driver=SSD1306, HFlip,VFlip

    i2c_config scl=22,sda=21,speed=100000,port=1
    Last edited by mboxler; 2021-01-19 at 06:00.

  8. #428
    Junior Member
    Join Date
    Jan 2021
    Posts
    12

    can't find precompiled binaries

    Hi folks,

    I got me a ESP32-A1S Audio development Kit (this one: https://www.exp-tech.de/plattformen/...evelopment-kit) to test your great project.

    Yesterday I tried to build Squeezelite-esp32 myself using a native Installation of esp-idf (on Pop!_OS 20.10) and also using the provided docker image, both with no success so far.
    I will have a deeper look into it and come back to you if I need further assistance with building from source.

    For now my question is where I can find the precompiled binaries.
    I read that sle118 "removed the release binaries all the way to 539", however I still can't find any release binaries at all.

    I have looked through the archives here https://github.com/sle118/squeezelite-esp32/tags
    But as I am a new to your project, I don't know where and what to look for exactly.
    Maybe someone can point me to the most recent binaries for my board that I'm supposed to use.

    Thanks in advance

  9. #429
    Senior Member chill's Avatar
    Join Date
    Mar 2007
    Location
    Nottingham, UK
    Posts
    1,964
    Click the button next to Tags to go to Releases: https://github.com/sle118/squeezelite-esp32/releases

    Then expand the assets below the block of text.

  10. #430
    Junior Member
    Join Date
    Jan 2021
    Posts
    12
    Quote Originally Posted by chill View Post
    Click the button next to Tags to go to Releases: https://github.com/sle118/squeezelite-esp32/releases

    Then expand the assets below the block of text.
    Thank you. This is actually not so hard to find.
    I have to open my eyes next time

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •