Home of the Squeezebox™ & Transporter® network music players.
Page 160 of 163 FirstFirst ... 60110150158159160161162 ... LastLast
Results 1,591 to 1,600 of 1626
  1. #1591
    Junior Member
    Join Date
    Jul 2022
    Posts
    6

    Problem displaying the album covers.

    Hi all.
    Congratulations for your great job.
    I have a setup with a ILI9341 screen, 240 wide 320 height.
    Everithing fine, but, most of the times the album cover is not fully delivered to the screen, and the screen appears black at the bottom.
    It happens more frequently when the song finish at it's end and change to the new song.
    It you push the forward button to change to the next song, it happens less frequently.
    Any ideas?ç
    Thanks in advance.

    Javier

  2. #1592
    Senior Member sle118's Avatar
    Join Date
    Dec 2009
    Location
    Quebec City, Canada
    Posts
    502
    Quote Originally Posted by yateng View Post
    Hi all.
    Congratulations for your great job.
    I have a setup with a ILI9341 screen, 240 wide 320 height.
    Everithing fine, but, most of the times the album cover is not fully delivered to the screen, and the screen appears black at the bottom.
    It happens more frequently when the song finish at it's end and change to the new song.
    It you push the forward button to change to the next song, it happens less frequently.
    Any ideas?ç
    Thanks in advance.

    Javier
    More info is needed if you want some help. Describe you hardware, including DAC, and more importantly the version you are running for squeezelite-esp32 as well as the plugin.

    Ideally, provide some logs that would give an indication of the issue.
    LMS 7.9 - 1xRadio, 1xBoom, 5xDuet,3xTouch, 1 SB2. Sony PlayStation, Emby, Chromecast v1 and v2 and...
    6xSqueezeAmp, several other ESP32-Wrover boards with jumper wires flying around, some with ethernet!

  3. #1593
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,898
    Quote Originally Posted by yateng View Post
    Hi all.
    Congratulations for your great job.
    I have a setup with a ILI9341 screen, 240 wide 320 height.
    Everithing fine, but, most of the times the album cover is not fully delivered to the screen, and the screen appears black at the bottom.
    It happens more frequently when the song finish at it's end and change to the new song.
    It you push the forward button to change to the next song, it happens less frequently.
    Any ideas?ç
    Thanks in advance.

    Javier
    I’ve seen that often with latest releases I did but I’ve not been able to figure out why. The image is fully sent to the device and I suspect something is happening at the local display level (like a race condition) but it is not driver dépendant. I’ve not been able to work on the project over the past few month.
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  4. #1594
    Junior Member
    Join Date
    Jun 2022
    Posts
    8

    Loading saved NVS Config from Web GUI

    Hi,

    New to this thread and it is a real help to someone who is a newbie to Squeezlite ESP32. I have been pulling my hair out even since I install my first Squeezelite ESP32, I don't seem to be able to load back a saved NVS config. file. I save a config in NVS editor and when I try to load it again (after erasing confg.), none of the setting changed (try load->commit->reboot, load->reboot etc.). I have try renaming it to .json etc. nothing works ! I really don''t want to re-type all the config. in again every time. This might be a stupid question, but if some one can shed some light on this will very appreciated.

    Bench

  5. #1595
    Senior Member sle118's Avatar
    Join Date
    Dec 2009
    Location
    Quebec City, Canada
    Posts
    502
    Quote Originally Posted by bench2015 View Post
    Hi,

    New to this thread and it is a real help to someone who is a newbie to Squeezlite ESP32. I have been pulling my hair out even since I install my first Squeezelite ESP32, I don't seem to be able to load back a saved NVS config. file. I save a config in NVS editor and when I try to load it again (after erasing confg.), none of the setting changed (try load->commit->reboot, load->reboot etc.). I have try renaming it to .json etc. nothing works ! I really don''t want to re-type all the config. in again every time. This might be a stupid question, but if some one can shed some light on this will very appreciated.

    Bench
    Which version are you running?
    LMS 7.9 - 1xRadio, 1xBoom, 5xDuet,3xTouch, 1 SB2. Sony PlayStation, Emby, Chromecast v1 and v2 and...
    6xSqueezeAmp, several other ESP32-Wrover boards with jumper wires flying around, some with ethernet!

  6. #1596
    Junior Member
    Join Date
    Jun 2022
    Posts
    8
    Quote Originally Posted by sle118 View Post
    Which version are you running?
    I am using balloob 's web installer, it install v1.1023. I also notice when there is no debug message when I open the config. file, when when I did it manually ie. commit config., there is debug message saying config changed.

  7. #1597
    Senior Member sle118's Avatar
    Join Date
    Dec 2009
    Location
    Quebec City, Canada
    Posts
    502
    Quote Originally Posted by bench2015 View Post
    I am using balloob 's web installer, it install v1.1023. I also notice when there is no debug message when I open the config. file, when when I did it manually ie. commit config., there is debug message saying config changed.
    Please download a binary file from here, unzip it and flash it.
    https://github.com/sle118/squeezelit...uns/2443074704

    I'm no longer maintaining the master branch, and I believe this issue was resolved in branch 4.3. We will eventually finish testing that branch and release from it, but we have limited bandwidth right now to make it happen.

    Thank you!
    LMS 7.9 - 1xRadio, 1xBoom, 5xDuet,3xTouch, 1 SB2. Sony PlayStation, Emby, Chromecast v1 and v2 and...
    6xSqueezeAmp, several other ESP32-Wrover boards with jumper wires flying around, some with ethernet!

  8. #1598
    Junior Member
    Join Date
    Jun 2022
    Posts
    8
    Quote Originally Posted by sle118 View Post
    Please download a binary file from here, unzip it and flash it.
    https://github.com/sle118/squeezelit...uns/2443074704

    I'm no longer maintaining the master branch, and I believe this issue was resolved in branch 4.3. We will eventually finish testing that branch and release from it, but we have limited bandwidth right now to make it happen.

    Thank you!
    Many thx will try that.

  9. #1599
    Junior Member
    Join Date
    Jun 2022
    Posts
    8
    Quote Originally Posted by bench2015 View Post
    Many thx will try that.
    It fixed. Many thx.

  10. #1600
    Junior Member
    Join Date
    Jul 2022
    Posts
    6
    Quote Originally Posted by sle118 View Post
    More info is needed if you want some help. Describe you hardware, including DAC, and more importantly the version you are running for squeezelite-esp32 as well as the plugin.

    Ideally, provide some logs that would give an indication of the issue.
    HI, thanks.
    My hardware is
    - ESP32-TTGO-T4 ,
    ESP32 chip (240Mhz dual core processor)
    Flash memory: 4MB
    PSRAM: 8MB
    Built-in 2.2 inch TFT display (ILI9341 driver)
    DAC is a PCM5102A DAC

    The audio works perfect, and the display, except for the art image problem.
    Squeezelite version fw: I2S-4MFlash.16.1034.master-v4.3, mode: Squeezelite-ESP32
    Plugin
    SqueezeESP32 v0.351
    Log

    [22-07-09 21:32:01.5357] Plugins::SqueezeESP32::Player::send_artwork (242) got resized artwork (length: 15842)
    [22-07-09 21:32:01.5371] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5390] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5406] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5423] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5440] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5457] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5474] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5489] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5504] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5517] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5531] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5546] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:01.5561] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 482
    [22-07-09 21:32:11.2058] Plugins::SqueezeESP32::Player::send_artwork (242) got resized artwork (length: 14503)
    [22-07-09 21:32:11.2073] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2091] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2108] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2124] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2139] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2157] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2173] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2187] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2201] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2215] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2229] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:11.2246] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 423
    [22-07-09 21:32:18.1192] Plugins::SqueezeESP32::Player::send_artwork (242) got resized artwork (length: 14021)
    [22-07-09 21:32:18.1211] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1233] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1255] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1277] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1296] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1311] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1325] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1340] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1357] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1372] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1280
    [22-07-09 21:32:18.1386] Plugins::SqueezeESP32::Player::send_artwork (248) sending grfa 1221

    The log seems ok, as sends the data to the ESP32, but the display sometimes show the whole picture and sometimes not.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •