Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Senior Member
    Join Date
    Jun 2017
    Posts
    266

    LMS 8 and "Play Next"

    Currently running LMS 8.0.0 - 1596004420 @ Wed Jul 29 08:48:51 CEST 2020 on Linux X86_64. It used to be that if I selected a track to Play Next, it would be added to the current playlist as the very next track, unless the current track was less than (approximately) 20 seconds from its end. With the current version, the current track must have more than a minute left to play. Otherwise, Play Next will add the selected track as the one AFTER the next track.

    Does anyone else see this behavior?
    LMS 8 nightly; 3 Squeezelite players connected by powerline ethernet; 5 wireless players connected via Airplay Bridge; 1 SqueezeAmp player
    no high-end or esoteric audio gear
    1 Squeezebox Radio (upgraded UE Smart Radio) now mostly retired

  2. #2
    Senior Member
    Join Date
    Jun 2017
    Posts
    266
    Is anyone willing to test this and report your results? So far as I know, I have used every nightly build that has been available in the past week, and I continue to experience this. If the current track has more than (approximately) one minute, fifteen seconds left to play, I can add another track to "Play Next" and will be added to the current playlist as the very next track. If less than 1:15 remains, the next track is unchanged and the new track is added after the next one.

    Has LMS changed when it begins caching the next track?
    LMS 8 nightly; 3 Squeezelite players connected by powerline ethernet; 5 wireless players connected via Airplay Bridge; 1 SqueezeAmp player
    no high-end or esoteric audio gear
    1 Squeezebox Radio (upgraded UE Smart Radio) now mostly retired

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,452

    LMS 8 and "Play Next"

    What kind of player are you using? Could it be you increased its buffer?
    Does it make a difference whether it's FLAC or lossy?
    --

    Michael

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,016
    Quote Originally Posted by RobbH View Post
    Is anyone willing to test this and report your results? So far as I know, I have used every nightly build that has been available in the past week, and I continue to experience this. If the current track has more than (approximately) one minute, fifteen seconds left to play, I can add another track to "Play Next" and will be added to the current playlist as the very next track. If less than 1:15 remains, the next track is unchanged and the new track is added after the next one.

    Has LMS changed when it begins caching the next track?
    I just tried this on my Pi4 server and was still able to add a track as next track less than 20 seconds from the end of the track. I tried at various times starting at around 50 seconds from the end and all of them were inserted as the immediate next track.

    Sent from my Pixel 3a using Tapatalk

  5. #5
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,847
    Quote Originally Posted by slartibartfast View Post
    I just tried this on my Pi4 server and was still able to add a track as next track less than 20 seconds from the end of the track. I tried at various times starting at around 50 seconds from the end and all of them were inserted as the immediate next track.
    Same here, less than 20 seconds no problem.
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.1.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 6.1.0/pi screen/Allo Boss DAC Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Squeezebox Radio

    Spares - 2xTouch, 1xSB3, 1xRadio, 7xRPi

  6. #6
    Senior Member
    Join Date
    Jun 2017
    Posts
    266
    Quote Originally Posted by mherger View Post
    What kind of player are you using? Could it be you increased its buffer?
    Does it make a difference whether it's FLAC or lossy?
    --

    Michael
    I don't think it matters if the file is FLAC or lossy, or if it's local or online, but I will do more testing to be sure. I'm usually playing several players synchronized, but I will try to isolate the problem and will report back when I know more.
    LMS 8 nightly; 3 Squeezelite players connected by powerline ethernet; 5 wireless players connected via Airplay Bridge; 1 SqueezeAmp player
    no high-end or esoteric audio gear
    1 Squeezebox Radio (upgraded UE Smart Radio) now mostly retired

  7. #7
    Senior Member
    Join Date
    Jun 2017
    Posts
    266
    Quote Originally Posted by slartibartfast View Post
    I just tried this on my Pi4 server and was still able to add a track as next track less than 20 seconds from the end of the track. I tried at various times starting at around 50 seconds from the end and all of them were inserted as the immediate next track.

    Sent from my Pixel 3a using Tapatalk
    Quote Originally Posted by kidstypike View Post
    Same here, less than 20 seconds no problem.
    Thanks to both of you! Now that I know the problem is mine, not LMS's, I should be able to isolate it.
    LMS 8 nightly; 3 Squeezelite players connected by powerline ethernet; 5 wireless players connected via Airplay Bridge; 1 SqueezeAmp player
    no high-end or esoteric audio gear
    1 Squeezebox Radio (upgraded UE Smart Radio) now mostly retired

  8. #8
    Senior Member
    Join Date
    Jun 2017
    Posts
    266
    The problem (Play Next doesn't work in the last 1:15 of the current track) occurs on three virtual players that are connected by ethernet, all running Squeezelite v1.9.7-1256 on LInux. One is 64-bit, and one is on piCorePlayer 6.1. My other players are connected over wifi, using the AirPlay bridge, and Play Next works normally on them.

    I also have a Radio, a Boom, and a SqueezeAmp, but they are not currently part of my "always-on" system, so they were not included in my description of the problem, and I did not test them.
    LMS 8 nightly; 3 Squeezelite players connected by powerline ethernet; 5 wireless players connected via Airplay Bridge; 1 SqueezeAmp player
    no high-end or esoteric audio gear
    1 Squeezebox Radio (upgraded UE Smart Radio) now mostly retired

  9. #9
    Senior Member
    Join Date
    Jun 2017
    Posts
    266
    A little more testing reveals that it was the resampling option, "-u E", that seems to have been the reason squeezelite was not handling the Play Next command as expected.
    LMS 8 nightly; 3 Squeezelite players connected by powerline ethernet; 5 wireless players connected via Airplay Bridge; 1 SqueezeAmp player
    no high-end or esoteric audio gear
    1 Squeezebox Radio (upgraded UE Smart Radio) now mostly retired

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •