Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    May 2020
    Posts
    7

    Rpi 4b as car audio player over bluetooth?

    Hi,

    I'm expanding my multiroom setup, have three players (2x Rpi 4b and 1x Rpi Zero W) with Hifiberry DACs and Amp2 stationary in my house.

    I have another Rpi 4b with Hifiberry DAC that I would like to use in my car as input to the car amplifier via RCA cables. For this it would need to function over bluetooth obviously without wifi present. When the car sits in the garage with full wifi strength it would be awesome if it can sync with the rest of the multiroom system. For this obviously the car needs to have the key in, which is no problem as it's got an off-grid battery pack. I bought a 5v/a3mp step down power supply to feed the Rpi.

    There's 2 problems;
    1. I can connect my iphone over bluetooth with the Rpi, it shows connected, but it's not listed as output option in Ios for Spotify/Soundcloud or as output from the navigation app. Are there any specifics that I need to do in terms of settings?
    2. It would be nice if the Rpi with PcP could boot up bluetooth quickly so eveything works when driving off, anything to tweak there? Also, are there any issues with just powering down the Rpi by just killing power? Would it possibly corrupt something?

    Many thanks in advance for help.

    Gr. Nelis

  2. #2
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,125
    Quote Originally Posted by Nelis View Post
    Hi,

    I'm expanding my multiroom setup, have three players (2x Rpi 4b and 1x Rpi Zero W) with Hifiberry DACs and Amp2 stationary in my house.

    I have another Rpi 4b with Hifiberry DAC that I would like to use in my car as input to the car amplifier via RCA cables. For this it would need to function over bluetooth obviously without wifi present. When the car sits in the garage with full wifi strength it would be awesome if it can sync with the rest of the multiroom system. For this obviously the car needs to have the key in, which is no problem as it's got an off-grid battery pack. I bought a 5v/a3mp step down power supply to feed the Rpi.

    There's 2 problems;
    1. I can connect my iphone over bluetooth with the Rpi, it shows connected, but it's not listed as output option in Ios for Spotify/Soundcloud or as output from the navigation app. Are there any specifics that I need to do in terms of settings?
    2. It would be nice if the Rpi with PcP could boot up bluetooth quickly so eveything works when driving off, anything to tweak there? Also, are there any issues with just powering down the Rpi by just killing power? Would it possibly corrupt something?

    Many thanks in advance for help.

    Gr. Nelis
    If I may, you can try to use my SqueezeAMP or a more simply an esp32 module with our SqueezeEsp32 software. I think it does what you want, boots in 3-4s, and (for the amp) can be powered by anything from 12 to 20V
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  3. #3
    Junior Member
    Join Date
    May 2020
    Posts
    7
    If I understand correctly that would require other hardware (the Amp)?

    I'd rather stick with the hardware that I have now, and get that working.

    I managed to solve point 1; I unchecked the onboard audio option is stumbled upon in the settings. Was able to connect the bluetooth after reboot and use it as output for all my apps with the iPhone.

    I would just make sure this is as fast and reliable as can be. Maybe make the bluetooth boot up first, so adjust the boot sequence so that has priority? What about running all that off the RAM memory instead of the SD?

  4. #4
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,125
    Quote Originally Posted by Nelis View Post
    If I understand correctly that would require other hardware (the Amp)?

    I'd rather stick with the hardware that I have now, and get that working.
    No worries, good luck with your project!
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  5. #5
    Junior Member
    Join Date
    May 2020
    Posts
    7
    Thanks! That’s helpfull. My iPhone now does connect but doesn’t show up as player. My girlfriend’s iPhone works flawless. Both iPhone 7 on same version ios.
    I’ll try that. There’s no way to influence this setting manually?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •