Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33
  1. #21
    Junior Member
    Join Date
    Jul 2017
    Posts
    19
    Quote Originally Posted by slartibartfast View Post
    I have some compilation albums of children's songs under the genre "Children". No other albums have this genre but the compilations all appear under the genre.

    Sent from my Pixel 3a using Tapatalk
    Do you have any of the artists on the compilation albums on album/s of their own? In any genre?

    I also have a genre called "Children", which is working correctly. Most of the artists have their own album/s. In this genre even the compilation album artists show up.

  2. #22
    Junior Member
    Join Date
    Jul 2017
    Posts
    19
    Quote Originally Posted by garym View Post
    I don't think it is the nonstandard genre. I have lots of those. It may be related to how LMS deals with artists that are ONLY in a complilation album. (this may have been changed in newer LMS versions, but at least in the old days this was an issue.) That is, if an artist is ONLY represented in a compilation album but nowhere else in the library, that artist name didn't show up when browsing by artist. One needed at least one track in a noncompilation album with that artist name. Something like that, this is all based on memories of things a while back.... So, maybe your DIGEST artists are only represented in compilations. take another noncompilation album, give it the name of one of the artists in the reader's digest comp, and see if that makes the DIGEST albums show up. Just as a test. edit: first do it without changing the genre of the test album to DIGEST, and if that doesn't work, also change the genre to digest. It may be a similar concept, if a genre is ONLY represented in a compilation album and nowhere else, it doesn't show up in browsing.
    I did your test. Copied an album and changed the artist to Perry Como. Which is one of the artists on the compilation albums. I set the test album to the "Digest" genre. This caused both the test album and the songs on the compilation album to appear under the "Digest" genre. Once I removed the test album from the "Digest" genre, all songs disappeared from the "Digest" genre.

    This is after I upgraded to the latest version of LMS.

  3. #23
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,852
    Quote Originally Posted by NoDad View Post
    Do you have any of the artists on the compilation albums on album/s of their own? In any genre?

    I also have a genre called "Children", which is working correctly. Most of the artists have their own album/s. In this genre even the compilation album artists show up.
    There are five albums with the genre "Children" and only one contains an artist who has an album in my library. If you have Dropbox you could share one of your "Digest" albums so we can see how it behaves in our libraries.

    Sent from my Pixel 3a using Tapatalk

  4. #24
    Junior Member
    Join Date
    Jul 2017
    Posts
    19
    Another test. I changed all songs on one of the Reader's Digest compilation albums to "Easy Listening" (I have two albums in this genre already), did a complete scan and all songs from the RD albums now shows up.

    So this led to another test. I changed the genre for two albums to "Digest", scanned and now all songs from all the compilations albums show up.

    I removed the "Digest" genre from the test albums. This now removed all songs from the genre.

    So to recap.
    1. The genre in question has three compilation albums with all songs marked as "Digest" genre.
    2. None of the compilation album songs show up in the genre, when looking in LMS.
    3. Adding one album to the "Digest" genre makes the songs for the artist, both the single artist album and the compilation album, show up in the "Digest" genre. None of the other artist's songs on the compilation album show up.
    4. Adding two albums to the "Digest" genre makes all songs show up. All artists on all compilation albums are now listed in the genre.
    5. Removing the "test" albums from the genre, makes all songs disappear from the genre (like number 2 above).


    Seems a genre needs at least two other albums listed in the genre to be able to recognize compilation album songs in the genre in question.

    One artist albums are OK, a genre gets recognized with only the one album.


    Can someone else please test this as well and let me know. Just curious is it's something wrong with my setup or if it's a bigger issue.

  5. #25
    Junior Member
    Join Date
    Jul 2017
    Posts
    19
    Quote Originally Posted by slartibartfast View Post
    There are five albums with the genre "Children" and only one contains an artist who has an album in my library. If you have Dropbox you could share one of your "Digest" albums so we can see how it behaves in our libraries.

    Sent from my Pixel 3a using Tapatalk
    No Dropbox unfortunately. Otherwise I'd share.

    I'm not sure it's related to just these albums though. It seems to be an issue with LMS not recognizing a compilation album by itself. Please see my tests above.

  6. #26
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,852
    Quote Originally Posted by NoDad View Post
    No Dropbox unfortunately. Otherwise I'd share.

    I'm not sure it's related to just these albums though. It seems to be an issue with LMS not recognizing a compilation album by itself. Please see my tests above.
    I'll try copying one of my "Children" albums to a Windows 10 server tomorrow to see if that acts differently to my Pi server. Is your LMS 8 up to date?

    Sent from my Pixel 3a using Tapatalk

  7. #27
    Junior Member
    Join Date
    Jul 2017
    Posts
    19
    Quote Originally Posted by slartibartfast View Post
    I'll try copying one of my "Children" albums to a Windows 10 server tomorrow to see if that acts differently to my Pi server. Is your LMS 8 up to date?

    Sent from my Pixel 3a using Tapatalk
    Yes. I installed the latest update today before the last few tests. It's running on a Windows 10 Pro machine. The files are stored on a WD 1TB Blue 3D NAND SATA III M.2 2280 Internal SSD. I don't see that it would make any difference as compared to a regular drive. I just wanted a quiet fanless computer.

    Thanks for helping.

  8. #28
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    It seems you and @slartibartfast are finding opposite results in your tests. His genres in compilations only are showing up, but yours are not. It would be nice to have one of your comp "Digest" albums. Dropbox accounts are free, at least for a small amount of storage. It would be nice to test with a few of your files.

    p.s. I doubt it can be related to the name "Digest" but just in case, have you changed the Genre on all these to something else and tested (e.g., "Readers Digest")
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  9. #29
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,519
    Does the OP use the "compilation" tag?

    Is the compilation tag set to "1", "0" or "Blank"?

    Does it make any difference?
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.1 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi4/pCP 7.0.1/Topping E30 DAC/Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  10. #30
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,852
    Quote Originally Posted by NoDad View Post
    Yes. I installed the latest update today before the last few tests. It's running on a Windows 10 Pro machine. The files are stored on a WD 1TB Blue 3D NAND SATA III M.2 2280 Internal SSD. I don't see that it would make any difference as compared to a regular drive. I just wanted a quiet fanless computer.

    Thanks for helping.
    Right, just tried my "Children" compilation on Windows 10 and I agree with you. It doesn't show up in "Compilations" or "Genres". The "Children" genre is present but empty. Something else for @mherger to look at.

    Sent from my Pixel 3a using Tapatalk

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •