Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 33
  1. #11
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,852
    Quote Originally Posted by NoDad View Post
    Looking at the album information it does say it's a compilation, see below
    Attachment 31140.
    I was forgetting the compilation tag isn't necessary. Still odd that the album gain doesn't match.

    Sent from my Pixel 3a using Tapatalk

  2. #12
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    Quote Originally Posted by NoDad View Post
    Maybe the album gain is different than the track gain?

    Looking at the album information it does say it's a compilation, see below.

    Attachment 31140.
    album gain *is* typically different from the track gain. But all tracks in a single album should have identical album gain.
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  3. #13
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,852
    Quote Originally Posted by garym View Post
    album gain *is* typically different from the track gain. But all tracks in a single album should have identical album gain.
    The track posted had album and track gain equal. That would be the kind of thing that would happen if you scanned each track for replaygain individually and not as an album.

    Sent from my Pixel 3a using Tapatalk

  4. #14
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    Quote Originally Posted by slartibartfast View Post
    The track posted had album and track gain equal. That would be the kind of thing that would happen if you scanned each track for replaygain individually and not as an album.

    Sent from my Pixel 3a using Tapatalk
    exactly. Which as you point out, indicates something odd going on if this is in fact supposed to be one album with one genre.
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  5. #15
    Junior Member
    Join Date
    Jul 2017
    Posts
    19
    Well, I re-ran the ReplayGain and now it shows -3.06 for the album and -3.14 for the same song as above.

    I also upgraded to the latest LMS and did a "clear library and rescan" (for the umpthenth time today) and all of a sudden all the songs are now listed in the Oldies genre. I'm thinking it's because I added a single artist album to the genre as well before scanning. This seem to have triggered LMS to realize the genre actually exists and added the American Graffiti album to the genre.

    I am going to try this with another genre as well as it is still empty.

  6. #16
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,852
    Quote Originally Posted by NoDad View Post
    Well, I re-ran the ReplayGain and now it shows -3.06 for the album and -3.14 for the same song as above.

    I also upgraded to the latest LMS and did a "clear library and rescan" (for the umpthenth time today) and all of a sudden all the songs are now listed in the Oldies genre. I'm thinking it's because I added a single artist album to the genre as well before scanning. This seem to have triggered LMS to realize the genre actually exists and added the American Graffiti album to the genre.

    I am going to try this with another genre as well as it is still empty.
    If all of your replaygain values are wrong try fixing that first and do a scan.

    Sent from my Pixel 3a using Tapatalk

  7. #17
    Junior Member
    Join Date
    Jul 2017
    Posts
    19
    The issue I'm having is not with ReplayGain. It was brought up as someone noticed it was a little off. Which may have been me scanning the songs incorrectly.

    My issue was and still is with songs not showing in certain genres. Doing some testing it might be a bug in the system. LMS doesn't seem to recognize a genre assigned to only compilation albums. For example, my wife wanted me to rip her parents Reader's Digest compilation LP albums, which (as the good husband I am :-) I did.

    A new genre for these songs; "Digest" was created. None of the songs/albums show up under this genre. As a test I changed a Frank Sinatra album to the "Digest" genre. Once I did, not only did the Sinatra album show up in the "Digest" genre, but also all Sinatra songs from the Reader's Digest compilation albums.

    Changing the Sinatra album back to Easy Listening genre, removed both the album and all Sinatra songs on the RD albums from being listed in the "Digest" genre. After each change I "Clear the library and rescan everything" to make sure the changes are implemented.

    Is this happening because I'm using a non-standard genre? Or, is it a bug which prevents LMS from recognizing genres for compilation albums?
    Last edited by NoDad; 2020-08-02 at 10:14. Reason: Spelling error

  8. #18
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    Quote Originally Posted by NoDad View Post
    The issue I'm having is not with ReplayGain. It was brought up as someone noticed it was a little off. Which may have been me scanning the songs incorrectly.

    My issue was and still is with songs not showing in certain genres. Doing some testing it might be a bug in the system. LMS doesn't seem to recognize a genre assigned to only compilation albums. For example, my wife wanted me to rip her parents Reader's Digest compilation LP albums, which (as the good husband I am :-) I did.

    A new genre for these songs; "Digest" was created. None of the songs/albums show up under this genre. As a test I changed a Frank Sinatra album to the "Digest" genre. Once I did, not only did the Sinatra album show up in the "Digest" genre, but also all Sinatra songs from the Reader's Digest compilation albums.

    Changing the Sinatra album back to Easy Listening genre, removed both the album and all Sinatra songs on the RD albums from being listed in the "Digest" genre. After each change I "Clear the library and rescan everything" to make sure the changes are implemented.

    Is this happening because I'm using a non-standard genre? Or, is it a bug which prevents LMS from recognizing genres for compilation albums?
    I don't think it is the nonstandard genre. I have lots of those. It may be related to how LMS deals with artists that are ONLY in a complilation album. (this may have been changed in newer LMS versions, but at least in the old days this was an issue.) That is, if an artist is ONLY represented in a compilation album but nowhere else in the library, that artist name didn't show up when browsing by artist. One needed at least one track in a noncompilation album with that artist name. Something like that, this is all based on memories of things a while back.... So, maybe your DIGEST artists are only represented in compilations. take another noncompilation album, give it the name of one of the artists in the reader's digest comp, and see if that makes the DIGEST albums show up. Just as a test. edit: first do it without changing the genre of the test album to DIGEST, and if that doesn't work, also change the genre to digest. It may be a similar concept, if a genre is ONLY represented in a compilation album and nowhere else, it doesn't show up in browsing.
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  9. #19
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,852
    Quote Originally Posted by garym View Post
    I don't think it is the nonstandard genre. I have lots of those. It may be related to how LMS deals with artists that are ONLY in a complilation album. (this may have been changed in newer LMS versions, but at least in the old days this was an issue.) That is, if an artist is ONLY represented in a compilation album but nowhere else in the library, that artist name didn't show up when browsing by artist. One needed at least one track in a noncompilation album with that artist name. Something like that, this is all based on memories of things a while back.... So, maybe your DIGEST artists are only represented in compilations. take another noncompilation album, give it the name of one of the artists in the reader's digest comp, and see if that makes the DIGEST albums show up. Just as a test. edit: first do it without changing the genre of the test album to DIGEST, and if that doesn't work, also change the genre to digest. It may be a similar concept, if a genre is ONLY represented in a compilation album and nowhere else, it doesn't show up in browsing.
    I have some compilation albums of children's songs under the genre "Children". No other albums have this genre but the compilations all appear under the genre.

    Sent from my Pixel 3a using Tapatalk

  10. #20
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    Quote Originally Posted by slartibartfast View Post
    I have some compilation albums of children's songs under the genre "Children". No other albums have this genre but the compilations all appear under the genre.

    Sent from my Pixel 3a using Tapatalk
    good info. Was just a guess on my part for this odd problem.
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •