Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 50
  1. #21
    Junior Member
    Join Date
    Aug 2009
    Posts
    27
    Just a quick thank you for this plugin. It's working great on my nightly of LMS 8.0. I couldn't find the Bandcamp login cookie in Safari but it can be found in Chrome.

  2. #22
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,655
    Logitech Media Server Version: 8.0.0 - 1604995301 @ Tue Nov 10 09:27:59 CET 2020
    Hostname: musicbox
    Server IP Address: 192.168.1.4
    Server HTTP Port Number: 9000
    Operating system: piCore - EN - utf8
    Platform Architecture: aarch64-linux
    Perl Version: 5.32.0 - aarch64-linux-thread-multi
    Audio::Scan: 1.02
    IO::Socket::SSL: 2.068
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
    Total Players Recognized: 5

    For a while now I have no Band Camp under My Apps.

    Plugin settings show this:

    Name:  bandcamp.jpg
Views: 158
Size:  23.6 KB

    Uninstalled, reinstalled plugin, cleared browser cache, nothing I've tried helps.

    Last few lines of server log:



    Code:
    [20-11-10 10:04:32.2510] main::init (388) Starting Logitech Media Server (v8.0.0, 1604555568, Thu Nov  5 09:29:13 CET 2020) perl 5.032000 - aarch64-linux-thread-multi[20-11-10 10:04:36.4538] Slim::Utils::PluginManager::load (392) Warning: Couldn't call Plugins::Bandcamp::Plugin->initPlugin: Can't use string ("12345678u_"...) as a HASH ref while "strict refs" in use at /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Bandcamp/Search.pm line 33.
    [20-11-10 10:07:20.9491] main::init (388) Starting Logitech Media Server (v8.0.0, 1604555568, Thu Nov  5 09:29:13 CET 2020) perl 5.032000 - aarch64-linux-thread-multi
    [20-11-10 10:08:27.1480] main::init (388) Starting Logitech Media Server (v8.0.0, 1604555568, Thu Nov  5 09:29:13 CET 2020) perl 5.032000 - aarch64-linux-thread-multi
    [20-11-10 10:08:31.1775] Slim::Utils::PluginManager::load (392) Warning: Couldn't call Plugins::Bandcamp::Plugin->initPlugin: Can't use string ("12345678u_"...) as a HASH ref while "strict refs" in use at /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Bandcamp/Search.pm line 33.
    [20-11-10 10:11:53.4704] main::init (388) Starting Logitech Media Server (v8.0.0, 1604995301, Tue Nov 10 09:27:59 CET 2020) perl 5.032000 - aarch64-linux-thread-multi [20-11-10 10:11:57.3925] Slim::Utils::PluginManager::load (392) Warning: Couldn't call Plugins::Bandcamp::Plugin->initPlugin: Can't use string ("12345678u_"...) as a HASH ref while "strict refs" in use at /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Bandcamp/Search.pm line 33.
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP 8.0.0 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi4/pCP 8.0.0/Topping E30 DAC/Ruark MR1 Mk2
    Lounge - Pi2/pCP 8.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  3. #23
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,433
    Working here on

    Logitech Media Server Version: 7.9.4 - 1603273368 @ Thu Oct 22 04:21:56 CEST 2020
    Hostname: LMS
    Server IP Address: 192.168.1.119
    Server HTTP Port Number: 9000
    Operating system: piCore - EN - utf8
    Platform Architecture: armv8l-linux
    Perl Version: 5.28.2 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 1.02
    IO::Socket::SSL: 2.066
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
    Total Players Recognized: 2


    v 1.8.3

    Name:  bandcamp.jpg
Views: 157
Size:  89.6 KB

    ronnie

  4. #24
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    [Announce] Band's Campout 1.8

    > For a while now I have no Band Camp under My Apps.
    >
    > Plugin settings show this:


    Go to Settings/Advanced/Bandcamp instead.

    > [20-11-10 10:04:32.2510] main::init (388) Starting Logitech Media Server (v8.0.0, 1604555568, Thu Nov 5 09:29:13 CET 2020) perl 5.032000 - aarch64-linux-thread-multi[20-11-10 10:04:36.4538] Slim::Utils::PluginManager::load (392) Warning: Couldn't call Plugins::Bandcamp::Plugin->initPlugin: Can't use string ("12345678u_"...) as a HASH ref while "strict refs" in use at /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Bandcamp/Search.pm line 33.


    Is this the literal error message you get?

    You should be able to recover by shutting down LMS and removing
    bandcamp.db from your cache folder.

    --

    Michael

  5. #25
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,655
    Quote Originally Posted by mherger View Post
    > For a while now I have no Band Camp under My Apps.
    >
    > Plugin settings show this:


    Go to Settings/Advanced/Bandcamp instead.

    > [20-11-10 10:04:32.2510] main::init (388) Starting Logitech Media Server (v8.0.0, 1604555568, Thu Nov 5 09:29:13 CET 2020) perl 5.032000 - aarch64-linux-thread-multi[20-11-10 10:04:36.4538] Slim::Utils::PluginManager::load (392) Warning: Couldn't call Plugins::Bandcamp::Plugin->initPlugin: Can't use string ("12345678u_"...) as a HASH ref while "strict refs" in use at /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Bandcamp/Search.pm line 33.


    Is this the literal error message you get?

    You should be able to recover by shutting down LMS and removing
    bandcamp.db from your cache folder.

    --

    Michael
    Not listed under Settings/Advanced/Bandcamp

    Name:  bandcamp2.jpg
Views: 155
Size:  27.0 KB

    Not literal, no, seems to have lost something in the copy/paste, picture below instead.

    Name:  bandcamp3.jpg
Views: 158
Size:  183.4 KB

    Deleted the file bandcamp.db and back in business.

    Thanks.
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP 8.0.0 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi4/pCP 8.0.0/Topping E30 DAC/Ruark MR1 Mk2
    Lounge - Pi2/pCP 8.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  6. #26
    Member
    Join Date
    Sep 2008
    Location
    Barcelona
    Posts
    61
    Sorry to bother with a problem but could not find anything after a whilesearching.
    Logitech Media Server Version: 7.9.3 running in Raspi 4B (Max2Play)
    Band's Campout v1.8.3

    When I go to "Music Feed" get this error (tried with iPeng and web interface):

    Plugins::Bandcamp::API::__ANON__ (144) There was an error accessing the data servers. Please double-check or re-set your identity cookie in the plugin settings.

    I've updated the Identity cookie value but no difference. Any clue?

    Other sections work fine (Wishlist, Bands). Only exception is "Collection" that is Empty (and no message in the server logs when using this option).

    Anybody has experienced something similar? I understand I must fill the identity cookie with the char string without "identity=" in front of it, isn't it?

    ------------------------------
    PS: edited to fix typo "Music Find" -> "Music Feed"
    Last edited by waldo; 2020-12-27 at 05:05.

  7. #27
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    [Announce] Band's Campout 1.8

    > When I go to "Music Find" get this error (tried with iPeng and web
    > interface):


    What exact menu is this?

    > -Plugins::Bandcamp::API::__ANON__ (144) There was an error accessing the
    > data servers. Please double-check or re-set your identity cookie in the
    > plugin settings.-


    I can't reproduce this issue. Maybe because I can't find the menu you're
    referring to.

    > Anybody has experienced something similar? I understand I must fill the
    > identity cookie with the char string without "identity=" in front of it,
    > isn't it?


    Yes.

    --

    Michael

  8. #28
    Member
    Join Date
    Sep 2008
    Location
    Barcelona
    Posts
    61
    Quote Originally Posted by mherger View Post
    > When I go to "Music Find" get this error (tried with iPeng and web interface)


    What exact menu is this?


    Hi Michael, didn't expect to see you on a Sunday!! There was a typo, it was "Music Feed" menu

  9. #29
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    [Announce] Band's Campout 1.8

    > Hi Michael, didn't expect to see you on a Sunday!! There was a typo, it
    > was "*Music Feed*" menu


    Ok. That's working fine here. Please enable logging for plugin.bandcamp,
    then upload your server.log.zip to:

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    (and don't forget to reset logging options afterwards)

    --

    Michael

  10. #30
    Member
    Join Date
    Sep 2008
    Location
    Barcelona
    Posts
    61
    Quote Originally Posted by mherger View Post
    > Hi Michael, didn't expect to see you on a Sunday!! There was a typo, it
    > was "*Music Feed*" menu


    Ok. That's working fine here. Please enable logging for plugin.bandcamp,
    then upload your server.log.zip to:

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    (and don't forget to reset logging options afterwards)

    --

    Michael
    Done!
    Two files uploaded just in case:
    1.- Waldo_BandCamp_MusicFeed.log : the part of the logs for BandCamp plugin
    2.- Waldo_Server.log: server log starting with a reboot (BandCamp Plugin contents located at the end)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •