Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 106

Hybrid View

  1. #1
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,069

    EXPERIMENTAL: "reliable" plugin for HTTP(S) streaming

    Well... you should probably not believe the title too much

    This is an attempt to make HTTP/HTTPS streaming more reliable as some of us seem to experiment issues, for example with podcasts.

    This plugin has many hacks and does dangerous things to LMS, be warned

    In the background, it replaces the HTTP and HTTPS classes by a new one that has the possibility to re-open an HTTP connection when it fails. As said, it is *very* experimental. Once you enabled it in the settings, *all* HTTP and HTTPS streams will go through it and will be proxied. Of course, you can disable it in the settings

    It's very (very) lightly tested at that moment, so don't throw arrows if it does not work but I'd like to get early feedback from whoever is having these issues to know if it helps or not.

    http://downloads.sourceforge.net/pro...ev/repo-sf.xml
    Last edited by philippe_44; 2020-07-02 at 23:16.
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,452
    Where can we find it?
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  3. #3
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,069
    Quote Originally Posted by mherger View Post
    Where can we find it?
    Oops ... this is so funny

    http://downloads.sourceforge.net/pro...ev/repo-sf.xml
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  4. #4
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,069

    EXPERIMENTAL: "reliable" plugin for HTTP(S) streaming

    Sorry guys but there is some crap issue between Windows & Linux at the moment, and my working Windows version gives me a lot of s... on Linux. Stupid dos2unix and other things, but it's late and in addition the SF site has decided to be non-responsive, so too much is too much. I'll fix that tomorrow. Meanwhile, if you make it work, pleased don't forget to force your player in proxy mode for now.
    Last edited by philippe_44; 2020-07-03 at 01:34.
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  5. #5
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,069
    Fixed now
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  6. #6
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,069

    EXPERIMENTAL: "reliable" plugin for HTTP(S) streaming

    I've done many tweaks and it seems to be acceptable now for the adventurous. I've verified a couple of times with very long podcasts (1 hour) that when normal streaming process fails it is able to resume seamlessly
    Last edited by philippe_44; 2020-07-04 at 00:19.
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  7. #7
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,017
    Just tried this with one of the Sorcerer's Orphan podcasts that always suffered from this issue. The RSS feed disappeared for a long time but now seems to be back. I am pleased to say It played from start to finish. I played it again to try pausing and seeking and didn't see any issues there either. Sound resumed after both pausing and seeking for me although from a brief test I can't say it will never happen.
    Great work

    Sent from my Pixel 3a using Tapatalk

  8. #8
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    1,290
    I this a replacement for the official podcast plugin?
    QLMS 8.0.0@2.21 x64 (digimaster) with perl 5.30.1 / QNAP 469L QTS 4.3.4

  9. #9
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,017
    Quote Originally Posted by dolodobendan View Post
    I this a replacement for the official podcast plugin?
    No you still need the podcast plugin.

    Sent from my Pixel 3a using Tapatalk

  10. #10
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    1,290
    Quote Originally Posted by slartibartfast View Post
    No you still need the podcast plugin.

    Sent from my Pixel 3a using Tapatalk
    Okay, thanks!
    QLMS 8.0.0@2.21 x64 (digimaster) with perl 5.30.1 / QNAP 469L QTS 4.3.4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •