Home of the Squeezebox™ & Transporter® network music players.
Page 17 of 30 FirstFirst ... 7151617181927 ... LastLast
Results 161 to 170 of 299
  1. #161
    Senior Member mvordeme's Avatar
    Join Date
    Jan 2009
    Location
    Germany
    Posts
    301
    It looks like my daughter's old problem with playlists being restricted to 50 tracks is fixed, too. Thanks a lot.
    SCALEO Home Server 2105 | Logitech Media Server 8.0.0 | Server Power Control 20120716.103808 | Transporter & Duet & Touch & Boom & Radio | Rotel RC-995 & RMB-100 | Nubert NuVero 140

  2. #162

    Tracks from Tidal coming as MP4?

    Hi,

    Continuing to test Tidal integration, I've noticed there was an album from Tidal that wasn't playing: American VI: Ain't No Grave from Johnny Cash. I'm running LMS 7.9.3 on Debian and squeezelite for playback. When running squeezelite with -d stream=debug, this what I get when playing a track from the album:

    Code:
    [12:14:14.589288] stream_thread:247 headers: len: 476
    HTTP/1.1 200 OK
    Content-Type: audio/mp4
    Last-Modified: Sat, 27 Sep 2014 08:21:30 GMT
    ETag: "0ee74e2fbc5bf3ecd5058ee8013881ff"
    cache-control: max-age=31536000
    Access-Control-Allow-Origin: *
    Accept-Ranges: bytes
    Age: 866654
    Content-Length: 6973519
    Accept-Ranges: bytes
    Date: Fri, 11 Sep 2020 11:14:14 GMT
    Via: 1.1 varnish
    Connection: close
    X-Served-By: cache-bwi5130-BWI, cache-mad22053-MAD
    X-Cache: HIT
    X-Cache-Hits: 0, 0
    X-Timer: S1599822855.580562,VS0,VE0
    
    
    [12:14:15.311760] stream_thread:320 end of stream
    Another album will be presented like this and this one plays fine:

    Code:
    [12:13:58.998226] stream_thread:247 headers: len: 565
    HTTP/1.1 200 OK
    Content-Type: audio/flac
    Access-Control-Allow-Headers: Origin
    Access-Control-Allow-Methods: GET, HEAD, OPTIONS
    ETag: "3bb27f3e6d8f7fd987bcc0d3cdc7c452"
    Last-Modified: Wed, 08 Feb 2017 14:08:54 GMT
    Access-Control-Allow-Origin: *
    cache-control: max-age=31536000
    Accept-Ranges: bytes
    Age: 43951
    Content-Length: 24484431
    Accept-Ranges: bytes
    Date: Fri, 11 Sep 2020 11:13:58 GMT
    Via: 1.1 varnish
    Connection: close
    X-Served-By: cache-bwi5136-BWI, cache-mad22030-MAD
    X-Cache: HIT
    X-Cache-Hits: 0, 0
    X-Timer: S1599822839.987418,VS0,VE0
    I'm wondering then if this is some kind of video rather than audio but if this is the case, shouldn't this not show on the search results or when browsing the library?

  3. #163
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,278
    Quote Originally Posted by nunovi View Post
    Hi,

    Continuing to test Tidal integration, I've noticed there was an album from Tidal that wasn't playing: American VI: Ain't No Grave from Johnny Cash. I'm running LMS 7.9.3 on Debian and squeezelite for playback. When running squeezelite with -d stream=debug, this what I get when playing a track from the album:
    .
    .
    .
    I'm wondering then if this is some kind of video rather than audio but if this is the case, shouldn't this not show on the search results or when browsing the library?
    I think you need LMS8 to play AAC/mp4 Tidal see
    https://forums.slimdevices.com/showt...l=1#post984147

  4. #164
    Quote Originally Posted by bpa View Post
    I think you need LMS8 to play AAC/mp4 Tidal see
    https://forums.slimdevices.com/showt...l=1#post984147
    Hi bpa,

    Thanks for the quick answer. I'll try with LMS 8 and check if that works.

  5. #165
    Quote Originally Posted by nunovi View Post
    Hi bpa,

    Thanks for the quick answer. I'll try with LMS 8 and check if that works.
    Just installed LMS 8. Still skips all tracks from this album. This is what I get now on squeezelite:

    Code:
    [13:00:14.613674] stream_thread:247 headers: len: 493
    HTTP/1.1 200 OK
    Server: Logitech Media Server (8.0.0 - 1599750927)
    Connection: close
    Content-Type: audio/x-flac
    Set-Cookie: Squeezebox-albumView=; path=/
    Set-Cookie: Squeezebox-expandPlayerControl=true; path=/
    Set-Cookie: Squeezebox-expanded-MY_MUSIC=1; path=/
    Set-Cookie: Squeezebox-expanded-FAVORITES=0; path=/
    Set-Cookie: Squeezebox-expanded-PLUGINS=0; path=/
    Set-Cookie: Squeezebox-expanded-PLUGIN_MY_APPS_MODULE_NAME=1; path=/
    Set-Cookie: Squeezebox-expanded-RADIO=0; path=/
    
    
    [13:00:14.654697] stream_thread:320 end of stream
    [13:00:15.380580] _tcp_connect:486 connecting to 192.168.2.237:9000
    [13:00:15.380717] stream_sock:577 header: GET /stream.mp3?player=ac:1f:6b:24:c5:86 HTTP/1.0
    On File Types I have FLAC as native with the other FLAC options disabled. Do I need any specific configuration for AAC or MPEG-4? Any additional libraries are required on Debian to make this work?

  6. #166
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    Attention TIDAL users - changesahead!

    > Continuing to test Tidal integration, I've noticed there was an album
    > from Tidal that wasn't playing: American VI: Ain't No Grave from Johnny


    That's playing fine here.

    > Cash. I'm running LMS 7.9.3 on Debian and squeezelite for playback. When
    > running squeezelite with -d stream=debug, this what I get when playing a
    > track from the album:


    Please make sure your squeezelite does support AAC playback. This track
    seems not to be available in FLAC.

    > I'm wondering then if this is some kind of video rather than audio but
    > if this is the case, shouldn't this not show on the search results or
    > when browsing the library?


    It's AAC in a mp4 container, audio. The file size would be way too small
    for video anyway.

    --

    Michael

  7. #167
    Senior Member
    Join Date
    Dec 2018
    Location
    The Netherlands
    Posts
    106
    Quote Originally Posted by bpa View Post
    I think you need LMS8 to play AAC/mp4 Tidal see
    https://forums.slimdevices.com/showt...l=1#post984147
    AFAIK you only need LMS8 for players that do not have native support for AAC (like Squeezebox Boom). Only LMS8 can transcode Tidal AAC streams to FLAC or MP3.
    Recent Squeezelite versions have native support for AAC, and in my experience do not require LMS8 for playback of Tidal AAC.
    | LMS 8.0 | Squeezebox Boom | RPi0W + pCP 6.1.0 + HiFiBerry DAC Zero | SqueezeAMP |

  8. #168
    Quote Originally Posted by mherger View Post
    > Continuing to test Tidal integration, I've noticed there was an album
    > from Tidal that wasn't playing: American VI: Ain't No Grave from Johnny


    That's playing fine here.

    > Cash. I'm running LMS 7.9.3 on Debian and squeezelite for playback. When
    > running squeezelite with -d stream=debug, this what I get when playing a
    > track from the album:


    Please make sure your squeezelite does support AAC playback. This track
    seems not to be available in FLAC.

    > I'm wondering then if this is some kind of video rather than audio but
    > if this is the case, shouldn't this not show on the search results or
    > when browsing the library?



    It's AAC in a mp4 container, audio. The file size would be way too small
    for video anyway.

    --

    Michael
    Hi Michael,

    Glad to hear it's working there, must be something local then. The track does not play also on my Squeezebox Radio so I'd think this should be somehow related to LMS or missing libraries...

    Do you have any specific setting on File Types to transcode or are you sending the audio native? It's curious that after updating to LMS 8, the log on Squeezelite shows the mime type to be audio/x-flac and not audio/mp4 anymore.

    I'm using squeezelite v1.9.7-1256 with Build options: LINUX ALSA EVENTFD RESAMPLE ALAC OPUS VISEXPORT IR GPIO DSD SSL LINKALL if that helps. libasound2 is up to date and also have libfdk-acc1 installed.

    Anyway, if anyone has hint where to look that would be appreciated.

  9. #169
    Quote Originally Posted by CJS View Post
    AFAIK you only need LMS8 for players that do not have native support for AAC (like Squeezebox Boom). Only LMS8 can transcode Tidal AAC streams to FLAC or MP3.
    Recent Squeezelite versions have native support for AAC, and in my experience do not require LMS8 for playback of Tidal AAC.
    Hi CJS,

    Thanks, that's very useful info. As just posted, I'm using a fairly recent version of Squeezelite and doesn't play on my Squeezebox Radio either...

  10. #170
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    Attention TIDAL users - changesahead!

    > Thanks, that's very useful info. As just posted, I'm using a fairly
    > recent version of Squeezelite and doesn't play on my Squeezebox Radio
    > either...

    Did you try with the latest 8.0, no changes applied? Or would you eg.
    have a custom-convert file, modified transcoding settings etc.?

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •