Home of the Squeezebox™ & Transporter® network music players.
Page 31 of 31 FirstFirst ... 21293031
Results 301 to 305 of 305
  1. #301
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    Attention TIDAL users - changesahead!

    > is there a way to integrate Tidal Connect?

    Unfortunately no, there's no documentation available for this.

    --

    Michael

  2. #302
    Junior Member
    Join Date
    Oct 2012
    Posts
    16

    5-10 % of songs I play on Tidal Stutter since HiFi upgrade

    Quote Originally Posted by loungelizard View Post
    Tidal is up YAY!! I have seen stuttering on two tracks in my playlist(My MIx 3) of 40 songs and they are by Milky Chance (Daydreaming and Oh Mama). I can skip the Milky Chance song and the stuttering stops and if I go back to a Milky Chance the stuttering happens again. I am so excited, the issue is very reproducible today.
    I guess I go to Tidal and report this?

    The log file does not seem to have anything corelated to the event:

    LOG file excerpt during the stuttering:

    [20-10-19 10:49:01.2414] Slim::Player::Squeezebox2::directHeaders (544) Processing 18 headers
    [20-10-19 10:49:01.2418] Slim::Player::Squeezebox2::directHeaders (550) Calling Slim::Plugin::WiMP::ProtocolHandler :arseDirectHeaders
    [20-10-19 10:49:01.2439] Slim::Player::Client::streamingProgressBar (1125) url=http://sp-pr-fa.audio.tidal.com/mediatracks/CAEaKRInYzMzMzg2ODIzYWJmZDU5ODZlMjRjOGE2MTVkNzU0ND ZfNjEubXA0/0.flac?token=1603122498~MGRkNDA3ZGE1OTI3YmQ0YmFjYW IyYTgwNjllNGYyNDU4OWFkOGY3NA==, duration=undef, bitrate=854412, contentLength=21146713
    [20-10-19 10:49:01.2447] Slim::Player::Client::streamingProgressBar (1166) Duration of stream set to 198.00014981063 seconds based on length of 21146713 and bitrate of 854412
    [20-10-19 10:49:01.2451] Slim::Player::Squeezebox2::directHeaders (612) Got a stream type: flc bitrate: 854412 title: undef
    [20-10-19 10:49:01.2456] Slim::Player::Squeezebox2::directHeaders (663) Beginning direct stream!
    [20-10-19 11:08:28.9162] Slim::Utils::Cache::cleanup (169) Squeezebox Receive is still playing or being used. Let's postpone the cleanup some more. (Idle time: 2s)
    I have included a log file with debug turned on as suggested by Phillipe, I highlighted the log file as per below. Confirmed that songs that stuttered yesterday stutter again today. I sent a ticket to Tidal, waiting to hear back.


    ================================================== ================================================== ====================================
    I Select the Song that always causes stuttering, "Alaska", by Maggie Rogers. Song starts stuttering after 10 seconds Bit rate 797 kbps
    ================================================== ================================================== ====================================


    ================================================== =======================================
    Now I Select next song >> , The stuttering stops and is playing "Anemone" by Slenderbodies
    ================================================== =======================================
    Attached Files Attached Files

  3. #303
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,305
    Quote Originally Posted by loungelizard View Post
    I have included a log file with debug turned on as suggested by Phillipe, I highlighted the log file as per below. Confirmed that songs that stuttered yesterday stutter again today. I sent a ticket to Tidal, waiting to hear back.
    Look likes the stream is being played "direct" by the player - which means LMS is not the issues but possibly network problems if "hard" player - if a "soft" player then maybe some processor problems.

    What is the player ?
    How is the player networked ?
    If it is a old SB player - no additional logs available - can Tidal be run with LMS and "proxied" stream on the player ? What is the WHS system ?
    If it is a Touch/Radio or Pi - then player logging should be enabled.
    If it is a "bridge" player (e.g. Airplay, Chromecast, upnp) - then special logging should be enabled.

  4. #304
    Junior Member
    Join Date
    Oct 2012
    Posts
    16
    Quote Originally Posted by bpa View Post
    Look likes the stream is being played "direct" by the player - which means LMS is not the issues but possibly network problems if "hard" player - if a "soft" player then maybe some processor problems.

    What is the player ?
    How is the player networked ?
    If it is a old SB player - no additional logs available - can Tidal be run with LMS and "proxied" stream on the player ? What is the WHS system ?
    If it is a Touch/Radio or Pi - then player logging should be enabled.
    If it is a "bridge" player (e.g. Airplay, Chromecast, upnp) - then special logging should be enabled.
    I have Original squeezebox Duet in two places. Receiver connection: One is wired and one is connected to Wifi. The logs were connected on the Wifi connected receiver, but i see the same issue on both. These songs work fine on PC or iPhone. These songs cause stuttering:

    https://tidal.com/browse/track/102221758 Maggie Rogers Alaska, Tidal labelled Masters.
    https://tidal.com/browse/track/115083765 Milky Chance
    https://tidal.com/browse/track/120207704 Milky Chance
    https://tidal.com/browse/track/120207705 Milky Chance
    https://tidal.com/browse/track/120207706 Milky Chance


    WHS is running on Zeon X3440 at 2.53 GHz. 4G of RAM. Never see CPU usage above 2%.

  5. #305
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,305
    Quote Originally Posted by loungelizard View Post
    I have Original squeezebox Duet in two places. Receiver connection: One is wired and one is connected to Wifi. The logs were connected on the Wifi connected receiver, but i see the same issue on both. These songs work fine on PC or iPhone. These songs cause stuttering:

    https://tidal.com/browse/track/102221758 Maggie Rogers Alaska, Tidal labelled Masters.
    https://tidal.com/browse/track/115083765 Milky Chance
    https://tidal.com/browse/track/120207704 Milky Chance
    https://tidal.com/browse/track/120207705 Milky Chance
    https://tidal.com/browse/track/120207706 Milky Chance


    WHS is running on Zeon X3440 at 2.53 GHz. 4G of RAM. Never see CPU usage above 2%.
    Just for clarity - I understand "stuttering" to mean audio gaps in an audio stream where no audio is lost just there is added chunks of silence.

    Unfortunately with SB Receiver - no additional logging is available to indicate the problem as stream is direct between station and player. The Receiver has a smallish buffer (especially compared to iPhone or PC) when playing Flac so an "uneven" network stream can result in gaps.
    You should try enabling "proxied streaming" for each of the affected players. See WebUI Settings/Player/Audio/Streaming method "proxied streaming". This means network streams will first be be received by the LMS server, buffered (more than Receiver) and then sent onto Receiver. It can smooth out a "lumpy" network stream.

    Another less likely possible cause could be these songs are highly compressed and require more processing compared to other songs. There are ways to check this by enabling "flac to flac" transcode on LMS to decode and re-encode Flac streams at a lower compression level.
    Last edited by bpa; 2020-10-22 at 12:09.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •