Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Senior Member
    Join Date
    Jul 2008
    Posts
    248
    I'm working on getting LMS functioning again on Alpine 3.13.2. I'd say "Don't Panic!" except I don't think anybody except me is using my packages. I upgraded my server earlier to Alpine 3.13.2 and didn't realize until 8 hours or so later that LMS isn't starting. Perl version changed to:

    This is perl 5, version 32, subversion 0 (v5.32.0) built for x86_64-linux-thread-multi

    which I think is the culprit. I'm currently rebuilding the modules. We'll see how good my notes were.
    Last edited by sodface; 2021-02-21 at 06:52.

  2. #12
    Senior Member
    Join Date
    Jul 2008
    Posts
    248
    New modules package uploaded to repo:
    lms-modules-8.2-r0.apk

    for x86_64 only. Let me know if anyone needs any other architecture built.

    LMS is back up and running for me.

    [21-02-20 20:40:31.8953] main::init (389) Starting Logitech Media Server (v8.2.0, 1613803910, Sat Feb 20 08:18:40 CET 2021) perl 5.032000 - x86_64-linux-thread-multi
    Last edited by sodface; 2021-02-20 at 18:51.

  3. #13
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    My Alpine Linux Repo for LMS and Squeezelite

    > New modules package uploaded to repo:
    > lms-modules-8.2-r0.apk
    >
    > for x86_64 only. Let me know if anyone needs any other architecture
    > built.


    Haha... for a short moment I was wondering whether this would allow me
    to run LMS on the iPhone using iSH . But that seems to be 686, rather
    than x86_64.

  4. #14
    Senior Member
    Join Date
    Jul 2008
    Posts
    248
    I decided I wanted to rename the lms packages slightly to make them less version specific except for the lms-nocpan package. Probably a bad idea as I borked up my own server install and ended up having to walk through the setup again like it was an initial install. Oops.

    Here's the new package names with most of them just being "8" and lms-nocpan being more specific:

    lms-openrc-8-r0 x86_64 {lms} (GPL-2.0) [installed]
    lms-8-r0 x86_64 {lms} (GPL-2.0) [installed]
    lms-modules-8-r0 x86_64 {lms-modules} (GPL-2.0) [installed]
    lms-utils-8-r0 x86_64 {lms-utils} (GPL-2.9) [installed]
    lms-nocpan-8.2.0.1614180387-r0 x86_64 {lms-nocpan} (GPL-2.0) [installed]
    Last edited by sodface; 2021-02-24 at 15:54.

  5. #15
    Senior Member
    Join Date
    Feb 2019
    Posts
    258
    Quote Originally Posted by sodface View Post
    I decided I wanted to rename the lms packages slightly to make them less version specific except for the lms-nocpan package. Probably a bad idea as I borked up my own server install and ended up having to walk through the setup again like it was an initial install. Oops.

    Here's the new package names with most of them just being "8" and lms-nocpan being more specific:

    lms-openrc-8-r0 x86_64 {lms} (GPL-2.0) [installed]
    lms-8-r0 x86_64 {lms} (GPL-2.0) [installed]
    lms-modules-8-r0 x86_64 {lms-modules} (GPL-2.0) [installed]
    lms-utils-8-r0 x86_64 {lms-utils} (GPL-2.9) [installed]
    lms-nocpan-8.2.0.1614180387-r0 x86_64 {lms-nocpan} (GPL-2.0) [installed]
    Hello sodface
    Are you still working on this as I would like another go at it.
    diode84

  6. #16
    Senior Member
    Join Date
    Jul 2008
    Posts
    248
    Quote Originally Posted by diode84 View Post
    Hello sodface
    Are you still working on this as I would like another go at it.
    diode84
    Hi diode84, yes still have the repo up, currently with versions:

    lms-openrc-8-r0 x86_64 {lms} (GPL-2.0)
    lms-8-r0 x86_64 {lms} (GPL-2.0)
    lms-modules-8-r0 x86_64 {lms-modules} (GPL-2.0)
    lms-utils-8-r0 x86_64 {lms-utils} (GPL-2.9)
    lms-nocpan-8.2.0.1614990095-r0 x86_64 {lms-nocpan} (GPL-2.0)

    aarch64 I didn't "fix" yet to a more generic version 8 and it's a lot behind because I also apparently missed the 8.1 to 8.2 version switch in the script I have cron'd to pull updates and besides that, the builder is an RPi4 which is currently reloaded with armv7 building a kernel for another project I'm working on so aarch64 updates to the below packages might not happen for a bit:

    lms-8.0-r2.apk
    lms-modules-8.0-r0.apk
    lms-nocpan-8.0.1.1608617100-r0.apk
    lms-openrc-8.0-r2.apk
    lms-utils-8.0-r0.apk

    armel however, confusingly, seems to be more current than aarch64:

    lms-8.0-r2.apk
    lms-modules-8.0-r0.apk
    lms-nocpan-8.2.0.1614990095-r0.apk
    lms-openrc-8.0-r2.apk
    lms-utils-8.0-r0.apk

    So it looks like I need to get my repos straightened out. But I think you are only interested in x86_64?

  7. #17
    Senior Member
    Join Date
    Feb 2019
    Posts
    258
    Quote Originally Posted by sodface View Post
    Hi diode84, yes still have the repo up, currently with versions:


    So it looks like I need to get my repos straightened out. But I think you are only interested in x86_64?
    Yes, at first x86.
    Thanks

  8. #18
    Junior Member
    Join Date
    Jun 2021
    Posts
    1
    I'm interrestend in your repo. I would like to try installing LMS in an Alpine LXC container (currently using Debian in LXC). If your repository is still working, I would try to do a test install. The architecture is x86_64 of course.

  9. #19
    Senior Member
    Join Date
    Jul 2008
    Posts
    248
    Quote Originally Posted by pocok View Post
    I'm interrestend in your repo. I would like to try installing LMS in an Alpine LXC container (currently using Debian in LXC). If your repository is still working, I would try to do a test install. The architecture is x86_64 of course.
    Sorry I missed your post. Yes, the repo should still be working. See Post #1, basically download my public key and add to /etc/apk/keys/ and then add http://www.sodface.com/repo to /etc/apk/repositories. Then sudo apk add lms.

  10. #20
    Senior Member
    Join Date
    Jul 2008
    Posts
    248
    Alpine 3.14 just came out on 6/15 and I hadn't upgraded my server yet, which I did this morning - lms seems to still be working after a reboot so that's good!

    Current package versions for x86_64 are:

    lms-openrc-8-r0 x86_64 {lms} (GPL-2.0) [installed]
    lms-8-r0 x86_64 {lms} (GPL-2.0) [installed]
    lms-modules-8-r1 x86_64 {lms-modules} (GPL-2.0) [installed]
    lms-utils-8-r1 x86_64 {lms-utils} (GPL-2.9) [installed]
    lms-nocpan-8.2.0.1623987577-r0 x86_64 {lms-nocpan} (GPL-2.0) [installed]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •