Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Senior Member
    Join Date
    Jul 2018
    Location
    Oceanside, SoCal
    Posts
    101
    Mr. Herger,

    When PaleMoon was set as my default browser it allowed me to check the Insecure HTTPS box or not and it would hold either setting through an LMS restart; but with the box unchecked SDT would not update. With Firefox or IE set as the default browser the Insecure HTTPS setting always checks the box after an LMS restart (manual or computer reboot). I have not tried any other browsers.

    Eeyore

  2. #12
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    HTTPS vs HTTP and SuperDateTimeplugin

    > When PaleMoon was set as my default browser it allowed me to check the
    > Insecure HTTPS box or not and it would hold either setting through an
    > LMS restart; but with the box unchecked SDT would not update. With
    > Firefox or IE set as the default browser the Insecure HTTPS setting
    > always checks the box after an LMS restart (manual or computer reboot).
    > I have not tried any other browsers.


    But would checking/un-checking that pref change anything wrt. the
    SuperDateTime plugin?

    --

    Michael

  3. #13
    Senior Member
    Join Date
    Jul 2018
    Location
    Oceanside, SoCal
    Posts
    101
    Mr. Herger,

    I had never tried changing the Insecure HTTPS setting without restarting LMS immediately after. So I changed the setting to "full" HTTPS (box unchecked) without restarting. SDT gave me the ? on the screen which means that it can not update. But when I restart LMS the setting reverts to the box being checked and SDT not giving me the ?.

    Additionally, I uninstalled and reinstalled PaleMoon and it is now acting just like FireFox and IE. It will always enable the Insecure HTTPS by check marking the box after a restart of LMS. Previously it would hold the setting I applied even when restarting.

    I guess that I should be lucky that MY default Insecure HTTPS setting, with the box checked, allows SDT to update.

    Oh Oh! I just received a notification that LMS has an update. I will have to see if this cures my problem.

    Eeyore

  4. #14
    Senior Member
    Join Date
    Jul 2018
    Location
    Oceanside, SoCal
    Posts
    101
    Mr. Herger,

    FWIW. The latest update to LMS (8.0.0-1590868953) did not change anything.

    Eeyore

  5. #15
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    HTTPS vs HTTP and SuperDateTimeplugin

    > I guess that I should be lucky that MY default Insecure HTTPS setting,
    > with the box checked, allows SDT to update.


    Please forget your browser for a moment. I can't fix your browser. I can
    only fix LMS.

    You started this thread complaining about SDT not being able to render
    some stuff. Now you say it's ok, if you don't change LMS settings. So
    the solution to your problem simply is to not change that LMS setting,
    right?

    There's a reason for the settings behaviour you're seeing: it's enabled
    by default because your system is known to have a problem with strict HTTPS.

    --

    Michael

  6. #16
    Senior Member
    Join Date
    Jul 2018
    Location
    Oceanside, SoCal
    Posts
    101
    Mr Herger,

    I am happy that my default setting for Insecure HTTPS allows SDT to work properly. I am just curious as to why, previously, I could set Insecure HTTPS to enabled or disabled and the setting would hold through an LMS restart; I could set it so that SDT would update or not. But now it operates differently. Did you change something in LMS?

    Thanks,

    Eeyore

  7. #17
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    HTTPS vs HTTP and SuperDateTimeplugin

    > I am happy that my default setting for Insecure HTTPS allows SDT to work
    > properly. I am just curious as to why, previously, I could set Insecure
    > HTTPS to enabled or disabled and the setting would hold through an LMS
    > restart; I could set it so that SDT would update or not. But now it
    > operates differently. Did you change something in LMS?


    The setting indeed is a relatively recent addition (well, a year
    ago...). If some browser made you believe it did survive a restart, then
    that's a browser problem, because the setting would be reset on every
    restart on Windows.

    I'm going to hide that setting on that OS, as it's obviously confusing
    to have it, when it doesn't stick.

    --

    Michael

  8. #18
    Senior Member
    Join Date
    Jul 2018
    Location
    Oceanside, SoCal
    Posts
    101
    Mr. Herger,

    I am sorry to see that you removed the Insecure HTTPS setting; it IS gone from the latest nightly update (LogitechMediaServer-8.0.0-1590897265). It is useful to be able to see that a system may not be using "full" HTTPS. I am sure that many/most LMS users could use the information shown in the setting to correct any problems they might have. I am not one of them. But my initial question was only in the hopes that you might be able to supply some information as to how I could better protect my system since you, in instituting the setting, has to know about HTTP/S. It was not to change anything or upset anyone.

    Eeyore

  9. #19
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    HTTPS vs HTTP and SuperDateTimeplugin

    > I am sorry to see that you removed the Insecure HTTPS setting; it IS
    > gone from the latest nightly update
    > (LogitechMediaServer-8.0.0-1590897265). It is useful to be able to see
    > that a system may not be using "full" HTTPS. I am sure that many/most


    Agreed, it could be helpful to know that we have a problem verifying
    certs on Windows. But as you've shown leaving it there was super
    confusing. You tried to change it, which made things fail, then
    complained that the setting did not stick, because it was reset due to
    known issues.

    I'll probably change it to read-only on Windows instead of hiding the pref.

    --

    Michael

  10. #20
    Senior Member
    Join Date
    Jul 2018
    Location
    Oceanside, SoCal
    Posts
    101
    Mr. Herger,

    Thank you for reinstating the setting because it can be useful to know if LMS is using HTTPS or a debilitated version of HTTPS.

    Also, there was a time, I believe it was with an older version of the PaleMoon browser that I had been using, when I could change the setting and it would hold through restarts of LMS. SDT would not update when the box was unchecked (certificates enabled) but update with it checked (certificates disabled). My main purpose with the initial question was to, hopefully, get help in finding why LMS was not working with full HTTPS on my system. I was not denigrating your implementation of the setting. I am sorry if you took it that way.

    Thanks for the information,

    Eeyore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •