Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Senior Member
    Join Date
    Jun 2009
    Location
    Hove, UK
    Posts
    237

    LMS 8 server crashing issue - I dont belive LMS 8.0 specifically is the cause.

    Hi All,
    recently upgraded to LMS 8 after i needed to deploy a new server anyway so figured i would go for 8 but im having issues where the server has a hadbit of bombing out. it seems like comething just starts to take all CPU and ultimatley crahses the machine, this happens generally when playing or starting to play although i dont think its limited to this. I used to be running 7.9.1 and have a feeling that i tried a newer version at somepoint in the past which gave similar issues but cant really call but I dont hink this is a LMS 8 issue.

    always seems to start up in safe mode

    "squeezeboxserver_safe started."

    Setup is as follows
    Ubuntu 18.04.4 LTS (GNU/Linux 4.15.0-101-generic x86_64)
    Logitech Media Server Version: 8.0.0 - 1589867264 @ Tue May 19 08:18:49 CEST 2020
    Hostname: squeeze03
    Server IP Address: 192.168.1.10
    Server HTTP Port Number: 9000
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.26.1 - x86_64-linux-gnu-thread-multi
    Audio::Scan: 0.95
    IO::Socket::SSL: 2.060
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
    Total Players Recognized: 3



    logs attached.

    appriciate any help..
    Attached Files Attached Files

  2. #2
    Senior Member
    Join Date
    Jun 2009
    Location
    Hove, UK
    Posts
    237
    anone have any thoughts here?

  3. #3
    Senior Member
    Join Date
    Jun 2017
    Posts
    189
    Quote Originally Posted by trouty00 View Post
    anone have any thoughts here?
    I am no expert, and I can't offer any useful advice about the problems you're having. But I think you can at least stop worrying about the "squeezeboxserver_safe started" messages in the log. See this thread: https://forums.slimdevices.com/showt...l=1#post971830

    Beyond that, I can only wish you luck! I think it I were experiencing the problems you describe, one of the first things I would do is test the RAM.
    LMS 8 nightly; 3 Squeezelite players connected by powerline ethernet; 5 wireless players connected via Airplay Bridge; 1 SqueezeAmp player
    no high-end or esoteric audio gear
    1 Squeezebox Radio (upgraded UE Smart Radio) now mostly retired

  4. #4
    Senior Member
    Join Date
    Jun 2009
    Location
    Hove, UK
    Posts
    237
    Thanks Rob, I cant belive RAM is an issue as this is running as a virtual machine along with circa 6-10 other VMs doing various jobs - all of them pretty much take zero resource though and my 7.9.1 installatiom also runs on this box and runs flawlessley. Ive actually had to flip back to this server.

    the v8 server has been up for 10 days now but with no players connected to it and its not fallen over, going to flip one player back today but my guess is within a few hours it will have died.

    maybe I will ping mherger for his wisdom.

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,851
    Quote Originally Posted by trouty00 View Post
    Thanks Rob, I cant belive RAM is an issue as this is running as a virtual machine along with circa 6-10 other VMs doing various jobs - all of them pretty much take zero resource though and my 7.9.1 installatiom also runs on this box and runs flawlessley. Ive actually had to flip back to this server.

    the v8 server has been up for 10 days now but with no players connected to it and its not fallen over, going to flip one player back today but my guess is within a few hours it will have died.

    maybe I will ping mherger for his wisdom.
    Had a look at log file.

    As earlier post noted - safe does nto means "safe" mode minimal startup but a method to insure if LMS is urn as a service and crashes/stopped it is restarted.

    DFrom the log and the many different errors with no apparent common thread - assuming the installation is OK then there is something wrong with the environment in which LMS is running - since you now added that it is a VM - I'd look at other posts as IIRC there are special consideration for LMS in VMs

    LMS is run as a single thread with an event loop for all network traffic - if CPU is all consuming then LMS most likely is spinning on a network interaction polling for "status" - if the virtual network adaptor is not set up right - this could be the issues especially as early errors message all have network errors.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    LMS 8 server crashing issue - Idont belive LMS 8.0 specifically is the cause.

    > recently upgraded to LMS 8 after i needed to deploy a new server
    > anyway so figured i would go for 8 but im having issues where the server
    > has a hadbit of bombing out. it seems like comething just starts to take
    > all CPU and ultimatley crahses the machine, this happens generally when


    A program like LMS should not be able to "crash the machine". Any decent
    OS would kill it before it gets there. What do you consider a crash? Can
    you describe what symptoms you're seeing before this happens? Is it
    running out of memory? If so: what is eating the memory?
    --

    Michael

  7. #7
    Senior Member
    Join Date
    Jun 2009
    Location
    Hove, UK
    Posts
    237
    So what generally happens is that CPU generally goes from using using cica 70Mhz (normal run load) to 1.5Ghz - using the entire core essentially, it comes unresponsive to ssh or even ping and will stay in that state until i doa hard power cycle in vmare. It has 1Gb of memory assigned and genearlly only ever uses half of that and memory is nt overcommitted so there is zero balooning going on.

    saying all this ive been playing on and off for the last day and it seems ok for now. :-/

    Stu

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •