Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Senior Member
    Join Date
    Dec 2013
    Posts
    111

    Material Skin is blank in browser on Android

    I have two Android devices which I would like to use as remotes for LMS by using the Material Skin (and the LMS-Material-App to which I will come in another post).

    One is a

    Lenovo tablet, Android 4.4.2,

    the other one a

    Motorola phone, Android 6.0

    In both of these, opening the Material skin in Chrome, results in a blank page, while it works in all iOS devices.

    What An I missing?

  2. #2
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,347
    How old are the OSes (browsers)?

    I have an iPad 2 that doesn't display Material, I have always assumed it was that the iPad is end of life and has an old version of Safari.

  3. #3
    Senior Member
    Join Date
    Dec 2013
    Posts
    111

    Material Skin is blank in browseron Android

    The Lenovo tablet has 4.4 - October 31st 2013
    The Motorola phone has 6.0 - October 5th 2015, Android Security patch from 01 August 2016



    > On 19 May 2020, at 23:17, Greg Erskine <Greg.Erskine.9j52vz (AT) no-mx (DOT) forums.slimdevices.com> wrote:
    >
    >
    > How old are the OSes (browsers)?
    >
    > I have an iPad 2 that doesn't display Material, I have always assumed it
    > was that the iPad is end of life and has an old version of Safari.
    >
    >
    > ------------------------------------------------------------------------
    > Greg Erskine's Profile: http://forums.slimdevices.com/member.php?userid=7403
    > View this thread: http://forums.slimdevices.com/showthread.php?t=112249
    >
    >

  4. #4
    Senior Member
    Join Date
    Mar 2017
    Posts
    3,017
    Quote Originally Posted by rkrug View Post
    The Lenovo tablet has 4.4 - October 31st 2013
    The Motorola phone has 6.0 - October 5th 2015, Android Security patch from 01 August 2016
    App wont run on this old a version of Android - 7.1 is the minimum. Perhaps I'll think of changing this.

    Anyhow, I've just checked on an Note2 with Android 4.4.2, and Material runs just fine. You will need to ensure Chrome is up to date. This is one of the advantages of Android - the browser engine is not tied to the OS version.
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

  5. #5
    Senior Member
    Join Date
    Mar 2017
    Posts
    3,017
    Tried letting the app run on 4.4 - but only a blank screen is shown. Same happens with Samsung browser, and Fully-Kiosk. I'm guess the WebView shipped with 4.4 does not support Chrome, and is so old Material does not work with it.

    But Kiwi browser does install, and Material works fine. This is preferable to Chrome - you can use this to add to homescreen, and it does not show the insecure site warning that Chrome does. This would be my recommended route for such an old device.
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

  6. #6
    Senior Member
    Join Date
    Dec 2013
    Posts
    111

    Material Skin is blank in browseron Android

    > On 20 May 2020, at 09:51, cpd73 <cpd73.9j5w8n (AT) no-mx (DOT) forums.slimdevices.com> wrote:
    >
    >
    > rkrug wrote:
    >> The Lenovo tablet has 4.4 - October 31st 2013
    >> The Motorola phone has 6.0 - October 5th 2015, Android Security patch
    >> from 01 August 2016

    >
    > App wont run on this old a version of Android - 7.1 is the minimum.


    Yes - I got parsing errors in the 0.0.4 and 0.0.5 version on the tablet (4.4) and the 0.0.4 installed on the newer android version.

    > Perhaps I'll think of changing this.


    That would be great, as it would give a new lease of life to older Android devices.

    >
    > Anyhow, I've just checked on an Note2 with Android 4.4.2, and Material
    > runs just fine. You will need to ensure Chrome is up to date. This is
    > one of the advantages of Android - the browser engine is not tied to the
    > OS version.


    OK - I guess I have to login than to the App Store. Will try that out.

    Thanks.

    >
    >
    >
    > *Material debug:* 1. Launch via http: //SERVER:9000/material/?debug=json
    > 2. Open browser's developer tools 3. Open console tab in developer tools
    > 4. REQ/RESP messages sent to/from LMS will be logged here.
    > ------------------------------------------------------------------------
    > cpd73's Profile: http://forums.slimdevices.com/member.php?userid=66686
    > View this thread: http://forums.slimdevices.com/showthread.php?t=112249
    >
    >

  7. #7
    Senior Member
    Join Date
    Dec 2013
    Posts
    111

    Material Skin is blank in browseron Android

    > On 20 May 2020, at 10:55, cpd73 <cpd73.9j5z7c (AT) no-mx (DOT) forums.slimdevices.com> wrote:
    >
    >
    > Tried letting the app run on 4.4 - but only a blank screen is shown.
    > Same happens with Samsung browser, and Fully-Kiosk. I'm guess the
    > WebView shipped with 4.4 does not support Chrome, and is so old Material
    > does not work with it.
    >
    > *But* Kiwi browser does install, and Material works fine. This is
    > preferable to Chrome - you can use this to add to homescreen, and it
    > does not show the insecure site warning that Chrome does. This would be
    > my recommended route for such an old device.


    Good to know - I will install kiwi than.

    Thanks

    Rainer

    >
    >
    >
    > *Material debug:* 1. Launch via http: //SERVER:9000/material/?debug=json
    > 2. Open browser's developer tools 3. Open console tab in developer tools
    > 4. REQ/RESP messages sent to/from LMS will be logged here.
    > ------------------------------------------------------------------------
    > cpd73's Profile: http://forums.slimdevices.com/member.php?userid=66686
    > View this thread: http://forums.slimdevices.com/showthread.php?t=112249
    >
    >

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •