Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Oct 2006
    Location
    Saint Paul, MN
    Posts
    5

    Two wifi's, players can see LMS only on one

    Several years ago my Xfinity cable modem was replaced with one that has wifi. I kept my original wifi, as they broaden my access area. I can connect my players to the original wifi and can play music from my LMS, but cannot access the server from the cable modem wifi.

    Here is my setup: My cable modem with wifi is on the second floor in my den, with a router attached directly. My pc, Mac and printer are attached to this. I have an ethernet cable run from the router to the basement, attached to an ethernet switch. The NAS running LMS is attached to this switch, as well as my original wifi access point.

    I'm replacing a squeezebox that recently died with a piCoreplayer device. While setting up the device, I attached it directly to the router. I could see the LMS and play music. Then I set a connection to the cable modem wifi, detached it from the router and rebooted. It was unable to connect to the LMS while connected only to wifi. My connected devices on the cable modem have IP's in the range of 10.0.0.x, while those on the router and switch are 192.168.0.x.

    I have tried port forwarding 9000 and 3483 on the router to 10.0.0.x, but does not appear to help.

    I would welcome any suggestions and can provide additional detail if needed.
    Lance Schneider

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,769
    Here is how I do something similar ...
    I have only one DHCP server inside the regular home LAN - in your case that could be the cable modem/router box.

    Other access points are put into bridge mode and get their own IP address via DHCP (although you could make them static in a range outside that being used by the cable modem but in the same subnet).
    Then when a device connects to the second access point (wired or wireless) they get their IP address via DHCP from the cable modem.
    Then everything is on the same 10.x.y.z subnet and, hopefully, your problem would disappear.

    In reality I have another router (X) between the LAN and the ISP router and have nothing plugged/wifi into the ISP router apart from router X or sometimes a house guest.
    That way I can change ISP without relying on features that might not be in the ISP router.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia, CBC/Radio-Canada and RTE Ireland
    and, via the extra "Radio Now Playing" plugin, AllZIC Radio, Caroline Flashback, Cesky rozhlas, Frequence3, JukeRadio, KlassikRadio.de, Linn Radio, Mother Earth, Naim Radio, Nova.fr, RadioBlues Flac, Radio Espace, Somehow Jazz, Supla Finland

  3. #3
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,218
    Also check that the WiFi on the cable modem does not have a “client isolation” feature switched on.

    It’s a security feature that isolates a WiFi connected client from everything else on the network. This would explain why a wired connection works when a wireless one doesn’t.
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

  4. #4
    Junior Member
    Join Date
    Oct 2006
    Location
    Saint Paul, MN
    Posts
    5
    Thanks for the suggestion. I have an Arris TG862 modem from Xfinity, and looked for a client isolation feature, but could not find a setting for that.
    Lance Schneider

  5. #5
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,218
    Quote Originally Posted by LanceInMN View Post
    Thanks for the suggestion. I have an Arris TG862 modem from Xfinity, and looked for a client isolation feature, but could not find a setting for that.
    In which case you need to do as Paul suggested and ensure you only have one DHCP server running on your home network. As Paul suggests this is better on the Cable Modem where your internet connection is.

    LMS and all clients need to be on the same network subnet either 192.168.x.x or 10.x.x.x
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •