Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    May 2020
    Posts
    2

    Thank you and help diagnosing stuttering

    Hi there - first off I want to thank everyone for making piCoreplayer. My old chrome castaudio died and I replaced it with a raspberry pi running piCore and the outcome is so much better! I use stream airplay audio and spotify audio to it - and it works well. I really appreciate the work everyone has gone to making this product. So much went right for me - I was able to install two plugins (shairtunes2 and spotty) and both worked immediately.

    I have a problem with stuttering - some times playback stops for a few seconds before continuing. I have been reading the forums and I've made some progress.

    I am using a wifi only connection. The audio output is to the raspberry pi headphone jack.

    1. I have installed iw and used the command iw dev wlan0 get power_save to verify that power save is off (and this setting is now fixed).

    2. My iwconfig results are:

    wlan0 IEEE 802.11 ESSID:"...."
    Mode:Managed Frequency:5.18 GHz Access Point:
    Bit Rate=195 Mb/s Tx-Power=31 dBm
    Retry short limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff
    Link Quality=41/70 Signal level=-69 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:20 Invalid misc:0 Missed beacon:0

    Is this a fast enough connection?

    3. If I ping the raspberry pi from another computer I get:
    PING 192.168.1.27 (192.168.1.27): 56 data bytes
    64 bytes from 192.168.1.27: icmp_seq=0 ttl=64 time=6.209 ms
    64 bytes from 192.168.1.27: icmp_seq=1 ttl=64 time=14.335 ms
    64 bytes from 192.168.1.27: icmp_seq=2 ttl=64 time=8.158 ms
    64 bytes from 192.168.1.27: icmp_seq=3 ttl=64 time=14.111 ms
    64 bytes from 192.168.1.27: icmp_seq=4 ttl=64 time=14.710 ms
    64 bytes from 192.168.1.27: icmp_seq=5 ttl=64 time=11.235 ms
    64 bytes from 192.168.1.27: icmp_seq=6 ttl=64 time=13.464 ms
    64 bytes from 192.168.1.27: icmp_seq=7 ttl=64 time=13.987 ms
    64 bytes from 192.168.1.27: icmp_seq=8 ttl=64 time=6.061 ms
    64 bytes from 192.168.1.27: icmp_seq=9 ttl=64 time=11.959 ms
    64 bytes from 192.168.1.27: icmp_seq=10 ttl=64 time=5.404 ms
    64 bytes from 192.168.1.27: icmp_seq=11 ttl=64 time=11.764 ms
    64 bytes from 192.168.1.27: icmp_seq=12 ttl=64 time=6.307 ms
    64 bytes from 192.168.1.27: icmp_seq=13 ttl=64 time=11.527 ms
    64 bytes from 192.168.1.27: icmp_seq=14 ttl=64 time=6.514 ms
    64 bytes from 192.168.1.27: icmp_seq=15 ttl=64 time=11.941 ms
    64 bytes from 192.168.1.27: icmp_seq=16 ttl=64 time=12.174 ms

    4. The raspberry pi internal ping test gives:
    PING 192.168.1.27 (192.168.1.27): 56 data bytes
    64 bytes from 192.168.1.27: seq=0 ttl=64 time=0.129 ms
    64 bytes from 192.168.1.27: seq=1 ttl=64 time=0.177 ms
    64 bytes from 192.168.1.27: seq=2 ttl=64 time=0.176 ms
    64 bytes from 192.168.1.27: seq=3 ttl=64 time=0.175 ms
    64 bytes from 192.168.1.27: seq=4 ttl=64 time=0.175 ms
    64 bytes from 192.168.1.27: seq=5 ttl=64 time=0.179 ms
    64 bytes from 192.168.1.27: seq=6 ttl=64 time=0.203 ms
    64 bytes from 192.168.1.27: seq=7 ttl=64 time=0.178 ms

    Are there any other diagnostic settings I should look at?

    Thanks again everyone.

  2. #2
    Quote Originally Posted by SanderBob View Post

    I am using a wifi only connection.

    Are there any other diagnostic settings I should look at?

    Thanks again everyone.
    If you have not, you should test the Pi using an ethernet connection. If this works reliably, then you will know it is a wifi problem and not something else.

  3. #3
    Junior Member
    Join Date
    May 2020
    Posts
    2
    Quote Originally Posted by redgum View Post
    If you have not, you should test the Pi using an ethernet connection. If this works reliably, then you will know it is a wifi problem and not something else.
    Thanks - that's a good idea. Because it is in an out of the way location - I didn't do this - but I should! I'll get back to people with the result of the test.

    Thanks.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •