Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Apr 2020
    Posts
    3

    rpi3 + digione : squeezebox error

    Hello,

    I'm a bit stuck with this issue, and I don't really understand how to solve it...
    I have a raspberry3+ with a digione card, and all was perfect.

    I made an update, or several, from the piCorePlayer interface, and now I face the issue that there's nothing working anymore : even squeezelite refuses to start now !
    I checked this https://forums.slimdevices.com/showt...is-not-running and https://forums.slimdevices.com/showt...o-Allo-DigiOne, but could not make it work again.

    I think that the issue comes from a missing driver, but I cannot figure how to install it...
    In the output, I had hw:CARD=sndallodigione, but it is not listed in the available hardware :
    Name:  2020-04-12 16_00_51-pCP - Squeezelite Settings.png
Views: 219
Size:  68.1 KB

    Could you tell me how to fix this issue ?

    If you think this issue might come from elsewhere, or if you need logs or so, don't hesitate to ask, I'm a bit lost right now...

    Thanks !

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,424
    Are you in beta mode ? (bottom of pcp gui)

    ronnie

    or make a fresh download

  3. #3
    Junior Member
    Join Date
    Apr 2020
    Posts
    3
    Hi,

    Well, I tried many things, including probably going to beta screens, but I cannot figure out what I did wrong (because yes, I obviously did something wrong).

    I was running PCP audio enthusiast, and "update" it back to standard version, but this does not change anything.

    Here are the current versions :
    piCorePlayer v6.0.0 | www v0005 | linux 4.19.105-pcpCore_v7 | piCore v10.3pCP | Squeezelite v1.9.6-1206-pCP

    [edit]
    Now on startup, I get this error :
    Waiting for soundcard sndallodigione to populate......................................... Failed to find sndallodigione (42).
    Done (42).
    Last edited by gangsoleil; 2020-04-12 at 08:58.

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,424
    I would download the standard version and use balena-etcher to burn the image

    when you have the pcp web gui click on Main page and then scroll down and click on beta (ignore the warning)

    Select squeezelite tab and complete the set-up

    this is my digione

    hw:CARD=sndallodigione,DEV=0
    ronnie

    then try the update to enthusiast if you wish

    I've just done this and it works (especially if I turn on the speakers )
    Last edited by Man in a van; 2020-04-12 at 09:36.

  5. #5
    Junior Member
    Join Date
    Apr 2020
    Posts
    3
    Thanks a lot for your answer. The thing is that I was really trying not to reinstall everything (though there is not much to install, I agree)... Would you have an idea of something else I could try ?

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,424
    No

    Edit: and make a backup
    Last edited by Man in a van; 2020-04-12 at 11:02.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •