Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 12 FirstFirst 1234 ... LastLast
Results 11 to 20 of 118
  1. #11
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,174
    Quote Originally Posted by mherger View Post
    > I've successfully patched both my Radios, but the message "You seem to
    > be using a Radio with an outdated firmware, not recognizing this version
    > of Logitech Media Server. Please consider patching it. Get more
    > information." remains in Server Settings when I select either one of
    > them.


    When did you apply the patch? The workaround indeed isn't perfect
    indeed. There are two (I know of) reasons why you might still get the
    message:

    * you have a non-patched Radio in your network which is connected to
    another LMS

    * you installed an early version of the patch

    In the first case the solution is obvious: install the patch as if it
    was connected to your LMS8.

    In the second case you'd have to uninstall the old patch first, just to
    re-install the new version. Unfortunately the patch installer doesn't
    know updates.

    Or there's a third option: you ignore the warning as long as things seem
    to be working fine anyway. But I can't guarantee that it would continue
    to work.

    --

    Michael
    I got the same warning with my previously patched Radios. I uninstalled and reinstalled the patch and still see the warning.

    Sent from my Pixel 3a using Tapatalk

  2. #12
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,521

    Squeezebox Radio would not connect to LMS

    > I got the same warning with my previously patched Radios. I uninstalled
    > and reinstalled the patch and still see the warning.


    We'll see where this goes. I've experienced cases where I had to
    re-install twice before it picked up the change.

    You could enable debugging for network.http, then browse to some album
    list. When you get requests for artwork from the Radio you should see
    the header it's sending, among which there's the "User-Agent":

    User-Agent: SqueezePlay-baby/7.7.3-r16676-lms8 (armv5tejl)

    That version there should have the "-lms8" appendix if the patch was
    applied correctly.

    If the workaround turns out to be good enough, I'll probably remove the
    warning in a bit to get rid of the confusion.

    --

    Michael

  3. #13
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,174
    Quote Originally Posted by mherger View Post
    > I got the same warning with my previously patched Radios. I uninstalled
    > and reinstalled the patch and still see the warning.


    We'll see where this goes. I've experienced cases where I had to
    re-install twice before it picked up the change.

    You could enable debugging for network.http, then browse to some album
    list. When you get requests for artwork from the Radio you should see
    the header it's sending, among which there's the "User-Agent":

    User-Agent: SqueezePlay-baby/7.7.3-r16676-lms8 (armv5tejl)

    That version there should have the "-lms8" appendix if the patch was
    applied correctly.

    If the workaround turns out to be good enough, I'll probably remove the
    warning in a bit to get rid of the confusion.

    --

    Michael
    OK I do see
    User-Agent: SqueezePlay-baby/7.7.3-r16676-lms8 (armv5tejl)


    Sent from my Pixel 3a using Tapatalk

  4. #14
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,521

    Squeezebox Radio would not connect to LMS

    > OK I do see
    > User-Agent: SqueezePlay-baby/7.7.3-r16676-lms8 (armv5tejl)


    Oh... that message might only go away after a server restart. It's a
    flag which will only be set if needed, but never reset. Needs some
    refinement.

    --

    Michael

  5. #15
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,174
    Quote Originally Posted by mherger View Post
    > OK I do see
    > User-Agent: SqueezePlay-baby/7.7.3-r16676-lms8 (armv5tejl)


    Oh... that message might only go away after a server restart. It's a
    flag which will only be set if needed, but never reset. Needs some
    refinement.

    --

    Michael
    Yup that clears it.

    Sent from my Pixel 3a using Tapatalk

  6. #16
    Senior Member
    Join Date
    May 2006
    Location
    New York
    Posts
    279
    Quote Originally Posted by mherger View Post
    Oh... that message might only go away after a server restart. It's a
    flag which will only be set if needed, but never reset. Needs some
    refinement.
    Just getting back to this thread, and a server restart did remove the message. Could you add a note to the instructions about this?

    Bill

  7. #17
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,521

    Squeezebox Radio would not connect to LMS

    >> Oh... that message might only go away after a server restart. It's a
    >> flag which will only be set if needed, but never reset. Needs some
    >> refinement.

    >
    > Just getting back to this thread, and a server restart did remove the
    > message. Could you add a note to the instructions about this?


    I'll review this for sure. Thanks for the heads up!

    --

    Michael

  8. #18
    Junior Member
    Join Date
    Jul 2009
    Location
    Sweden
    Posts
    26

    My Radio did work with LMS 8

    I installed LMS 8 on a piCorePlayer a few days ago, and updated with latest nightly yesterday. I hadn't used my Radio since, but when I turned it on now it did work as usual. The firmware was 7.7.3-r16676.

    Just to try it, I followed the instructions in the first post of this thread and installed the patch. Language is set to Swedish and it was no problem to install the patch. When I checked the Information tab in Server settings it still says 7.7.3-r16676, but I assume it's not supposed to change.

  9. #19
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,521

    Squeezebox Radio would not connect to LMS

    > I installed LMS 8 on a piCorePlayer a few days ago, and updated with
    > latest nightly yesterday. I hadn't used my Radio since, but when I
    > turned it on now it did work as usual. The firmware was 7.7.3-r16676.


    Same here. I had been working on LMS8 for a long time before I learned
    about this.

    Looking at the firmware I believe that the check is only done when you
    try to switch server, but not when it's re-connecting to the server it's
    always been connected to. If you went to My Music/Switch Library and
    tried to connect to the same server, it would fail...

    > Just to try it, I followed the instructions in the first post of this
    > thread and installed the patch. Language is set to Swedish and it was no
    > problem to install the patch


    Thanks for that confirmation.

    >. When I checked the Information tab in
    > Server settings it still says 7.7.3-r16676, but I assume it's not
    > supposed to change.


    Yes, I haven't changed that. Would have been helpful...

    --

    Michael

  10. #20
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,126
    I'm confused! (not unusual these days)

    I have a radio which has the patch installed. I still get the bug message in the server log:

    [20-04-09 10:17:18.0916] main::init (388) Starting Logitech Media Server (v8.0.0, 1586408756, Thu Apr 9 07:19:42 CEST 2020) perl 5.026001 - i686-linux-gnu-thread-multi-64int

    [20-04-09 10:17:26.8198] Slim::Networking:iscovery::getFakeVersion (129)
    You're using a Radio with a buggy firmware not recognizing this version of Logitech Media Server.
    Please consider patching it. Until then we'll try to play nice and return a fake version number...
    LMS server: O2 Joggler with Jivelite, Pi Zero W with PcP 6.0

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Fiio M6, Avantree Priva BT transmitter



    ------------------------------------------------------------------------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •