Home of the Squeezebox™ & Transporter® network music players.
Page 44 of 46 FirstFirst ... 344243444546 LastLast
Results 431 to 440 of 451
  1. #431
    Junior Member
    Join Date
    May 2020
    Posts
    6

    Constant re-buffering using Spotify

    First off...thanks to the community, especially Michael for continuing to support these amazing audio streaming devices. I recently moved up to LMS 8 on a QNAP NAS (using the QLogitech package, which automatically installs Spotty v4.3), and I am experiencing constant re-buffering, like every 30 seconds. It is making it completely unusable. I have the same behaviour on my wired Touch and my wireless Radio, so the issue is not with the wifi. My NAS will stream my local library with no problems, so I don't think it is an issue with the power of my NAS. I have read what I think is every post in this thread with hopes to find some troubleshooting tips but to no avail. Here is my info:

    Nothing shown in the LMS Server log:

    [20-08-17 13:22:38.4304] main::init (388) Starting Logitech Media Server (v8.0.0, 1597639997, Mon Aug 17 07:24:41 CEST 2020) perl 5.020003 - arm-linux-gnueabi-thread-multi-64int

    Logitech Media Server Version: 8.0.0 - 1597639997 @ Mon Aug 17 07:24:41 CEST 2020
    Hostname: Annapolis
    Server IP Address: 192.168.0.10
    Server HTTP Port Number: 9001
    Operating system: QLMS 2.X (QNAP TurboStation) [Debian 9 stretch] - EN - utf8
    Platform Architecture: armv5tel-linux
    Perl Version: 5.20.3 - arm-linux-gnueabi-thread-multi-64int
    Audio::Scan: 0.95
    IO::Socket::SSL: 2.060
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Total Players Recognized: 2

    Some additional info that I thought I would add...my NAS is somewhat old, it is a TS-110 single bay, I rebuilt the unit last week with a new 4 TB drive (my old 2 TB died, thankfully I had a backup) but I believe this unit is based on an ARMv7 processor...I think I read somewhere about dependencies on the processor architecture with Spotty, there is a legacy helper plugin that is enabled.

    My use case is pretty basic...I really just want to stream Spotify content on my players, I really like the Don't Stop the Music plugin. I disabled the Spotify Connect since I don't really need that and I also disabled the Online Music Library Integration hoping to simplify but the problem prevails.

    Anyone have any ideas?

    Thanks in advance!
    Last edited by Locutus1967; 2020-08-18 at 06:39.

  2. #432
    Junior Member
    Join Date
    Dec 2019
    Posts
    8

    Problems authenticating

    Hi,

    Thanks for all the work on the squeezebox and this plugin

    After months of working I found I couldn't play anything and the logs contained timeouts about getting tokens
    I upgraded both the plugin and also the server but I still get timeouts:
    Plugins::Spotty::API::Token::_killTokenHelper (177) Timed out waiting for a token

    I've tried uninstalling and reinstalling - also using the password and the app to connect and no joy

    Any other suggestions?

  3. #433
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    [Announce] Spotty 4.0 - integrate locallibrary with your Spotify collection (LMS 8+)

    > Plugins::Spotty::API::Token::_killTokenHelper (177) Timed out waiting
    > for a token
    >
    > I've tried uninstalling and reinstalling - also using the password and
    > the app to connect and no joy


    Did you install/update a firewall or something? Spotty needs to access
    eg. port 4070 in addition to 80/443.

    --

    Michael

  4. #434

    No library integration anymore after update

    Hi Michael,

    my formerly flawlessly running system started saying "Cannot convert stream" when trying to play via Spotty. So I updated max2play, LMS to 0.9.4 and Spotty to the latest version and now playing songs is working fine again.

    But what I am noticing now is that the Spotify library is not mixed in to the regular one anymore.

    Is that intentional?

    Thanks,
    Mo

  5. #435
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,125
    Quote Originally Posted by mo5265654 View Post
    Hi Michael,

    my formerly flawlessly running system started saying "Cannot convert stream" when trying to play via Spotty. So I updated max2play, LMS to 0.9.4 and Spotty to the latest version and now playing songs is working fine again.

    But what I am noticing now is that the Spotify library is not mixed in to the regular one anymore.

    Is that intentional?

    Thanks,
    Mo
    If you aren't using LMS 8.0.0 it won't be.

    Sent from my Pixel 3a using Tapatalk

  6. #436
    Junior Member
    Join Date
    Dec 2019
    Posts
    8
    Quote Originally Posted by mherger View Post
    > Plugins::Spotty::API::Token::_killTokenHelper (177) Timed out waiting
    > for a token
    >
    > I've tried uninstalling and reinstalling - also using the password and
    > the app to connect and no joy


    Did you install/update a firewall or something? Spotty needs to access
    eg. port 4070 in addition to 80/443.

    --

    Michael
    Oh I've no idea why it wasn't working properly but after starting to trace the spotty binary I did the classic reboot the server and it started working - thanks for answering - it's so nice to have it working again.

  7. #437
    Hello, Spotty is working, all great, but I can't seem to find my "liked songs". Were can I find them?
    many thanks for all the work

  8. #438
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    [Announce] Spotty 4.0 - integrate locallibrary with your Spotify collection (LMS 8+)

    > Hello, Spotty is working, all great, but I can't seem to find my "liked
    > songs". Were can I find them?


    Last time I checked they didn't provide an API to get them. But I think
    you can like the item in Spotify, then it would show up as a liked playlist.

    --

    Michael

  9. #439
    No such "Liked" playlist here... but don't worry. It is a great app as it is.
    BR, Johan

  10. #440
    Senior Member
    Join Date
    Jan 2008
    Posts
    405

    iPeng Playing next Spotty track instead of the one I want

    Hi,

    Not quite sure how to debug this since it's somewhat intermittent.

    Set up: LMS 8.0 nightly, Spotty 4.3.0. Players: squeezelite on RPis (not PCP). Latest iPeng on iOS 13 devices for control.

    Problem: sometimes when a Spotty track is selected to play now in iPeng, the following track on the list is played instead. Usually trying it the second time plays the correct track. Playing a different track will again play its following one.

    Steps to reproduce: use the Spotty interface in LMS through ipeng to e.g. search for a track. Select a track to play from the returned list. The track below the one you selected plays (the metadata is that of the playing track, so there is no mismatch).

    Observations: it doesn't happen always, but if Spotty enters this state, it happens every time until things begin to work OK again (usually 5-10 songs). It seems to happen more frequently with list of output of searches than with saved playlists. But I think I've had it happen for both. I've not observed it through the web interface, but I usually use Spotty through ipeng, so this may be just a selection effect. It doesn't happen with non-Spotty items, so I don't think it's an iPeng problem.

    Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •