Home of the Squeezebox™ & Transporter® network music players.
Page 43 of 46 FirstFirst ... 334142434445 ... LastLast
Results 421 to 430 of 451
  1. #421
    Junior Member
    Join Date
    Aug 2014
    Posts
    17

    problems with music stopping

    First of all, thanks for writing the plugin - it's really awesome to be able to use this great infrastructure with spotify.

    I have been experiencing some problems, and was wondering if there are things to try:

    - tried using a touch in the spotify-connect mode, but every now and and then it would stop working; the device would be seen in the spotify app, but nothing would play (i.e in the app it would show as playing, but not on the touch). The touch would just show what played last, or black music art, and no text where the song title should be.
    Nothing obvious in the logs, although I've seen things like (not sure if related):
    [20-08-12 21:07:05.0047] Plugins::Spotty::API::__ANON__ (1417) Invalid data

    I could fix the issue, by turning spotify-connect option off, then back on.

    - So I switched to playing spotify through LSM directly. This seems much more solid, however the music stops quite often... as often as every few songs (i.e. 4 or 5). My playlists are fairly large, but have seen this with smaller ones as well. I can just play "next" and the next song will play, after which a few more.. then things will stop again.
    Is there a way to change options/settings or do anything to eliminate this problem?

    I have observed these issues with both 4.2 and latest 4.3 plugin version.

    My setup: squeebox touch and radio
    Logitech Media Server Version: 7.9.3 - 1584993250 @ Tue Mar 24 04:13:22 CET 2020
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.26.1 - x86_64-linux-gnu-thread-multi
    Audio::Scan: 0.95
    IO::Socket::SSL: 2.060
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    my machine is powerful, so this is not a performance/resources issue.

    Thanks!

  2. #422
    Junior Member
    Join Date
    May 2016
    Posts
    28
    Quote Originally Posted by wmupchurch View Post
    Hi Michael, Love the app. Have been using it for years! I am having a problem in that i can't connect to Spotify. I installed LMS 8 (and have tried this on 7.9). When I go into add the account, my account is already there. When I delete it, I get the sign in/up menu where you connect to spotify. I have tried this with and without entering my user name and password. What happens is that once I start playing something and go into devices to authorize and select max2play, LMS switches the screen back to the settings screen as if the connection has occurred, but spotify hangs on 'connecting' and the connection never occurs. I've tried this on my PC and phone. I've also reinstalled LMS and the plugin. Is there a cache for spotty that I can clear or set of files that I can clean up to start over? Even when reinstalling LMS, your plug in is there and if I take it out and reinstall, when I add the plugin, my account shows up so I suspect there is some kind of file corruption somewhere. Thanks for any help you can provide.
    I ended up rebuilding the entire stack. It works now. I still suspect it was some kind of cache/corrupt file issue that the reinstall fixed. Man, these PIs are cool, but sometimes unstable. :-)

  3. #423
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    [Announce] Spotty 4.0 - integrate locallibrary with your Spotify collection (LMS 8+)

    > - tried using a touch in the spotify-connect mode, but every now and and
    > then it would stop working; the device would be seen in the spotify app,


    This unfortunately is a known issue.

    > - So I switched to playing spotify through LSM directly. This seems much
    > more solid, however the music stops quite often... as often as every few
    > songs (i.e. 4 or 5). My playlists are fairly large, but have seen this
    > with smaller ones as well. I can just play "next" and the next song will
    > play, after which a few more.. then things will stop again.
    > Is there a way to change options/settings or do anything to eliminate
    > this problem?
    >
    > I have observed these issues with both 4.2 and latest 4.3 plugin
    > version.


    There recently were reports about "short" tracks not playing correctly.
    But it seems the situation has recovered. And I certainly hear my sons
    listen to their favorite audio books all day long again... Could this
    have been the issue for you, too?

    --

    Michael

  4. #424
    Hello,

    today i receive update for plugin spotify
    after select and make update and reboot the lms
    spotify it's desabled from the list and lms it's shut down several time
    when i select the plugins and make valide to apply the lms it's disconnect and i not see spotify
    i don't have any problems before update from today

    Spotify 4.3.0
    LMS 7.9.2 / r1578996832

    Best Regards

  5. #425
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    [Announce] Spotty 4.0 - integrate locallibrary with your Spotify collection (LMS 8+)

    > when i select the plugins and make valide to apply the lms it's
    > disconnect and i not see spotify
    > i don't have any problems before update from today
    >
    > Spotify 4.3.0
    > LMS 7.9.2 / r1578996832


    There have been various reports about issues with LMS on Windows and
    plugin installations. Please get the latest 7.9.3 nightly build and give
    it a try:

    http://downloads.slimdevices.com/nig...ex.php?ver=7.9

    Many have claimed that did resolve their issue.

    --

    Michael

  6. #426
    Junior Member
    Join Date
    Aug 2014
    Posts
    17
    Quote Originally Posted by mherger View Post
    > - tried using a touch in the spotify-connect mode, but every now and and
    > then it would stop working; the device would be seen in the spotify app,


    This unfortunately is a known issue.
    ok, that's too bad. Is this a spotify lib/api limitation?

    Quote Originally Posted by mherger View Post
    >

    > - So I switched to playing spotify through LSM directly. This seems much
    > more solid, however the music stops quite often... as often as every few
    > songs (i.e. 4 or 5). My playlists are fairly large, but have seen this
    > with smaller ones as well. I can just play "next" and the next song will
    > play, after which a few more.. then things will stop again.
    > Is there a way to change options/settings or do anything to eliminate
    > this problem?
    >
    > I have observed these issues with both 4.2 and latest 4.3 plugin
    > version.



    There recently were reports about "short" tracks not playing correctly.
    But it seems the situation has recovered. And I certainly hear my sons
    listen to their favorite audio books all day long again... Could this
    have been the issue for you, too?
    No, in my case this seems to have nothing to do with "short" tracks... it will happen with tracks that are, say, 6 minutes or longer as well.
    There seems to be nothing about it in the logs (at least with default logging, etc).

  7. #427
    I am having this problem as well a lot lately. I frequently have to manually skip to the next song in a playlist to keep it going.

    However, skipping back to the beginning of the song that stopped seems to have smoothed things over and playback is continuing as normal for now. Odd.

    Never mind. It’s still doing it. Gotta switch over to local music now.
    Last edited by maddymarc; 2020-08-17 at 11:21.

  8. #428
    Junior Member
    Join Date
    Aug 2014
    Posts
    17
    yes, same for me, every few songs.
    how big are your playlists @maddymarc ?
    Mine are typically large... it's possible that I see this happen more with larger lists (say ~400 songs).. but can't quite tell at the moment)

  9. #429
    My playlists have been somewhat large; 300-500 songs.

    Oddly itĺs been working well again for about an hour or so. There may be something to the song length, but Iĺm not sure.

  10. #430
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,460

    [Announce] Spotty 4.0 - integrate locallibrary with your Spotify collection (LMS 8+)

    >>> - tried using a touch in the spotify-connect mode, but every now and
    >> and
    >>> then it would stop working; the device would be seen in the spotify

    >> app,
    >>
    >> This unfortunately is a known issue.

    >
    > ok, that's too bad. Is this a spotify lib/api limitation?


    No, I believe it's a combination of the playback issues seen below and
    the complexity of having multiple systems who believe they were in
    control of the streaming: both LMS and Spotify want to be the playback
    master, and try to be. Keeping them in sync is not easy, and I believe
    there's some wierd interaction going on sometimes stopping playback.

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •