Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1

    Sample Rate Problem

    I'm running squeezelite under Ubuntu on an ODriod N2. It works great with one exception: The sample rate seems to be limited to 48kHz. I've tried passing "-r 192000" as an option, and when playing a 96kHz file I see output like:

    [01:01:38.771803] stream_thread:176 headers: len: 118
    HTTP/1.1 200 OK
    Server: Logitech Media Server (7.9.2 - 1539967036)
    Connection: close
    Content-Type: audio/x-flac


    [01:01:38.771882] sendRESP:202 RESP
    [01:01:38.801161] sendSTAT:171 STAT: STMl
    [01:01:38.805941] process:494 strm
    [01:01:38.805971] process_strm:256 strm command u
    [01:01:38.805988] process_strm:312 unpause at: 8033985 now: 8033789
    [01:01:38.806001] sendSTAT:171 STAT: STMr
    [01:01:38.877346] write_cb:116 setting track_start
    [01:01:39.003682] _output_frames:146 track start sample rate: 96000 replay_gain: 0
    [01:01:39.013866] output_thread:638 open output device: default
    [01:01:39.016910] alsa_open:355 opening device at: 96000
    [01:01:39.029893] alsa_open:406 opened device default using format: S32_LE sample rate: 96000 mmap: 0
    [01:01:39.030006] alsa_open:485 buffer: 40 period: 4 -> buffer size: 3840 period size: 960

    So that seems like it is saying it's outputting at 96kHz. But the DAC (a Schiit Yggdrasil) indicates that it's only receiving 48kHz. If I instead use a Logitech transporter into the same DAC (synchronized even), I see 96kHz. Of course, the ODroid is connected via USB whereas the Transporter is connected by AES/EBU. But I'm guessing that is not the problem.

    Thanks for any ideas,
    Riki
    Transporter --> Pass Labs D1 --> Pass Labs Aleph 2s --> BC Acoustique A2.5s (listening room)
    Transporter --> Pass Labs D1 --> Adcom GFA-5800 --> Monitor Audio GR-60s (living room)
    Receiver --> T-Amp --> Monitor Audio Radius 90s (daughter)
    Receiver --> Sony HT Receiver (Garbage) --> Monitor Audio Raduis HT Setup (bedroom)
    Squeezebox Boom (exercise room)
    SqueezeboxServer on a 350MHz Pentium II with 768MB RAM, 1.5TB storage, running Centos 5.x

    http://frege.brown.edu/heck/audio/mysystem.php

  2. #2
    Junior Member
    Join Date
    Aug 2014
    Posts
    11
    Hi Riki,

    I am using also squeezelite player on Ubuntu 20.04 with an external DAC.
    I guess you have the wrong output device for the player.

    My DAC, a T+A DAC8, has two devices under Ubuntu and only one device supports all bit- and samplerates.
    First of all you can list all the output devices the squeezelite player supports with '/usr/bin/squeezelite -l' --> choose the devices with native support (no conversions of the audio signal).
    And then try the following command 'aplay --dump-hw-params -D <devicename> -f cd /dev/zero', where <devicename> is the output port you have configured in /etc/default/squeezelite.
    With this command you can see which bit- and samplerates the connected device supports. In my case I set the output device to this device which supports all bit- and samplerates.

    Greetings,
    Christian

  3. #3
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,882
    Quote Originally Posted by rgheck View Post
    I'm running squeezelite under Ubuntu on an ODriod N2. It works great with one exception: The sample rate seems to be limited to 48kHz. I've tried passing "-r 192000" as an option, and when playing a 96kHz file I see output like:
    Squeezelite usually checks with ALSA output devices first to see what sample rates are supported so perhaps 9600kHz or 19.2kHz are not supported by the output devices on the chosen interface.

    You can check by enabling squeezelite logging and see what rate capabilities squeezelite reports to LMS. LMS then decides whether to resample or not as it depends on what squeezelite has reported to LMS on first connection.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •