Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Apr 2013
    Posts
    12

    Server Power Control unable to make it work

    My apologies if this subject has already been addressed elsewhere in this forum. I searched the entire forum for a solution to no avail.
    But let me start by saying that my knowledge of Linux is extremely limited.

    I run the squeezebox server in a vortexbox 2.4 environment and SrvrPowerCtrl was working faultlessly for many months now.
    However, last week I tried installing Home Assistant but in the end I was left with a non working server. I had to install Vortexbox from scratch. I also tried to reinstall SrvrPowerCtrl which I did but I have not been able to make it work properly again ever since.

    What happens now is that after the Allowed system idle time set by me squeezeboxserver stops but the computer running the server continues on as before.
    Can someone point me in the right direction? Many thanks.
    Cheers from Portugal
    -----------------------
    I installed SrvrPowerCtrl following the plugin instructions. In the end every time I try to run
    Code:
    sudo -u squeezeboxserver sudo spc-test.sh
    I get the message below
    Code:
    Sorry, user root is not allowed to execute '/bin/sudo /usr/local/sbin/spc-clearblock.sh
    I noted that even if I try to enter a non existing script the reply is always the same.

    squeezeboxserver group permissions in the sudoer file are as follows

    Code:
    %squeezeboxserver ALL = NOPASSWD: /usr/bin/systemctl poweroff
    %squeezeboxserver ALL = NOPASSWD: /usr/bin/systemctl suspend
    %squeezeboxserver ALL = NOPASSWD: /usr/bin/systemctl hibernate
    %squeezeboxserver ALL = NOPASSWD: /usr/bin/systemctl hybrid-sleep
    %squeezeboxserver ALL = NOPASSWD: /usr/bin/systemctl reboot
    %squeezeboxserver ALL = NOPASSWD: /usr/bin/crontab -l
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-clearblock.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-functions.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-health.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-minidlna.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-restart.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-setblock.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-test.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-update.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-wakeup_alt.sh*
    %squeezeboxserver ALL = NOPASSWD: /usr/local/sbin/spc-wakeup.s
    Due to forum limitations I am attaching a txt file with the SrvrPowerControl log.
    I thank you once again for any help you may provide.
    Attached Files Attached Files
    Last edited by DuLac; 2020-03-29 at 10:08.

  2. #2
    Junior Member
    Join Date
    Apr 2013
    Posts
    12

    [Solved]

    As referred I searched the forum for a previous post on this. My search did not produce any results but this was due only to me not doing that search properly.
    In fact there has been a previous post about a similar situation in 2017 and - shame, shame - it was started by me! I apologize
    The problem was solved using epoch1970's solution.
    Here is the said post
    https://forums.slimdevices.com/showt...trl&highlight=

  3. #3
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,636
    No worries, its better than some of the less thought about questions on here.

    I was going to post a question last night but found the answer, I'd posted it !!!

    Want a webapp ? Get SqueezeLite-X ! https://forums.slimdevices.com/showt...l=1#post903953

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •