Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 28
  1. #1
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    1,158

    LmsUpdate and LmsRepack - Synology 8.0.* packages

    Hi all,


    This is a continuation of the Synology 7.9.2 thread
    Packages are currently limited to the x86_64 architectures!

    We have 2 flavours: LmsRepack and LmsUpdate.
    Which package should I choose?
    • If you're not sure what to choose, or already have LmsUpdate running or the official package from Synology: always use LmsUpdate for updating the current installation or to start a fresh install.
    • Only install LmsRepack if you starting to use Logitech Media Server and want Package Center take care of notifying and installing the package by adding the repo.


    Questions
    • Can I migrate my settings and plugins between LmsUpdate and LmsRepack? NO, this is not possible! The both are installed in different directories, and have their own settings, plugins, database e.g.
    • Can I install LmsRepack alongside LmsUpdate? YES, But! Rnning both LmsUdate and LmsRepack at the same time is NOT possible. You have to stop one package to be able to install and run the other!

    ------------------------------------------------------------------------------------------------
    LmsRepack: packages are available in Package Center after adding the Package source location to settings. LMS webui is available on port 9000.

    Installation LmsRepack

    Precondition: Perl needs to be installed. The Perl package is available in Package Center under "All Packages -> Third-party--> Perl".
    • In Package Center: go to ->settings -> General -> set trust level to 'any publisher'.
    • In Package Center go to -> settings -> Package Sources -> Add -> name: LmsRepack -> Location: https://pinkdot.myds.me/sspks/
    • LmsRepack will apear in the community section of Package Center


    ------------------------------------------------------------------------------------------------
    LmsUpdate: packages need manual installation via Package Center in DSM and can be installed as an update over the official Synology package. LMS webui is available on port 9002.

    Installation LmsUpdate

    Precondition: Perl needs to be installed. The Perl package is available in Package Center under "All Packages -> Third-party-> Perl".
    • In Package Center: go to ->settings -> set trust level to 'all pubishers'.
    • Download the correct package from https://pinkdot.myds.me/sspks/
    • Install the package manually via Package Center.


    To update:

    • You will be notified in the LMS webui if an update is available.
    • In this notification a link is provided to the correct package for your nas.
    • Download the package to your pc.
    • Install the package manually via Package Center as usual.


    ------------------------------------------------------------------------------------------------
    >>>Synology has announced to discontinue Logitech Media Server support and remove it from Package Center, as of july 2020. How this will affect our community packages in the long term is uncertain. So, enjoy while it lasts.<<<

    DSM6 packages are available for the following nas models:

    • x86_64*= DS1019+, DS1511+, DS1512+, DS1513+, DS1515+, DS1517+, DS1618+, DS1812+, DS1813+, DS1815+, DS1817+, DS1819+, DS2015xs, DS216+, DS216+II, DS218+, DS2411+, DS2413+, DS2415+, DC2419+, DS3615xs, DS3617xs, DS411+II, DS412+, DS415+, DS416play, DS418play, DS620slim, DS712+, DS713+, DS716+, DS716+II, DS718+, DS916+, DS918+


    * = Included SOX binaries by Ralphy, adding DSD and Opus support.
    Last edited by pinkdot; 2020-03-28 at 08:32.
    -DS718+, RPI 2 (Spotifyd/myMPD/Squeezelite),Aune S6 - Exposure 3010S2 - PMC FB1i-s
    -LmsRepack + LmsUpdate - Updated and Cleaned up Logitech Media Server 8.0.0 for Synology.

  2. #2
    Senior Member Stig Nygaard's Avatar
    Join Date
    Feb 2006
    Location
    Copenhagen
    Posts
    304

    Stability of Synology 8.0.* packages

    What are people's experiences with the new 8.0.* nightlies? Are they already to be considered stable enough for normal use for most people - like the 7.9.2 packages have been in a long time?

    And thanks (again) for your work Pinkdot :-)
    /Stig
    rockland.dk - last.fm/user/rockland - discogs.com/user/StigNygaard - flickr.com/photos/stignygaard
    Server: LMS 7.9.2 (LmsUpdate) - 0030.1578996832 @ Jan 14 2020 on Synology DS716+II. Clients: RPi3 (Max2Play, 7" touch, HiFiBerry Digi+ Pro), SB Touch, OrangeSqueeze/SqueezePlayer. Livingroom HiFi: Marantz PM6005 and F3/Lyd Audiovector 2.

    Try my Art Grabr for fetching big cover-art from various sites - And Album Linkr for a better last.fm desktop browser experience...

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,393

    LmsUpdate and LmsRepack - Synology 8.0.*packages

    > What is people's experience with the new 8.0.* nightlies? Are they

    It's awesome. It's the best. Ever.

    > already to be considered stable enough for normal use for most people -
    > like the 7.9.2 packages have been in a long time?


    I'm using it daily. I wouldn't be surprised if some issues around
    library integration cropped up. But overall it's working fine here.

    --

    Michael

  4. #4
    Senior Member Stig Nygaard's Avatar
    Join Date
    Feb 2006
    Location
    Copenhagen
    Posts
    304
    Quote Originally Posted by mherger View Post
    It's awesome. It's the best. Ever.
    :-)

    Quote Originally Posted by mherger View Post
    I'm using it daily. I wouldn't be surprised if some issues around
    library integration cropped up. But overall it's working fine here.

    Sounds good. I will try them soon. And also thanks for your continuos great work on LMS.

    /Stig
    Last edited by Stig Nygaard; 2020-03-26 at 00:05.
    /Stig
    rockland.dk - last.fm/user/rockland - discogs.com/user/StigNygaard - flickr.com/photos/stignygaard
    Server: LMS 7.9.2 (LmsUpdate) - 0030.1578996832 @ Jan 14 2020 on Synology DS716+II. Clients: RPi3 (Max2Play, 7" touch, HiFiBerry Digi+ Pro), SB Touch, OrangeSqueeze/SqueezePlayer. Livingroom HiFi: Marantz PM6005 and F3/Lyd Audiovector 2.

    Try my Art Grabr for fetching big cover-art from various sites - And Album Linkr for a better last.fm desktop browser experience...

  5. #5
    Senior Member HeadBanger's Avatar
    Join Date
    May 2010
    Location
    Ashingdon, UK
    Posts
    471
    Thanks pinkdot (and Michael of course!)!

    Working fine with my 2419+, you can add that to the Synology models supported.

    Very sad to hear that Synology are ceasing their version of LMS. I really hope that it can continue in your repack version somehow.

    Best,

    HB
    Last edited by HeadBanger; 2020-03-25 at 23:43.

  6. #6
    Junior Member
    Join Date
    Feb 2016
    Location
    NRW, Germany
    Posts
    17
    Hi.

    can I just install the v8 over my existing v7.9.2 on my Synology?
    So does it an update or will it installed as an new app?

    thx

  7. #7
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    1,158
    Quote Originally Posted by HeadBanger View Post
    Thanks pinkdot (and Michael of course!)!

    Working fine with my 2419+, you can add that to the Synology models supported.

    Very sad to hear that Synology are ceasing their version of LMS. I really hope that it can continue in your repack version somehow.

    Best,

    HB
    Thanks, will add the 2419+ to the list.

    Greetings,

    Martin
    -DS718+, RPI 2 (Spotifyd/myMPD/Squeezelite),Aune S6 - Exposure 3010S2 - PMC FB1i-s
    -LmsRepack + LmsUpdate - Updated and Cleaned up Logitech Media Server 8.0.0 for Synology.

  8. #8
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    1,158
    Quote Originally Posted by Chrischan View Post
    Hi.

    can I just install the v8 over my existing v7.9.2 on my Synology?
    So does it an update or will it installed as an new app?

    thx
    If you're running LmsUpdate, yes! You can simply install it as an update over the current installation. It will not be installed as a new app.

    Greetings,

    Martin
    Last edited by pinkdot; 2020-03-26 at 03:50.
    -DS718+, RPI 2 (Spotifyd/myMPD/Squeezelite),Aune S6 - Exposure 3010S2 - PMC FB1i-s
    -LmsRepack + LmsUpdate - Updated and Cleaned up Logitech Media Server 8.0.0 for Synology.

  9. #9
    Junior Member
    Join Date
    Mar 2020
    Posts
    3

    Synology 216+ also confirmed stable with LmsRepack-x86_64-8.0.0-1584980762.spk

    works very nice for me. Hopefully you'll continue to support the Synology packages.

  10. #10
    Senior Member
    Join Date
    Sep 2017
    Posts
    138

    LMS Update

    Hi,

    When I go the 1812+ LMS Update link it only has the LMS Repack version. Is there an LMS Update version available?
    Last edited by grimmace92; 2020-03-26 at 22:07.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •