Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,394

    pCP: "Missing WWWROOT"

    I brought my pCP based controller home from the office. Plugged it in,
    and it doesn't re-boot. It stops with "Missing WWWROOT". Any idea what I
    could do there?

    --

    Michael

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,912
    All you did is move it? hmmm. Doesn't make sense.

    About the only way for that to happen is if pcp-6.0.0-www.tcz is not loaded.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,394

    pCP: "Missing WWWROOT"

    > About the only way for that to happen is if pcp-6.0.0-www.tcz is not
    > loaded.


    How could I verify/investigate that? Or is it not worth it?... That
    thing is quickly set up.

    But as it's the same unit that caused problems during the upgrade I was
    wondering whether that SD card is about to give up its ghost after about
    three years of faithful, daily services...

    --

    Michael

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,912
    Easiest way is with a keyboard and monitor. You can run 'mount' and see if that extension is mounted.

    How many times have you tried to boot it? What kind of pi is it? I have occasionally seen on a pi zero where during boot the kernel cannot create loop devices dynamically fast enough. But I've been running a zero on 4.19.105 and have not seen that. The correction in that case is to statically create the loop mounts on the kernel command line.

    Add to cmdline.txt
    max_loop=xxx (Normally 100 is plenty of loop devices)
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,394

    pCP: "Missing WWWROOT"

    > Easiest way is with a keyboard and monitor. You can run 'mount' and see
    > if that extension is mounted.


    pcp-6.0.0-www.tcz is mounted on /tmp/tcloop/pcp-6.0.0.-www. But it's
    almost empty. Only has a few libedit related files/links in there.

    > How many times have you tried to boot it?


    5-10x

    > What kind of pi is it? I


    Pi 2B

    > Add to cmdline.txt
    > max_loop=xxx (Normally 100 is plenty of loop devices)


    That didn't help.

    --

    Michael

  6. #6
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,912
    Sounds like the extension is corrupted.....but that would have happened after download.

    The MD5 is only checked at download.....it does not get checked at each boot.

    You can try to download the file from the repo manually and copy to the card.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,394

    pCP: "Missing WWWROOT"

    > You can try to download the file from the repo manually and copy to the
    > card.


    That indeed did improve the situation. But then the network adapter
    still wasn't found, then the soundcard, then... eventually I started
    from scratch and am back in business now. Thanks!

    --

    Michael

  8. #8
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,912
    Must have driven through a magnetic x-ray storm on the way home
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  9. #9
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,394

    pCP: "Missing WWWROOT"

    > Must have driven through a magnetic x-ray storm on the way home

    Now that you mention it!...

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •