Home of the Squeezebox™ & Transporter® network music players.
Page 55 of 55 FirstFirst ... 545535455
Results 541 to 549 of 549
  1. #541
    This is useful but there was a post somewhere that talked about doing a RESET on a container which brought old setting sover. It worked like a charm, but I can't find it now?

  2. #542
    Junior Member
    Join Date
    Sep 2021
    Posts
    3
    Quote Originally Posted by Huey11 View Post
    Been awhile since I ran it on kubernetes. Had to keep up with changes too much to my liking so switched back to simple docker stack. But this was the config I used which was working perfectly. I used traefik and metal as load balancer though. That might make a difference.
    Well, I'm using about 45 other services on the kubernetes cluster, so I can't just change the nginx-ingress to traefik. I'll check your config and see what is different from mine.
    I too have lms running in docker-compose with traefik on my media server (dedicated NUC) - but I would like to save the produced CO2 by that nuc by running it straight on my server.

  3. #543
    Quote Originally Posted by Huey11 View Post
    Been awhile since I ran it on kubernetes. Had to keep up with changes too much to my liking so switched back to simple docker stack. But this was the config I used which was working perfectly. I used traefik and metal as load balancer though. That might make a difference.

    Hi Haley, changed the tag to code in the original reply, so should be better formatted. Added it as attachment here as well.
    Attached Files Attached Files

  4. #544
    Junior Member
    Join Date
    Sep 2021
    Posts
    3
    Quote Originally Posted by Huey11 View Post
    Hi Haley, changed the tag to code in the original reply, so should be better formatted. Added it as attachment here as well.
    Thanks! That helps

  5. #545
    Junior Member
    Join Date
    Nov 2016
    Posts
    12

    Wokrs great on OpenWrt 21.02.0 - LMS 8.2.1 ARM64

    TRY with SUCCESS on 21.02.0 (and update of dockerd docker docker-compose luci-dockerman)
    MVEBU ARM64 EspressoBin-Ultra...

    Code:
    root@ultra:~# cat /etc/config/dockerd
    # The following settings require a restart of docker to take full effect, A reload will only have partial or no effect:
    # bip
    # blocked_interfaces
    # extra_iptables_args
    # device
    
    config globals 'globals'
    #	option alt_config_file '/etc/docker/daemon.json'
    	option enable '1'
    	option data_root '/srv/docker/'
    #	option data_root '/opt/docker/'
    	option log_level 'warn'
    	option iptables '1'
    	list hosts 'unix:///var/run/docker.sock'
    #	option bip '172.18.0.1/24'
    #	option fixed_cidr '172.17.0.0/16'
    #	option fixed_cidr_v6 'fc00:1::/80'
    #	option ipv6 '1'
    #	option ip '::ffff:0.0.0.0'
    #	list dns '172.17.0.1'
    #	list registry_mirrors 'https://<my-docker-mirror-host>'
    	list registry_mirrors 'https://hub.docker.com'
    	option remote_endpoint '0'
    #	option bridge 'br-container'
    
    # Docker ignores fw3 rules and by default all external source IPs are allowed to connect to the Docker host.
    # See https://docs.docker.com/network/iptables/ for more details.
    # firewall config changes are only additive i.e firewall will need to be restarted first to clear old changes,
    # then docker restarted to load in new changes.
    config firewall 'firewall'
    	option device 'docker0'
    	list blocked_interfaces 'wan'
    #	option extra_iptables_args '--match conntrack ! --ctstate RELATED,ESTABLISHED' # allow outbound connections


    Code:
    root@ultra:~# cat /root/LMS/docker-compose.yml 
    version: '3.5'
    volumes:
      gmusic:
    	driver: local
    	driver_opts:
    	  type: nfs
    	  o: "addr=10.4.2.25,nolock,soft,rw"
    	  device: ":/GDATA02/MUSIQUES"
    services:
      lms:
    	container_name: lms
    	image: lmscommunity/logitechmediaserver:stable
    	volumes:
    	  - /srv/SHARE/LMS/CONFIG:/config:rw
    	  - /srv/SHARE/MUSIC:/music:ro
    	  - /srv/SHARE/LMS/PLAYLIST:/playlist:rw
    	  - /etc/localtime:/etc/localtime:ro
    	  - /etc/timezone:/etc/TC:ro
    	  - gmusic:/gmusic:ro
    #    ports:
    #      - 9002:9002/tcp
    #      - 9090:9090/tcp
    #      - 3483:3483/tcp
    #      - 3483:3483/udp
    	restart: always
    	environment:
    	  - HTTP_PORT=9000
    	  - PUID=1000
    	  - PGID=1000
    	network_mode: host

    Code:
    root@ultra:~# docker-compose -f /root/LMS/docker-compose.yml up --no-start
    Building with native build. Learn about native build in Compose here: https://docs.docker.com/go/compose-native-build/
    Recreating lms ... done
    FIX : I had to create a missing file which link to a non existing /tmp/localtime

    Code:
    touch /etc/localtime

    Then... http://ultra:9000 and LMS is UP and Works fine (look to be faster than with LXC)



    Original https://forum.openwrt.org/t/docker-e.../30?u=erdoukki

  6. #546
    Junior Member
    Join Date
    Sep 2021
    Posts
    24
    I am running LMS 8.2.1 on a docker using recommendations by optimumchaos on page 47. https://forums.slimdevices.com/showt...for-LMS/page47

    How do you upgrade to the latest version 8.3.0?

    Recently I robooted my NAS and now I am unable to connect to LMS [IP address of NAS]:9000.

    Using putty, how do you (a) check whether LMS service is running, (b) if not running, how do you restart the service, (c) how to auto start LMS service every time NAS is rebooted?

  7. #547
    Junior Member
    Join Date
    Sep 2021
    Posts
    24
    Quote Originally Posted by viperrabbit View Post
    I am running LMS 8.2.1 on a docker using recommendations by optimumchaos on page 47. https://forums.slimdevices.com/showt...for-LMS/page47

    How do you upgrade to the latest version 8.3.0?

    Recently I robooted my NAS and now I am unable to connect to LMS [IP address of NAS]:9000.

    Using putty, how do you (a) check whether LMS service is running, (b) if not running, how do you restart the service, (c) how to auto start LMS service every time NAS is rebooted?

    Problem solved, based on my own readings, not sure if it is correct. Kindly correct me if I am wrong.

    $ sudo docker stop [container]
    $ sudo docker rm [container]
    <install LMS> ... this time I run lmscommunity/logitechmediaserver:dev

    Still have not figured out how to auto restart LMS every time NAS is rebooted.

  8. #548
    Senior Member tfec's Avatar
    Join Date
    Oct 2005
    Location
    Germany
    Posts
    263
    Quote Originally Posted by viperrabbit View Post
    Still have not figured out how to auto restart LMS every time NAS is rebooted.
    Well, on my QNAP I'm using portainer and there I'm able to set the restart-policy to always. Also you can have a look at the docker-docs.
    1x Docker on QNAP TS-453B as LMS | 1x Raspberry Pi Zero W +moOde 8.0 UPnP as USB-Player + TEAC UD-501 USB-DAC + Phonitor Mini Headphone Amplifier + AKG K812 headphones | 2x SqueezeBox Classic | 2x Squeezbox Radio | 1x Raspberry Pi with HiFimeDIY ES9023 DAC +PiCorePlayer 8.0 | 1x Google Chromecast Audio with Arcam FMJ A22 + B&W Nautilus 805 | 1x Google Chromecast Audio with Philips Fidelio DS9000/12 | 1x Squeezelite on MacBook Pro Catalina

  9. #549
    Junior Member
    Join Date
    Nov 2020
    Posts
    5
    Quote Originally Posted by viperrabbit View Post
    Problem solved, based on my own readings, not sure if it is correct. Kindly correct me if I am wrong.

    $ sudo docker stop [container]
    $ sudo docker rm [container]
    <install LMS> ... this time I run lmscommunity/logitechmediaserver:dev

    Still have not figured out how to auto restart LMS every time NAS is rebooted.
    You can define a systemd unit like this:
    https://github.com/docker/compose/is...ment-302813256

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •