Home of the Squeezebox™ & Transporter® network music players.
Page 63 of 64 FirstFirst ... 135361626364 LastLast
Results 621 to 630 of 634
  1. #621
    Senior Member
    Join Date
    Sep 2009
    Location
    Norway
    Posts
    342
    Hi

    Is it a good idea to create a new thread called for example "LMS on Synology NAS with Docker container" and make it a STICKY in the LMS part of the forum (here: https://forums.slimdevices.com/forum...h-Media-Server) ?

    The sticky should (please) contain the setup instructions + how to keep it updated.

    Best regards,
    Claus

  2. #622
    Senior Member
    Join Date
    Jan 2016
    Location
    Germany
    Posts
    243
    [QUOTE=BramWithaar;1031573]
    Quote Originally Posted by Slot View Post
    ...
    I'm having the same Timezone/time problems with 'lmscommunity/logitechmediaserver:stable' on my just installed pi4 with raspbian.
    I'm also using the -v "/etc/localtime":"/etc/localtime":ro \ construct.

    When i run "mscommunity/logitechmediaserver:8.1.2" the container starts without problem.
    Haven't tried other, newer, versions yet, but there seems to be a problem with 'stable'
    After getting Docker up and running on my WD MyCloud EX2 Ultra NAS, I was now able to successfully install the LMS container as well.

    However, I have the same timezone problem with LMS 8.2, while LMS 8.1.2 works fine for me.

    Is there a workaround for this to get the latest version of LMS working?

    This is my docker install script:
    Code:
    docker run -it \
          -v "/shares/config":"/config":rw \
          -v "/shares/music":"/music":ro \
          -v "/shares/playlist":"/playlist":rw \
          -v "/etc/localtime":"/etc/localtime":ro \
          -v "/etc/timezone":"/etc/timezone":ro \
          -p 9002:9002/tcp \
          -p 9090:9090/tcp \
          -p 3483:3483/tcp \
          -p 3483:3483/udp \
          -e HTTP_PORT=9002 \
          lmscommunity/logitechmediaserver:stable
    Last edited by piPlayer; 2022-07-12 at 23:09.

  3. #623
    Watcher of the Windows build
    Join Date
    Mar 2006
    Location
    NYC
    Posts
    1,273
    The LMS 8.3 download page has been updated with new beta releases, but the lmscommunity/logitechmediaserver docker development version image is 9 days old.

  4. #624
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,776

    'Official' docker container for LMS?

    > The LMS 8.3 download page has been updated with new beta releases, but
    > the lmscommunity/logitechmediaserver docker development version image is
    > 9 days old.


    Thanks for the heads up! I had done a full round of updates (macOS host,
    Linux VM, Jenkins, Docker...) a few days ago. I was surprised not to see
    any failure. Turns out Jenkins didn't catch the Docker upload failure,
    reporting success. But that should be fixed now. Thanks again!

  5. #625
    Junior Member
    Join Date
    Oct 2022
    Posts
    4
    Hello

    I just installed latest version of docker Lms and have one problem and one question.
    First I want to use it locally with integrated sound card so installed local player.
    But it doesn't work. I have error
    Code:
    /config/cache/InstalledPlugins/Plugins/LocalPlayer/Bin/squeezelite-x86-64: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory
    I should pass through my sound card or something else to start local player ?
    Question:
    I'm trying to sign it into mysqueeze account but after writing my login and password nothing happens. How Lms should behave after sign in ?

  6. #626

    Mediaplayer fails to connect

    Hi,
    I've tried to setup the official docker container v.8.3 in Rancher 2.6. Everything works except the most important thing connecting to my mediaplayer ( Transporter ).
    Since this container seems not supports ping I'm not able to see if the container sees the mediaplayer.
    Is there something I've missed?
    Thanks in advance, for the help.

    Part of container yaml file
    ports:
    - containerPort: 9000
    hostIP: 192.168.2.145
    hostPort: 9000
    name: lms-frontend
    protocol: TCP
    - containerPort: 9090
    hostIP: 192.168.2.145
    hostPort: 9090
    name: lms-services
    protocol: TCP
    - containerPort: 3483
    hostIP: 192.168.2.145
    hostPort: 3483
    name: lms-tcp
    protocol: TCP
    - containerPort: 3483
    hostIP: 192.168.2.145
    hostPort: 3483
    name: lms-udp
    protocol: UDP

  7. #627
    Junior Member
    Join Date
    Aug 2010
    Posts
    3
    Quote Originally Posted by HarryPotter View Post
    Yes, its all set to German. The web interface is displayed in German as well.

    The screensaver date is displayed like this:

    Tuesday, 22. December 2020

    I can change the format of the date display on the screensaver. But If I change the language , its changed everywhere, but not on the screensaver date, that one stays English.
    Was facing a similar issue recently, Logitechmediaserver language set to German and working fine (using the "official" community image lmscommunity/logitechmediaserver)
    But screensaver of my Squeezebox Classic showing the date in english format ("Tuesday", and not "Dienstag") while in screensaver mode

    Reason: the screensaver does not derive its format from the language selected within Logitechmediaserver, but from the locale used on the underlying Linux system

    My solution:
    Use of the custom-init.sh script functionality the official docker container does luckily provide + change of two language related environment variables in docker compose
    This will generate German locale on Linux level at start of container, and set it as default locale
    Afterwards the screensaver will show the date in German format as expected

    Docker compose:
    Code:
        environment:
          - LANGUAGE=de_DE.UTF-8
          - LANG=de_DE.UTF-8
    custom-init.sh, to be placed into the root folder of the /config directory
    Code:
    #!/bin/sh
    apt-get update -qq
    apt-get install --no-install-recommends -qy locales
    sed -i -e 's/# en_US.UTF-8 UTF-8/en_US.UTF-8 UTF-8/' /etc/locale.gen
    sed -i -e 's/# de_DE.UTF-8 UTF-8/de_DE.UTF-8 UTF-8/' /etc/locale.gen
    echo 'LANG="de_DE.UTF-8"'>/etc/default/locale
    dpkg-reconfigure --frontend=noninteractive locales
    update-locale LANG=de_DE.UTF-8

  8. #628
    Quote Originally Posted by JohnnyPlayer View Post
    Hi,
    I've tried to setup the official docker container v.8.3 in Rancher 2.6. Everything works except the most important thing connecting to my mediaplayer ( Transporter ).
    Since this container seems not supports ping I'm not able to see if the container sees the mediaplayer.
    Is there something I've missed?
    Thanks in advance, for the help.

    Part of container yaml file
    ports:
    - containerPort: 9000
    hostIP: 192.168.2.145
    hostPort: 9000
    name: lms-frontend
    protocol: TCP
    - containerPort: 9090
    hostIP: 192.168.2.145
    hostPort: 9090
    name: lms-services
    protocol: TCP
    - containerPort: 3483
    hostIP: 192.168.2.145
    hostPort: 3483
    name: lms-tcp
    protocol: TCP
    - containerPort: 3483
    hostIP: 192.168.2.145
    hostPort: 3483
    name: lms-udp
    protocol: UDP

    If you're running on Kubernetes you'll need to create services for the ports and expose them to the outside world - has this been done? Docs link https://kubernetes.io/docs/tutorials...tions-service/

    Mark

  9. #629
    Junior Member
    Join Date
    Oct 2022
    Posts
    4
    Quote Originally Posted by bpbiszkopt View Post
    Hello

    I just installed latest version of docker Lms and have one problem and one question.
    First I want to use it locally with integrated sound card so installed local player.
    But it doesn't work. I have error
    Code:
    /config/cache/InstalledPlugins/Plugins/LocalPlayer/Bin/squeezelite-x86-64: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory
    I should pass through my sound card or something else to start local player ?
    Question:
    I'm trying to sign it into mysqueeze account but after writing my login and password nothing happens. How Lms should behave after sign in ?
    Answering to my first question, after starting docker container we need to pass through sound card, then install on container libasound2 and local player works ok.
    About second problem I leave it for now.

    But i have another question/problem how to pass through USB dac devices.
    I read about Edo player but if I understand correctly it is for Lms player not for docker image.

    I have amp that have input from usb c, so I can send music to it by usb and it works. If I setup it on my pc it works ok. But how to pass through it to docker lms ?
    If amp is disconnected it is recognized as serial convert after turning on it is recognized as audio device and device is recognized as snd devices so if I pass through whole /dev/snd I see it in my container but I have problem with choosing correct output device. In host it it discovered by pulse audio as analog output, but in container pulse audio isn't installed so I don't know how to choose correct output.

  10. #630
    Senior Member
    Join Date
    Sep 2009
    Location
    Norway
    Posts
    342
    Hi bpbiszkopt

    Presumably, when running LMS in a Docker container, you have it installed on a NAS (e.g. Synology, QNAP)

    Are you trying to run LMS on a PC and stream music directly from LMS to a USB port on the PC?

    Not sure what EDO Player is, but I know that the Squeezebox Touch can be installed with EDO kernel extension for 192 kHz support on the USB port.

    If you are using a piCorePlayer, then:

    Select [Squeezelite Settings] > “Audio output device settings” > “USB audio”.
    Click [Save].
    This will set “Audio output device settings” to “USB audio” and set “Change Squeezelite settings” to default values.

    See more here (Topping E30 is just an example): https://docs.picoreplayer.org/projec...g-e30-usb-dac/

    If you're running LMS from a PC and wish to use it as a player as well, please consider to install the Squeezelite-X on your PC.
    In Squeezelite-X, one of the 'players' is your PC. I believe this player will play to your (default) soundcard on the PC.
    ... Let me know if any of this is helpful, or where am I missing the point?

    Kind regards,
    Claus
    Last edited by cfuttrup; 2022-11-21 at 13:06.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •