Home of the Squeezebox™ & Transporter® network music players.
Page 8 of 12 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 115
  1. #71
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,743
    Quote Originally Posted by bpa View Post

    although Kremel hair tonic would be wasted on me.
    Most likely past its sell by date

  2. #72
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,622

    ByGolly Old Time Radio

    > Michael's fix works OK for http, https both proxied and direct.
    I've committed it to the 8.0 branch. Please give the next build another try.

    --
    --

    Michael

  3. #73
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,851
    Quote Originally Posted by mherger View Post
    > Michael's fix works OK for http, https both proxied and direct.
    I've committed it to the 8.0 branch. Please give the next build another try.
    OK - the OP will want to know when mysqueezebox.com will have the fix.

  4. #74
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,897
    Quote Originally Posted by bpa View Post
    OK - the OP will want to know when mysqueezebox.com will have the fix.
    Does that particular stream also work on http rather than https?
    If not - is my memory right that mysqueezebox cannot handle it for that reason?
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin, AllZIC Radio, Caroline Flashback, Cesky rozhlas, Dandelion Radio, Europa Radio Jazz, Frequence3, FSK, JukeRadio, KlassikRadio.de, Linn Radio, Mother Earth, Naim Radio, Nova.fr, RadioBlues Flac, Radio Espace, Radio Swiss, RTE Ireland, Somehow Jazz, Supla Finland

  5. #75
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,976
    Quote Originally Posted by mherger View Post
    > Michael's fix works OK for http, https both proxied and direct.
    I've committed it to the 8.0 branch. Please give the next build another try.

    --
    --

    Michael
    Just updated LMS. The stream doesn't work from the favourite I had stored. More info still reports the stream as MP3.

    Sent from my Pixel 3a using Tapatalk

  6. #76
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,976
    Quote Originally Posted by slartibartfast View Post
    Just updated LMS. The stream doesn't work from the favourite I had stored. More info still reports the stream as MP3.

    Sent from my Pixel 3a using Tapatalk
    The second time I tried it worked but how can I be sure the fix worked? The stream would always randomly play.

    Sent from my Pixel 3a using Tapatalk

  7. #77
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,851
    Quote Originally Posted by Paul Webster View Post
    Does that particular stream also work on http rather than https?
    If not - is my memory right that mysqueezebox cannot handle it for that reason?
    http URL plays OK with mplayer.

    I think the mysqueezebox problem is due to the LMS bug with two out-of-sync cache entries.

  8. #78
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,851
    Quote Originally Posted by slartibartfast View Post
    The second time I tried it worked but how can I be sure the fix worked? The stream would always randomly play.
    If it always "randomly" played (i.e. it sometimes failed) - then keep trying, include LMS restarts to clear cache - no failure would indicate fix worked.

    To be absolutely sure, enable network.protocol.slimproto logging to INFO, try to play the stream and look in the log for this message
    Code:
    Slim::Player::Squeezebox::stream_s (542) stream_s called: format: mp3 url: https://my.radiolize.com/radio/8440/radio.mp3
    If the format is mp3 - then it didn't work.

  9. #79
    Senior Member
    Join Date
    Jul 2009
    Posts
    585
    Quote Originally Posted by bpa View Post
    If it always "randomly" played (i.e. it sometimes failed) - then keep trying, include LMS restarts to clear cache - no failure would indicate fix worked.

    To be absolutely sure, enable network.protocol.slimproto logging to INFO, try to play the stream and look in the log for this message
    Code:
    Slim::Player::Squeezebox::stream_s (542) stream_s called: format: mp3 url: https://my.radiolize.com/radio/8440/radio.mp3
    If the format is mp3 - then it didn't work.
    I tried it with your (bpa) fixes:
    When using http, it works; I get audio and in logging:
    Code:
    [20-03-22 12:11:16.9882] Slim::Player::Squeezebox::stream_s (542) stream_s called: format: aac url: http://my.radiolize.com/radio/8440/radio.mp3
    When using https, there is no audio and in loggin, I only see:
    Code:
    [20-03-22 12:15:02.7004] Slim::Player::Squeezebox::stream (1049) strm-q
    [20-03-22 12:15:02.7053] Slim::Player::Squeezebox::stream (1049) strm-q
    [20-03-22 12:15:37.5788] Slim::Player::Squeezebox::stream (1049) strm-q
    I will now try LMS update to newest LMS8 version and try Michaels fix.

    P.S. I tried both on LMS8; player: SB3 (Classic) and SqueezeESP32 - both acted the same
    LMS 8.x on RasPi4 (running along with OMV and AdGuard)
    Player: 5 x Squeezebox Classic, Slimp3, SqueezeAmp
    2nd System: PiCorePlayer (and LMS) on Pi Zero

  10. #80
    Senior Member
    Join Date
    Jul 2009
    Posts
    585
    I updated now to LMS Logitech Media Server Version: 8.0.0 - 1584870543 @ Sun Mar 22 11:19:24 CET 2020

    http stream works; logging:
    Code:
    [20-03-22 12:37:08.2290] Slim::Player::Squeezebox::stream_s (542) stream_s called: format: aac url: http://my.radiolize.com/radio/8440/radio.mp3
    https stream does NOT work for me; logging:
    Code:
    [20-03-22 12:38:56.1447] Slim::Utils::Scanner::Remote::__ANON__ (192) Error: Can't connect to remote server to retrieve playlist for, https://my.radiolize.com/radio/8440/radio.mp3: Connect timed out: Bad file descriptor.
    I tried the https stream in 3 ways: 1) play from 'load url' ; 2) play from Favorites; 3) play via search radio station 'bygolly'; all give the above log message
    LMS 8.x on RasPi4 (running along with OMV and AdGuard)
    Player: 5 x Squeezebox Classic, Slimp3, SqueezeAmp
    2nd System: PiCorePlayer (and LMS) on Pi Zero

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •