Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Jul 2012
    Posts
    12

    USB Audio - Avantree Leaf in picoreplayer

    I have an Avantree Leaf USB Audio Bluetooth adaptor I would like to use with PiCoreplayer. It behaves like an ordinary USB audio device and not a Bluetooth device. It pairs with my headphones but no sound. It work on Windows and Android by just plugging it in. I am using picoreplayer V6 on a PI 3.

    dmesg gives the following:

    [ 2.078199] usb 1-1.2: new full-speed USB device number 4 using dwc_otg
    [ 2.224890] usb 1-1.2: New USB device found, idVendor=0a12, idProduct=1004, bcdDevice= 5.47
    [ 2.224896] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    [ 2.298550] hid-generic 0003:0A12:1004.0001: input,hiddev96,hidraw0: USB HID v1.11 Device [Avantree Leaf] on usb-3f980000.usb-1.2/input3

    Could the space in the device name be causing a problem?

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,906
    What’s in the Bluetooth log?
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Jul 2012
    Posts
    12
    Quote Originally Posted by paul- View Post
    What’s in the Bluetooth log?
    It is a USB audio device to the OS, not Bluetooth.

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,285
    Quote Originally Posted by tcb View Post
    It is a USB audio device to the OS, not Bluetooth.
    Are you sure some part of BT is not showing ?
    The code idVendor=0a12, idProduct=1004, shows it to be CSR bluetooth dongle. See https://elinux.org/RPi_USB_Bluetooth_adapters

  5. #5
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,906
    Looking at the Avantree website, that’s how these work. They are USB audio adapters. Bluetooth pairing is handled internally.

    So what shows up if you expand the more> but the output setting on the squeezelite page.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  6. #6
    Junior Member
    Join Date
    Jul 2012
    Posts
    12
    Quote Originally Posted by paul- View Post
    Looking at the Avantree website, that’s how these work. They are USB audio adapters. Bluetooth pairing is handled internally.

    So what shows up if you expand the more> but the output setting on the squeezelite page.
    Thank you,

    It shows this but the device name is Avantree Leaf and not just Leaf. If I select any of these I get silence. I have a USB DAC that works OK without any settings but I want to use it wireless.

    null
    default
    plugequal
    equal
    sysdefault:CARD=Leaf
    front:CARD=Leaf,DEV=0
    surround21:CARD=Leaf,DEV=0
    surround40:CARD=Leaf,DEV=0
    surround41:CARD=Leaf,DEV=0
    surround50:CARD=Leaf,DEV=0
    surround51:CARD=Leaf,DEV=0
    surround71:CARD=Leaf,DEV=0
    iec958:CARD=Leaf,DEV=0
    hw:CARD=Leaf,DEV=0
    plughw:CARD=Leaf,DEV=0

  7. #7
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,906
    The name shown is what the device is reporting to Alsa, it has absolutely no relation to the brand name. One of these is likely what you need to set.

    Quote Originally Posted by tcb View Post
    front:CARD=Leaf,DEV=0
    iec958:CARD=Leaf,DEV=0
    hw:CARD=Leaf,DEV=0
    Make sure you have selected "USB Audio" in the drop down box at the top, then press the card control button. There are instructions on how to check volume. USB devices have a wide variety of mixer setups..... easily adjusted with a ssh session and alsamixer. Then just be sure to press the save button in the interface.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #8
    Junior Member
    Join Date
    Jul 2012
    Posts
    12
    Quote Originally Posted by paul- View Post
    The name shown is what the device is reporting to Alsa, it has absolutely no relation to the brand name. One of these is likely what you need to set.

    Make sure you have selected "USB Audio" in the drop down box at the top, then press the card control button. There are instructions on how to check volume. USB devices have a wide variety of mixer setups..... easily adjusted with a ssh session and alsamixer. Then just be sure to press the save button in the interface.
    Got it working, thanks. hw:CARD=Leaf,DEV=0 worked but the sound was turned right down in alsamixer. I have adjusted alsamixer using ssh but how do I make it stick with the web interface?

    Found the save button in the card control page so all working now, thanks.
    Last edited by tcb; 2020-03-08 at 07:47.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •