Home of the Squeezebox™ & Transporter® network music players.
Page 30 of 114 FirstFirst ... 2028293031324080 ... LastLast
Results 291 to 300 of 1138
  1. #291
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,370
    Not dmesg output, there is a show log option on the bluetooth page.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  2. #292
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,370
    Quote Originally Posted by kidstypike View Post
    However, making the URL a favourite doesn't seem to accomplish anything usable. There are no "play" or "add" buttons alongside the favourite to start it playing,
    I have a play button by mine.... but I've seen it both ways. I'm not sure why LMS does that. It's not repeatable.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #293
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,854
    Quote Originally Posted by paul- View Post
    I have a play button by mine.... but I've seen it both ways. I'm not sure why LMS does that. It's not repeatable.
    Can confirm, I redid the steps and named the new favourite "Bluetooth2", which works no problem.

    Name:  Bluetooth04.jpg
Views: 332
Size:  35.6 KB
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.1.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 6.1.0/pi screen/Allo Boss DAC Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Squeezebox Radio

    Spares - 2xTouch, 1xSB3, 1xRadio, 7xRPi

  4. #294
    Junior Member
    Join Date
    Apr 2020
    Posts
    10
    Quote Originally Posted by paul- View Post
    Not dmesg output, there is a show log option on the bluetooth page.
    My bad. Here it is while desktop connected and playing. Thx again.
    Attached Files Attached Files

  5. #295
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,370
    Okay, that looks fine......go to Diagnostic then Logs in pCP, there is an option to show all logs. Look for the pcp-streamer log. One thing to note, when streaming like this, there can be a lag.... I’ve seen it as high as 10 seconds.

    Also, make sure you have the Bluetooth device connected and playing before you play the stream in LMS.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  6. #296

    Bluetooth Direct Play

    Hi, I have been running PcP since version 4 on a RPi1B+ and a DAC card and had no issues at all using it as a squeezebox. I am trying to add Bluetooth Direct Play to this and have upgraded to PcP6.0.0.006 but not having any joy.

    I have completed a clean install of PcP-6.0.0 and then followed the instructions in this thread to make the patch update to 6.0.0.006. I run WiFi through an Edimax 11n USB adapter (which has worked for several years) and now added Bluetooth through a USB adapter from piHut (CSR 4.0). I am trying to send audio from an Asus Nexus 7 tablet.

    I can stream audio from LMS to PcP without issue
    I can pair and connect PcP to the tablet without issue.
    The tablet can pair and direct play audio to a soundbar in another room.

    My only issue seems to be that I get no audio when playing a source on the tablet. I can see from the PcP logs that an a2dpsink connection is open.

    Code:
    pCP Bluetooth extension build:0006
    Starting BT Controller
    USB Bluetooth Hardware Address: 00:1A:7D:DA:71:11
    Starting pCP BT Pairing Agent
    BT Controller Ready
    04-10 15:16 BST INFO     ------------Starting pCP BT Speaker Daemon v6.0.0.0006------------
    04-10 15:16 BST INFO     Resetting asound.conf.
    04-10 15:16 BST INFO        Removing bt_ from asound.conf
    04-10 15:16 BST INFO     Current contents of /usr/local/etc/pcp/pcp-bt.conf.
    04-10 15:16 BST INFO        30:85:A9:E1:A7:0A#Nexus 7#10000#2
    04-10 15:16 BST INFO     Starting connection signal handlers.
    04-10 15:16 BST INFO     ---- Caught Connect signal ----
    04-10 15:16 BST INFO        MAC:30:85:A9:E1:A7:0A
    04-10 15:16 BST INFO        TRANSPORT:a2dpsnk
    I've also tried stopping Squeezelite completely before making the bluetooth connection but this made no difference. All help greatly appreciated.

    Setup:
    RPi B+: USB WiFI adapter, USB Bluetooth Adapter, "HiFiBerry DAC+ Light" compatible DAC

  7. #297
    Junior Member
    Join Date
    Apr 2020
    Posts
    10
    Quote Originally Posted by paul- View Post
    Okay, that looks fine......go to Diagnostic then Logs in pCP, there is an option to show all logs. Look for the pcp-streamer log. One thing to note, when streaming like this, there can be a lag.... I’ve seen it as high as 10 seconds.

    Also, make sure you have the Bluetooth device connected and playing before you play the stream in LMS.
    Here is the log... I do see an error in it: arecord: main:828: audio open error: No such file or directory
    Related?
    Attached Files Attached Files

  8. #298
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,941
    I thought I'd give this Bluetooth streaming a try.

    One thing I saw that I suspect only causes a presentation problem - but perhaps something else goes wrong later as well.

    I tried to stream from an iPad - and it has the default name that iOS created for it ... something like
    Paul’s iPad
    Note - the apostrophe is ’ (#2019) not ' (#27).

    It results in the display of the device information being broken on the pCP Bluetooth page.

    However, I also was not able to get sound to come out of the LMS player that I was trying to send to - but I have not delved deeper on that yet.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  9. #299
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,854
    Quote Originally Posted by Paul Webster View Post
    I thought I'd give this Bluetooth streaming a try.

    One thing I saw that I suspect only causes a presentation problem - but perhaps something else goes wrong later as well.

    I tried to stream from an iPad - and it has the default name that iOS created for it ... something like
    Paul’s iPad
    Note - the apostrophe is ’ (#2019) not ' (#27).

    It results in the display of the device information being broken on the pCP Bluetooth page.

    However, I also was not able to get sound to come out of the LMS player that I was trying to send to - but I have not delved deeper on that yet.
    Make sure the volume level on your iPad is at full?

    I had to change my phone's BT name from Moto (G4) to just Moto, pCP wouldn't allow the brackets.
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.1.0 - 74K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 6.1.0/pi screen/Allo Boss DAC Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Squeezebox Radio

    Spares - 2xTouch, 1xSB3, 1xRadio, 7xRPi

  10. #300
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,370
    The name should not be a problem since to change the dropdown to "Streamer" you have to save, and the web interface will make you remove the bad characters.

    Also - S_i_O, You are not running the latest bluetooth packages, please update.

    ---------For everyone, I just pushed another Bluetooth patch------
    Fixed in this version

    • a2dp profile switching, if your device connects as a ad2p-source, but you have it set as a "Player" or "Streamer", we should force your device to switch profiles to a2dp-sink.
    • Fixed some issues with odd characters in names coming from bluetooth devices



    Upgrade in this order (Order matters, otherwise you will have a permission issue, which will be corrected in this update too):
    • Bluetooth Page -> Update (You should see pcp-bt6.tcz and pcp-bluez-alsa.tcz needing upgraded)
    • When prompted for reboot, hit cancel
    • Goto Main page
    • Press - Patch Update (Both pcp-base and pcp-www-6.0.0 will be upgraded)
    • Press reboot on main page.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •