Home of the Squeezebox™ & Transporter® network music players.
Page 76 of 83 FirstFirst ... 26667475767778 ... LastLast
Results 751 to 760 of 823
  1. #751
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,499
    Quote Originally Posted by diggledude View Post
    Hi all. I'm familiar with debian based systems but lost when it comes to the workings of tinycore.

    I'm running pcp 6.1.0 and it seems cool. I've installed the ffmpeg library which should include alac. Is it possible now to recompile shairport-sync to include alac support?
    Shairport-sync requires alac to do it's thing. But it uses a bundled alac encoder, not ffmpeg.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  2. #752
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    406
    Hi

    I want to backup all my LMS config/plugin files to restore onto another PCP, so was looking for a way to copy various folders and files off PCP (I'm in a Windows environment). I know the various folder locations are under LMS > Info.
    The PCP UI has a function to upload files but not download them.

    SSH login works fine and so I tried Filezilla but it keeps saying "ECONNREFUSED - Connection refused by server".
    Any ideas?

  3. #753
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    11,825
    Quote Originally Posted by mr-b View Post
    Hi

    I want to backup all my LMS config/plugin files to restore onto another PCP, so was looking for a way to copy various folders and files off PCP (I'm in a Windows environment). I know the various folder locations are under LMS > Info.
    The PCP UI has a function to upload files but not download them.

    SSH login works fine and so I tried Filezilla but it keeps saying "ECONNREFUSED - Connection refused by server".
    Any ideas?
    I use Filezilla.

    Protocol: SFTP
    Logon Type: Ask for Password
    User: tc
    Password: whatever you used for password for the rPi
    Home: VBA 4TB (2.5) or rPi4B/pCP6.0/4TB>LMS 7.9.3>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: VBA 3TB (2.4) or rPi4B/pCP6.0/4TB>LMS 7.9.1>Touch>Benchmark DAC I, Boom, Radio w/Battery (ethernet, Radio WIFI)
    Office: Win10(64)>LMS 7.9.3>Squeezelite
    The Wild: rPi3B+/pCP4.0, hifiberry Dac+Pro, 4TB USB (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir2 (iPeng), CONTROLLER, or SqueezePlay 7.8 on Win10(64)
    Files: ripping: dbpa > FLAC; post-rip: mp3tag, PerfectTunes; Streaming: Spotify

  4. #754
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,040
    Quote Originally Posted by garym View Post
    I use Filezilla.

    Protocol: SFTP
    Logon Type: Ask for Password
    User: tc
    Password: whatever you used for password for the rPi
    I use WinSCP. Easy - looks like file Explorer.
    LMS server: O2 Joggler with Jivelite, Pi Zero W with PcP 6.0

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Fiio M6, Avantree Priva BT transmitter



    ------------------------------------------------------------------------------------

  5. #755
    Junior Member
    Join Date
    Jun 2020
    Posts
    7
    Quote Originally Posted by ralphy View Post
    Shairport-sync requires alac to do it's thing. But it uses a bundled alac encoder, not ffmpeg.
    Actually alac is optional. You have to first install the alac package and then compile with the --with-apple-alac flag. It's trivial in debian but in pcp it seems like everything is already prepackaged. The ffmpeg package implies that it installs alac so I'm just wondering if it is possible to compile from source within pcp?

  6. #756
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    406
    Quote Originally Posted by castalla View Post
    I use WinSCP. Easy - looks like file Explorer.
    Yes I went for WinSCP in the end, it worked first time and was easy to use, Filezilla just didn't want to play for some reason.

    E2A it was a bit of a pain having to manually copy all the files and folders though, but everything seemed to work when I restored them to my other PCP/LMS box.
    Has anyone thought of a LMS backup script to save them somewhere that could be triggered by a PCP UI button?
    Last edited by mr-b; 2020-06-30 at 14:00.

  7. #757
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,185
    Quote Originally Posted by Johnnysq View Post
    Hi,

    I have installed piCorePlayer6.1.0 on a Raspberry Pi 3B+.
    I have configured Bluetooth on the "Bluetooth Speaker Setup" entry (Main Page -> Bluetooth). (BT Controller is On; BT Speaker Daemon is running; BT Pairing Daemon for incoming connections is running)
    I have a BLuetooth device connected via the "Device Pairing/Selection" settings.
    So far, so good - but - I do not get the "Bluetooth Audio" entry in the drop-down list on the "Squeezelite Settings - Audio output device settings" page.

    Can somebody help me with this please?

    I did already install it twice and did the settings over.
    Note: It works with piCorePlayer5.0.0. (I did the install of piCorePlayer6.1.0 with a fresh image, no insitu update.)

    Kind regards
    Bluetooth does not work this way anymore. Bluetooth speakers will create a new squeezelite instance, and show up as a new player in LMS. If you did update from 5.0, then you should have been forced to remove bluetooth before doing the insitu update......if you did not, then remove bluetooth support, reboot, then re-install bluetooth support.

    More info is in the bluetooth thread. https://forums.slimdevices.com/showt...-x-x-Bluetooth
    Last edited by paul-; 2020-06-30 at 19:45.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #758

    HiFiBerry DAC+ Pro won't play 24/192?

    Quote Originally Posted by paul- View Post
    I would just start with a new SD card, and transfer settings over..... or at least make a backup of your card before you try an update.
    Good idea and this is the approach i took. Everything working but I can't get playback from 24 bit 192k files, get low static/feedback. Everything else plays great. Tried over ethernet too and i have several other players (not this card though) with no issues.

  9. #759
    Senior Member
    Join Date
    Sep 2006
    Posts
    622
    Quote Originally Posted by Greg Erskine View Post
    hi CatBus

    I use a JustBoom DAC all the time, so I know it works.

    1. Fresh Sd card
    2. Select JustBoom DAC/AMP (and Zero/AMP)
    3. Press Save.
    4. Reboot.

    It should be a really simple process.

    If you are still having a problem, try without 7" screen connected.

    regards
    Greg
    Sorry about the delay getting back on this.

    Another case of PEBKAC. My speakers were not switching inputs. Once that got sorted everything is great. I may have questions later about IR support, but honestly at this point I may cut my losses and just enjoy the music for a bit.

  10. #760
    Senior Member
    Join Date
    Dec 2015
    Posts
    219
    Quote Originally Posted by kbeast View Post
    Good idea and this is the approach i took. Everything working but I can't get playback from 24 bit 192k files, get low static/feedback. Everything else plays great. Tried over ethernet too and i have several other players (not this card though) with no issues.

    you could try another distro to try to isolate the issue
    maybe volumio to see if hi-res works under that OS
    rPi 3 + rasPi 7" LCD + HiFiBerry DiGi+ | rPi 2 + IQaudio DAC+ | rPi 2 + HiFiBerry DAC+ | Squeeze Box Touch | LMS on pCP
    https://www.picoreplayer.org/how_to_upgrade_lms.shtml
    Your usb device is taking too long to become ready at boot. You need to add some delay. On the extras menu, there is a bootcodes screen. Increase the value of waitusb
    https://forums.slimdevices.com/showt...-x-x-Bluetooth


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •