Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Jul 2018
    Posts
    6

    WIFI Setup Raspberry Pi 3 Model A+

    Hi I'm having a trouble connecting to the network using an Allo Boss DAC connected to a Raspi3 Model A+ with piCorePlayer.
    I followed the steps on; "How-to setup wifi on piCorePlayer without Ethernet" on the piCorePlayer help page.
    I have tried both methods (no/special characters) outlined by adding a wpa_supplicant.conf file to the BOOT disk with my WIFI credentials and country code added without success.
    I next tried to setup using a USB keyboard and monitor attached to the Raspi&Boss. The keyboard is not recognised.
    I do get a piCorePlayer setup screen but I can't interact with it. Most of the actions work fine with a DONE in green after them.
    However these lines are potential issues;
    *Checking for netusb... newpcp.cfg not found on mmcblk0pi.
    *waiting for network..........................................N o network found! Done (52).
    *there was a problem reaching sites for automatic time zones etc,........

    I cannot SSH in via Putty as I don't have an IP address for the Raspi&Boss. Remember its a Pi3 Model A+ No ethernet port for first setup.
    I have tried an Edimax WIFI dongle without success, not recognised.
    My Allo Digione player which is served by another Pi Running PiCorePlayer as a server only (Squeezelite disabled) and an O2 Joggler running Squeezeplay all work perfectly.
    I have tried with the audio optimised version, and the regular version of piCorePlayer 5.0.0 with the nightly build of LMS.
    I've been wrestling with this for some time now and am at my wits end. I don't know what to try next.
    I'd be very grateful for some help and advice. Hopefully it's a schoolboy error.

    Thanks & respect.
    Dreddguy
    Last edited by Dreddguy; 2020-02-22 at 17:22. Reason: Clarity

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,924
    How did you create the wpa_supplicant.conf Formatting is touchy. There is a sample file on the boot partition that you can rename. Then edit. Save and then put in your pi and boot.

    Don’t try the edimax with a model A, you would have to disable the onboard WiFi first.
    Last edited by paul-; 2020-02-22 at 17:08.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Jul 2018
    Posts
    6
    Quote Originally Posted by paul- View Post
    How did you create the wpa_supplicant.conf Formatting is touchy. There is a sample file on the boot partition that you can rename. Then edit. Save and then put in your pi and boot.

    Don’t try the edimax with a model A, you would have to disable the onboard WiFi first.
    I've tried a few different ways now. Including the method you described above. I have just deleted the existing wpa.supplicant.conf and replaced it with the edited sample in the Boot file. No luck. Exactly the same behaviour from the LED's. A steady red light and a rapidly flashing green light which dies after a minute. No IP address after a scan.
    Last edited by Dreddguy; 2020-02-22 at 17:56. Reason: Clarity

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,924
    What editor? Are you sure you have no special characters in your ssid and password? The file in 5.0.0 has an error in the country code field. It should not have quotes

    country=US

    What country are you in?

    Have you verified the board works with a Raspbian Image? The keyboard not working is a bit of a concern. What kind of keyboard is it?
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,747
    hi Dreddguy,

    I wrote most of the wifi software for piCorePlayer and here is the process *I* use to setup/test wifi on piCorePlayer on *my* network. I only use stand-alone wifi connected players, so if wifi doesn't work I don't have music!

    I just retested piCorePlayer v6.0.0-b9 on my RPi3A+ and RPi4B. Completely stand-alone, no ethernet, no keyboard, no monitor. It worked on both, first time.

    Code:
    1. Create new pCP image.
    2. Create wpa_supplicant.conf on boot partition.
    3. Only add 3 lines to wpa_supplicant.conf (3rd line is a blank line)
    
    ssid="ssid"
    psk="password"
    
    
    Note: I use a macro in Notepad++ to create this file. It adds an additional blank line.
    
    4. Save wpa_supplicant.conf and unmount SD card.
    5. Stick SD card into RPi and boot.
    This is the simplest method if you have a *standard* wifi network. It might only work in Australia

    regards
    Greg

  6. #6
    Junior Member
    Join Date
    Jul 2018
    Posts
    6

    Schoolboy Error

    Thank you for all your help guys. It really was a schoolboy error on my behalf. I wasn't including the apostrophes "" in my wifi credentials.
    I feel like such a dolt.
    Now to have some fun setting up and fine tuning and hopefully get to listen to my headphone rig tonight.
    I appreciate your help.
    Cheers.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •